Subject: [AVT] Overcome packet loss using duplicate packets

From: Michael Hakimi <[email-masked]>
Date: Thu, 16 Dec 2010 16:48:56 +0200

Hi,

I would like to send my media in a more reliable way.
In order to do so I am sending each packet n times.

For example, in case n=2:
Send packet no.1
Send packet no.2 + no.1
Send packet no.3 + no.2
...

In this way I can do a perfect PLC for a single packet that was lost.
Is there a standard way to do so?
Is the standard defines a way to overcome packet loss by sending
duplicate packets?

Thx in advance,
Mickey

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Thu, 16 Dec 2010 06:54:11 -0800

> Is the standard defines a way to overcome packet loss by sending

Yes, it's called RTP Forward Error Correction.

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
skype: kpfleming | jabber: [email-masked]
Check us out at www.digium.com & www.asterisk.org

---

From: "Van Caenegem, Tom (Tom)" <[email-masked]>
Date: Thu, 16 Dec 2010 23:01:10 +0100

A more efficient alternative for enhancing RTP packet transport reliability is to use RTP retransmission, where the client keeps track of any missing packet by tracking the RTP SN in the packets, and then sends a NACK to the retransmission server. See RFC 4588 and RFC 4585.
Tom 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Hakimi
Sent: donderdag 16 december 2010 15:49
To: [email-masked]
Subject: [AVT] Overcome packet loss using duplicate packets

Hi,

In this way I can do a perfect PLC for a single packet that was lost.
Is there a standard way to do so?
Is the standard defines a way to overcome packet loss by sending duplicate packets?

Thx in advance,
Mickey
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www.ietf.org/mailman/listinfo/avt