Subject: Re: [AVTCORE] Comment 4: draft-ietf-avtcore-idms-02

From: Kevin Gross <[email-masked]>
Date: Thu, 15 Dec 2011 11:29:23 -0700

My comment was trying to convey that I did not consider there to be a close
association between the SDP attributes and the XR and RTCP packets. I've
reread and now appreciate that there is for rtcp-xr:grp-sync and tcp-idms.

It is the clocksource attribute that does not have such an association. I
understand the plan is to move this into a draft Aidan is working on.

I'm OK to leave section 1.3 as is or accept Mario Montagud and Fernando
Boronat's suggested improvement.

Kevin Gross

On Thu, Dec 15, 2011 at 1:56 AM, Brandenburg, R. (Ray) van <
[email-masked]> wrote:

>  4/ Second paragraph, section 1.3. Delete "one for the RTCP XR block type
> and one for the new RTCP packet type." SDP parameters make the system work
> and are not closely associated with these protocols.
>
> I’m not sure what you mean here? The sentence is meant to indicate that
> this draft introduces two sets of SDP parameters: one for the new XR block
> type, and one for the new RTCP Packet Type (sections 9 and 10 respectively)
>
>
[F&M] We agree because both types are not defined yet. We can delete that
sentence or use an alternative like this: “This document describes two SDP
parameters for doing this, one for the RTCP XR block type and one for the
new RTCP packet type (both types will described in Sections 6 and 7,
respectively, and the associated SDP parameters are presented in Sections 9
and 10, respectively)”.

---

From: Qin Wu <[email-masked]>
Date: Fri, 16 Dec 2011 09:50:27 +0800

Hi,
----- Original Message ----- 
>From: Kevin Gross 
>To: [email-masked] 
>Sent: Friday, December 16, 2011 2:29 AM
>Subject: Re: [AVTCORE] Comment 4: draft-ietf-avtcore-idms-02

>My comment was trying to convey that I did not consider there to be a close association between the SDP attributes and the XR and RTCP packets. I've reread and now appreciate >that there is for rtcp->xr:grp-sync and tcp-idms.

[Qin]: I assume you suggest to define xr-format as follows:

                    xr-format =/ rtcp-idms                   
                    rtcp-idms = "rtcp-idms" ":" [sync-grp] CRLF
I think that's a issue needing to be fixed. Also XR and new packets share the same SDP attribute parameter "rtcp-idms".
Maybe it will be reasonable to define xr-format as follows:
                    
            xr-format =/ rtcp-xr-idms                   
            rtcp-xr-idms = "rtcp-xr-idms" ":" [sync-grp] CRLF

to distinguish from SDP Parameter for RTCP IDMS Packet Type.

As for [syn-grp], I am interested to know who generate SyncGroupId? How it is generated? Is it same as Media Stream Correlation Identifier carried in the XR or RTCP IDMS packet?
or if not, how they are mapped?

>It is the clocksource attribute that does not have such an association. I understand the plan is to move this into a draft Aidan is working on.

[Qin]: In my view, since SDP attribute for both XR and RTCP IDMS packet share the same SyncGroupId?
I think it is possible and more general to associate [syn-grp] with clocksource attribute.

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Mon, 19 Dec 2011 09:18:23 +0000

Hi Qin,

Yes, the SyncGroupID is the same as the Media Stream Correlation Identifier. During session setup it is generated as a random number, using the same principles as are used for the generation of an SSRC.

Ray

From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: vrijdag 16 december 2011 2:50
To: Kevin Gross; [email-masked]
Subject: Re: [AVTCORE] Comment 4: draft-ietf-avtcore-idms-02

Hi,
----- Original Message -----
>From: Kevin Gross
>To: [email-masked]<mailto:[email-masked]>

                    xr-format =/ rtcp-idms

[Qin]: In my view, since SDP attribute for both XR and RTCP IDMS packet share the same SyncGroupId?
I think it is possible and more general to associate [syn-grp] with clocksource attribute.
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer