Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-idms-07.txt

From: [email-masked]
Date: Thu, 11 Oct 2012 00:19:00 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Core Maintenance Working Group of the IETF.

	Title           : Inter-destination Media Synchronization using the RTP Control Protocol (RTCP)
	Author(s)       : Ray van Brandenburg
                          Hans Stokking
                          Oskar van Deventer
                          Fernando Boronat
                          Mario Montagud
                          Kevin Gross
	Filename        : draft-ietf-avtcore-idms-07.txt
	Pages           : 24
	Date            : 2012-10-11

Abstract:
   This document gives information on an RTP Control Protocol (RTCP)
   Packet Type and RTCP Extended Report (XR) Block Type including
   associated Session Description Protocol (SDP) parameters for Inter-
   Destination Media Synchronization (IDMS).  This document mandates the
   use of the RTCP XR Block Type 12, which is used to collect media
   playout information from participants in a group playing out
   (watching, listening, etc.) a specific RTP media stream.  This RTCP
   XR Block Type is specified and registered with IANA by ETSI.  The
   RTCP packet type specified by this document is used to distribute a
   common target playout point to which all the distributed receivers,
   sharing a media experience, can synchronize.

   Typical use cases in which IDMS is usefull are social TV, shared
   service control (i.e. applications where two or more geographically
   separated users are watching a media stream together), distance
   learning, networked video walls, networked loudspeakers, etc.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-idms

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-avtcore-idms-07

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-idms-07

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Thu, 11 Oct 2012 07:24:11 +0000

Hi all,

I've just uploaded a new version of the IDMS draft. This new version includes the comments received during the WGLC which were not yet included in the -06 version and a solution to the packet reporting issue that we discussed in Vancouver.

I believe that with this version all WGLC comments have been addressed. 

Best regards,

Ray van Brandenburg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: donderdag 11 oktober 2012 9:19
To: [email-masked]
Cc: [email-masked]
Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-idms-07.txt

Abstract:

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]
https://www.ietf.org/mailman/listinfo/avt
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer

---

From: Kevin Gross <[email-masked]>
Date: Fri, 19 Oct 2012 14:02:36 -0600

Ray has asked me to add to his comments and assure AVTCORE members that in
preparing this revision the authors also considered the following issues
discussed at IETF 84:

Which packet to report on - We decided to allow flexibility in which RTP
packet is used to report network delay. Flexibility allows implementations
to optimize reporting to get the most useful information to the MSAS
quickly. We do not believe interoperability or performance is compromised
by this flexibility.

draft-wu-xrblock-rtcp-xr-one-way-delay - We considered whether this
proposal could be used instead of the application-specific reporting
mechanism proposed in our draft. We found this unsuitable for the following
reasons.

   1. The IDMS proposal directly reports one-way delay of the RTP packets
   of the stream under control by IDMS. The one-way-delay proposal measures
   one-way delay using RTCP packets. RTP delay is what we care about for
   proper IDMS operation. RTCP packets are likely to experience different
   (shorter) delay due to their different (smaller) size.
   2. The one-way-delay proposal does not include a Media Stream
   Correlation Identifier. The MSAS requires this information to do its job.
   If it is not included in the XR, it will need to be signaled through
   another means significantly altering and complicating the system.
   3. The one-way-delay proposal does not include a presentation timestamp
   making the precise synchronization required by some IDMS applications
   difficult or impossible.

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com <http://www.avanw.com/>, www.X192.org

On Thu, Oct 11, 2012 at 1:24 AM, Brandenburg, R. (Ray) van <
[email-masked]> wrote:

> Hi all,
>
> I've just uploaded a new version of the IDMS draft. This new version
> includes the comments received during the WGLC which were not yet included
> in the -06 version and a solution to the packet reporting issue that we
> discussed in Vancouver.
>

---

From: Qin Wu <[email-masked]>
Date: Mon, 22 Oct 2012 09:34:56 +0800

Hi, Kevin:
I agree wth your comparision analysis between draft-wu-xrblock-rtcp-xr-one-way-delay and draft-ietf-avtcore-idms-07.
Thank for your clarification.

Regards!
-Qin
  ----- Original Message ----- 
  From: Kevin Gross 
  To: [email-masked] 
  Sent: Saturday, October 20, 2012 4:02 AM
  Subject: Re: [AVTCORE] FW: I-D Action: draft-ietf-avtcore-idms-07.txt

  Ray has asked me to add to his comments and assure AVTCORE members that in preparing this revision the authors also considered the following issues discussed at IETF 84:

  Which packet to report on - We decided to allow flexibility in which RTP packet is used to report network delay. Flexibility allows implementations to optimize reporting to get the most useful information to the MSAS quickly. We do not believe interoperability or performance is compromised by this flexibility.

  draft-wu-xrblock-rtcp-xr-one-way-delay - We considered whether this proposal could be used instead of the application-specific reporting mechanism proposed in our draft. We found this unsuitable for the following reasons.
    1.. The IDMS proposal directly reports one-way delay of the RTP packets of the stream under control by IDMS. The one-way-delay proposal measures one-way delay using RTCP packets. RTP delay is what we care about for proper IDMS operation. RTCP packets are likely to experience different (shorter) delay due to their different (smaller) size. 
    2.. The one-way-delay proposal does not include a Media Stream Correlation Identifier. The MSAS requires this information to do its job. If it is not included in the XR, it will need to be signaled through another means significantly altering and complicating the system. 
    3.. The one-way-delay proposal does not include a presentation timestamp making the precise synchronization required by some IDMS applications difficult or impossible.

  Kevin Gross

  +1-303-447-0517
  Media Network Consultant

  AVA Networks - www.AVAnw.com, www.X192.org

  On Thu, Oct 11, 2012 at 1:24 AM, Brandenburg, R. (Ray) van <[email-masked]> wrote:

    Hi all,

    Best regards,

    Ray van Brandenburg

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
    Sent: donderdag 11 oktober 2012 9:19
    To: [email-masked]
    Cc: [email-masked]
    Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-idms-07.txt

    Abstract:

------------------------------------------------------------------------------