Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-rtp-circuit-breakers-01.txt

From: [email-masked]
Date: Mon, 22 Oct 2012 15:16:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Core Maintenance Working Group of the IETF.

	Title           : RTP Congestion Control: Circuit Breakers for Unicast Sessions
	Author(s)       : Colin Perkins
                          Varun Singh
	Filename        : draft-ietf-avtcore-rtp-circuit-breakers-01.txt
	Pages           : 16
	Date            : 2012-10-22

Abstract:
   The Real-time Transport Protocol (RTP) is widely used in telephony,
   video conferencing, and telepresence applications.  Such applications
   are often run on best-effort UDP/IP networks.  If congestion control
   is not implemented in the applications, then network congestion will
   deteriorate the user's multimedia experience.  This document does not
   propose a congestion control algorithm; rather, it defines a minimal
   set of "circuit-breakers".  Circuit-breakers are conditions under
   which an RTP flow is expected to stop transmitting media to protect
   the network from excessive congestion.  It is expected that all RTP
   applications running on best-effort networks will be able to run
   without triggering these circuit breakers in normal operation.  Any
   future RTP congestion control specification is expected to operate
   within the envelope defined by these circuit breakers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-rtp-circuit-breakers

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-avtcore-rtp-circuit-breakers-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-rtp-circuit-breakers-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin Perkins <[email-masked]>
Date: Tue, 30 Oct 2012 15:05:30 +0000

A summary of the changes in this version is as follows:

- Clarify that multicast congestion control is outside the scope of this memo.

- Clarify what it means for an implementation to cease transmission when the circuit breaker fires. Specifically, the intention is that the application will stop sending RTP data packets until the user makes an explicit attempt to restart the call. The draft notes that RTP flows halted by the circuit breaker should not be restarted automatically unless the sender has received information that the congestion has dissipated.

- Add an explicit RTCP Timeout circuit breaker in Section 4.2 (this is a revised and extended version of Section 8 of the -00 draft). Unlike the media timeout in Section 4.1, which fires when returning RTCP RR packets show that media isn't reaching the receiver, this circuit breaker is triggered if RTCP packets are no longer returning to the sender.

- In section 4.3, clarify when high-rate senders can back-off to a lower rate when the circuit breaker is triggered, and when they need to cease transmission.

- Expand and clarify Section 5 about RTP circuit breakers for systems using the RTP/AVPF profile. A sender needs to process early RTCP reports that contain an SR/RR packet as-if they were regular RTCP reports, but ignore early non-compound RTCP packets without an SR/RR. This allows the use of low-overhead early RTP/AVPF feedback without triggering the RTP circuit breaker, and so is suitable for RTP congestion control algorithms that need to quickly report loss events in between regular RTCP reports.

- Expand and clarify Section 6 about the impact of RTCP XR, to note that RTCP XR packets are ignored by the circuit breaker algorithm.

- Expand and clarify Section 7 about the impact of ECN, to note that reports of ECN-CE marks are treated as packet loss for the congestion based circuit breaker, but ignored for the media timeout and RTCP timeout circuit breakers.

- Expand and clarify Section 8 on the security considerations to discuss authentication requirements.

I believe this draft is on the agenda for the AVTCORE meeting in Atlanta, but feedback via the list is also welcome. 

Colin

On 22 Oct 2012, at 23:16, [email-masked] wrote:
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

-- 
Colin Perkins
http://csperkins.org/