Subject: Re: [AVTCORE] AD review: draft-ietf-avtcore-clksrc-09

From: Aidan Williams <[email-masked]>
Date: Wed, 29 Jan 2014 11:19:56 +1100 (EST)

Hi Richard, 

Thanks for the review. Responses are inline below... 

----- Original Message -----

| From: "Richard Barnes" <[email-masked]>
| To: "[email-masked] WG" <[email-masked]>
| Sent: Sunday, 29 December, 2013 12:25:39 PM
| Subject: [AVTCORE] AD review: draft-ietf-avtcore-clksrc-09

| I have reviewed this document in preparation for IETF LC. Overall, it reads
| quite well. Thanks! I have requested a LC.

| A couple of comments that you can consider with LC comments:

| -- It seems like a reader familiar with
| draft-ietf-avtext-rtp-grouping-taxonomy might be surprised by these terms.
| Given that that document is still in development, I don't expect you to be
| able to use the terms there. However, it might be helpful to add a note
| saying that you are not attempting to align with their terminology.

It is great that there is a document attempting to define terminology clearly (it would have been awesome to have it for this draft!), but I'm not sure how to go about addressing your comment since we probably don't want to refer to the above draft explicitly. At present, there is a positive statement: "here are the definitions". Can you say a bit more about what you would like to see? 

| -- GLONASS?

Happy to add this. 

| -- Behavior with traceable clocks seems underspecified to me. Section 4.7
| should say explicitly that traceable clocks are marked with the ":traceable"
| suffix or the "/traceable/" identifier. With regard to NTP/PTP servers, how
| does the user of the clock know that the server is traceable? Is this
| indicated in-band to those protocols? Would it not be useful to be able to
| indicate that those servers provide traceable time?

Marking a clock as traceable allows additional information (e.g. IP addresses, PTP master identifiers and the like) to be omitted from the SDP since any traceable clock available at the answerer is considered to be an appropriate timestamp reference clock. For example, an offerer could could specify ts-refclk:ntp=/traceable/ and the answerer could use GPS as a reference clock since GPS is a source of traceable time. 

Would some additional sentences such as these address your comment? 

regards 
aidan 
____ 
:wq! 

| --Richard

| _______________________________________________
| Audio/Video Transport Core Maintenance
| [email-masked]
| https://www.ietf.org/mailman/listinfo/avt

---

From: Richard Barnes <[email-masked]>
Date: Thu, 30 Jan 2014 16:04:53 -0800

Hey Aidan,

Would you like to go ahead and revise the document before it goes to the
IESG for evaluation?  Or we can handle these with any IESG comments.

--Richard

On Tue, Jan 28, 2014 at 4:19 PM, Aidan Williams <[email-masked]
> wrote:

> ------------------------------
>
> *From: *"Richard Barnes" <[email-masked]>
> *To: *"[email-masked] WG" <[email-masked]>
> *Sent: *Sunday, 29 December, 2013 12:25:39 PM
> *Subject: *[AVTCORE] AD review: draft-ietf-avtcore-clksrc-09
>
>
> I have reviewed this document in preparation for IETF LC.  Overall, it
> reads quite well.  Thanks!   I have requested a LC.
>
> A couple of comments that you can consider with LC comments:
>
> -- It seems like a reader familiar with
> draft-ietf-avtext-rtp-grouping-taxonomy might be surprised by these terms.
> Given that that document is still in development, I don't expect you to be
> able to use the terms there.  However, it might be helpful to add a note
> saying that you are not attempting to align with their terminology.
>
> It is great that there is a document attempting to define terminology
> clearly (it would have been awesome to have it for this draft!), but I'm
> not sure how to go about addressing your comment since we probably don't
> want to refer to the above draft explicitly.  At present, there is a
> positive statement: "here are the definitions".  Can you say a bit more
> about what you would like to see?
>
> -- GLONASS?
>
> Happy to add this.
>
> -- Behavior with traceable clocks seems underspecified to me.  Section 4.7
> should say explicitly that traceable clocks are marked with the
> ":traceable" suffix or the "/traceable/" identifier.  With regard to
> NTP/PTP servers, how does the user of the clock know that the server is
> traceable?  Is this indicated in-band to those protocols?  Would it not be
> useful to be able to indicate that those servers provide traceable time?
>
> Marking a clock as traceable allows additional information (e.g. IP
> addresses, PTP master identifiers and the like) to be omitted from the SDP
> since any traceable clock available at the answerer is considered to be an
> appropriate timestamp reference clock.  For example, an offerer could could
> specify ts-refclk:ntp=/traceable/ and the answerer could use GPS as a
> reference clock since GPS is a source of traceable time.
>
> --Richard
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>
>
>

---

From: Aidan Williams <[email-masked]>
Date: Fri, 31 Jan 2014 15:34:44 +1100 (EST)

Hi Richard, 

I'm flexible, but I'd prefer to do another revision that addresses all comments in one batch. 

The other comments I have received so far are editorial in nature, so proceeding to IESG review seems appropriate. 

- aidan 

----- Original Message -----

| From: "Richard Barnes" <[email-masked]>
| To: "Aidan Williams" <[email-masked]>
| Cc: "[email-masked] WG" <[email-masked]>
| Sent: Friday, 31 January, 2014 11:04:53 AM
| Subject: Re: [AVTCORE] AD review: draft-ietf-avtcore-clksrc-09

| Hey Aidan,

| Would you like to go ahead and revise the document before it goes to the IESG
| for evaluation? Or we can handle these with any IESG comments.

| --Richard

| On Tue, Jan 28, 2014 at 4:19 PM, Aidan Williams < [email-masked]
| > wrote:

| | Hi Richard,
| 

| | Thanks for the review. Responses are inline below...
| 

| | | From: "Richard Barnes" <[email-masked]>
| | 
| 
| | | To: " [email-masked] WG" < [email-masked] >
| | 
| 
| | | Sent: Sunday, 29 December, 2013 12:25:39 PM
| | 
| 
| | | Subject: [AVTCORE] AD review: draft-ietf-avtcore-clksrc-09
| | 
| 

| | | I have reviewed this document in preparation for IETF LC. Overall, it
| | | reads
| | | quite well. Thanks! I have requested a LC.
| | 
| 

| | | A couple of comments that you can consider with LC comments:
| | 
| 

| | | -- It seems like a reader familiar with
| | | draft-ietf-avtext-rtp-grouping-taxonomy might be surprised by these
| | | terms.
| | | Given that that document is still in development, I don't expect you to
| | | be
| | | able to use the terms there. However, it might be helpful to add a note
| | | saying that you are not attempting to align with their terminology.
| | 
| 

| | It is great that there is a document attempting to define terminology
| | clearly
| | (it would have been awesome to have it for this draft!), but I'm not sure
| | how to go about addressing your comment since we probably don't want to
| | refer to the above draft explicitly. At present, there is a positive
| | statement: "here are the definitions". Can you say a bit more about what
| | you
| | would like to see?
| 

| | | -- GLONASS?
| | 
| 

| | Happy to add this.
| 

| | | -- Behavior with traceable clocks seems underspecified to me. Section 4.7
| | | should say explicitly that traceable clocks are marked with the
| | | ":traceable"
| | | suffix or the "/traceable/" identifier. With regard to NTP/PTP servers,
| | | how
| | | does the user of the clock know that the server is traceable? Is this
| | | indicated in-band to those protocols? Would it not be useful to be able
| | | to
| | | indicate that those servers provide traceable time?
| | 
| 

| | Marking a clock as traceable allows additional information (e.g. IP
| | addresses, PTP master identifiers and the like) to be omitted from the SDP
| | since any traceable clock available at the answerer is considered to be an
| | appropriate timestamp reference clock. For example, an offerer could could
| | specify ts-refclk:ntp=/traceable/ and the answerer could use GPS as a
| | reference clock since GPS is a source of traceable time.
| 

| | Would some additional sentences such as these address your comment?
| 

| | regards
| 
| | aidan
| 
| | ____
| 
| | :wq!
| 

| | | --Richard
| | 
| 

| | | _______________________________________________
| | 
| 
| | | Audio/Video Transport Core Maintenance
| | 
| 
| | | [email-masked]
| | 
| 
| | | https://www.ietf.org/mailman/listinfo/avt
| | 
|