Subject: [AVTCORE] Treatment of RTCP - proposed text

From: "Black, David" <[email-masked]>
Date: Wed, 27 Aug 2014 21:58:34 -0400

Trying to propose some text here:

OLD
   o  Should use a single DSCP for an RTCP session, primarily to avoid
      RTCP reordering (and because there is no compelling reason for use
      of different drop precedences).  One of the PHBs and associated
      DSCP used for the associated RTP traffic would be an appropriate
      choice.  [Editor's note: This bullet is an open technical issue.]
NEW
   o  Should use the same DSCP for RTCP reports as used for the RTP stream
      that is being reported on when that DSCP is known by the RTCP sender.
      When an RTP stream uses multiple DSCPs that differ only in drop
      precedence, RTCP reports on that RTP stream should use the DSCP with
      the least likelihood of drop to favor delivery of the RTCP reports.
      When a single RTCP message reports on multiple RTP streams that
      are sent with different DSCPs, the RTCP sender should choose one
      of those DSCPs.  When the RTCP sender does not know what
	DSCP or DSCPs were used to send an RTP stream, it should choose
	a DSCP that it would use to send a similar RTP stream.
      
The latter sentence is courtesy of the fact that there will be cases
where the RTCP sender will not know what DSCP or DSCPs were used to send
the RTP stream, due to en-route remarking.

If that text looks close, I'll edit further and try to get the -05 submitted
by the end of this week.

Thanks,
--David

> -----Original Message-----
> From: Paul E. Jones [mailto:[email-masked]]
> Sent: Wednesday, August 27, 2014 6:53 PM
> To: Ben Campbell; Michael Welzl; Colin Perkins; Black, David
> Cc: [email-masked]; [email-masked]; [email-masked]
> WG
> Subject: Re: [Dart] [AVTCORE] Treatment of RTCP (was Re: Colin Perkins
> comments - WGLC: draft-ietf-dart-dscp-rtp-02)
> 
> RTCP might not be used for RTT calculations (it might; I just doubt it's
> terribly useful),  but RTCP might be used to convey QoE measurements or
> one-way delay information useful for RMCAT.
> 
> I think there is agreement that the DSCP value applied to the RTCP
> packet for a given SSRC sender should align with the DSCP value used for
> the corresponding RTP packets of that sender. In the case where an AFxx
> class is used, I'm not sure there is agreement (though no disagreement).
>   I stated my view that we should use the lowest drop precedence in that
> case, but others should weigh in.
> 
> Paul
> 
> ------ Original Message ------
> From: "Ben Campbell" <[email-masked]>
> To: "Michael Welzl" <[email-masked]>; "Colin Perkins"
> <[email-masked]>; "Paul E. Jones" <[email-masked]>; "Black,
> David" <[email-masked]>
> Cc: "[email-masked]"
> <[email-masked]>; "[email-masked]"
> <[email-masked]>; "[email-masked] WG" <[email-masked]>
> Sent: 8/27/2014 4:48:37 PM
> Subject: Re: [Dart] [AVTCORE] Treatment of RTCP (was Re: Colin Perkins
> comments - WGLC: draft-ietf-dart-dscp-rtp-02)
> 
> >On Aug 27, 2014, at 3:45 PM, Michael Welzl <[email-masked]> wrote:
> >
> >>  I don't know the beginning of this but I can help go up the stack:
> >>
> >>  for the short dialogue between Colin and me, the conclusion is: Colin
> >>is right. RTCP probably won't be used by congestion control to
> >>estimate the RTT.
> >>
> >
> >Thanks, Michael, I think that fits with some earlier conversations as
> >well.
> >
> >Colin and Paul (and David):
> >
> >Are we converging on what guidance to put into the DART draft?
> >
> >Thanks!
> >
> >Ben.
> >
> >
> >_______________________________________________
> >Dart mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/dart

---

From: Ben Campbell <[email-masked]>
Date: Wed, 27 Aug 2014 21:28:07 -0500

I do not object to the text per se. 

But I do have a bit of a nagging concern that we may be offering too strong of guidance, given the thought process so far.  Do we believe we understand this well enough to say the sender should to this or that, as opposed to say that these are things the implementer should think about, and that these are probably reasonable choices? 

Is this an area where we need more deployment experience to offer real guidance? (I think it's okay for the doc to say that, if needed.)

But in any case, I will defer to Colin, Paul, and David.

---

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 28 Aug 2014 03:13:53 +0000

David,

Should it be the DSCP value of the SSRC being reported on or the DSCP of 
the SSRC sender?  My thought that was if Alice and Bob are sending flows 
to each other and Bob is sending audio using EF, then when Bob sends out 
a Sender Report, the packet would be marked EF.  The way this is worded, 
if Alice is sending packets using CS0, then Bob would mark his SR's 
using CS0.

I'm not sure how to handle the RR's, though, particularly of a 
receive-only device.  We could say it would be the same as the flow 
being reported on, but there might be 31 such flows being reported on.  
Perhaps if there is agreement that the RTCP packets will be marked in 
the same way as the sender would send its media, then we say the reports 
should be marked in the same was as it would if it did send media.

So, do we want RTCP packets to be marked the same as the media flow 
transmitted or the same as the received media flow?

Paul

------ Original Message ------
From: "Black, David" <[email-masked]>
To: "Paul E. Jones" <[email-masked]>; "Ben Campbell" 
<[email-masked]>; "Michael Welzl" <[email-masked]>; "Colin Perkins" 
<[email-masked]>
Cc: "[email-masked]" 
<[email-masked]>; "[email-masked]" 
<[email-masked]>; "[email-masked] WG" <[email-masked]>; "Black, David" 
<[email-masked]>
Sent: 8/27/2014 9:58:34 PM
Subject: Treatment of RTCP - proposed text

---

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 28 Aug 2014 03:21:13 +0000

Ben,

I think the answer is really whether we can quickly reach consensus.  I 
have an idea how I'd implement it if I didn't have guidance otherwise, 
which I explained in my last email.

I think this can be resolved pretty quickly.  If not, we can certainly 
leave it open.

Paul

------ Original Message ------
From: "Ben Campbell" <[email-masked]>
To: "Black, David" <[email-masked]>
Cc: "Paul E. Jones" <[email-masked]>; "Michael Welzl" 
<[email-masked]>; "Colin Perkins" <[email-masked]>; 
"[email-masked]" 
<[email-masked]>; "[email-masked]" 
<[email-masked]>; "[email-masked] WG" <[email-masked]>
Sent: 8/27/2014 10:28:07 PM
Subject: Re: Treatment of RTCP - proposed text

>But I do have a bit of a nagging concern that we may be offering too 
>strong of guidance, given the thought process so far. Do we believe we 
>understand this well enough to say the sender should to this or that, 
>as opposed to say that these are things the implementer should think 
>about, and that these are probably reasonable choices?
>
>Is this an area where we need more deployment experience to offer real 
>guidance? (I think it's okay for the doc to say that, if needed.)
>

---

From: "Black, David" <[email-masked]>
Date: Thu, 28 Aug 2014 00:47:37 -0400

> the SSRC sender?  

It should be the SSRC/RTP stream DSCP.  I think the proposed text covers
that for both the SR and RR cases (Bob would use EF in your example), but
I admit to thinking more about RRs when I wrote the proposed text.

If there are 31 flows being reported on in a single RTCP RR, I think
the receiver just picks a DSCP, as it may not know the DSCPs for any
of the flows (e.g., if they've all been remarked enroute).  I do like
the idea of having the reporter use the DSCP that it would use to send
a similar RTP stream - I'd be happy to slim the text down to only 
recommend that, as it's simpler and the RTCP sender should always know
what DSCP it would use if it were sending similar media.

Thanks,
--David

> Sent: Wednesday, August 27, 2014 11:14 PM
> To: Black, David; Ben Campbell; Michael Welzl; Colin Perkins
> WG; Black, David
> >       of those DSCPs. When the RTCP sender does not know what DSCP or
> >       DSCPs were used to send an RTP stream, it should choose a DSCP
> >       that it would use to send a similar RTP stream.
> >
> >where the RTCP sender will not know what DSCP or DSCPs were used to
> >send the RTP stream, due to en-route remarking.
> >
> >If that text looks close, I'll edit further and try to get the -05
> >submitted by the end of this week.
> >
> >Thanks,
> >--David
> >

---

From: Colin Perkins <[email-masked]>
Date: Thu, 28 Aug 2014 09:55:49 +0100

Paul, David,

On 28 Aug 2014, at 04:13, Paul E. Jones <[email-masked]> wrote:
> Should it be the DSCP value of the SSRC being reported on or the DSCP of the SSRC sender?  My thought that was if Alice and Bob are sending flows to each other and Bob is sending audio using EF, then when Bob sends out a Sender Report, the packet would be marked EF.  

Agree. An SSRC should use the same marking it would use to send packets, and not the marking of the received packets.

> The way this is worded, if Alice is sending packets using CS0, then Bob would mark his SR's using CS0.
> 
> I'm not sure how to handle the RR's, though, particularly of a receive-only device.  We could say it would be the same as the flow being reported on, but there might be 31 such flows being reported on.  Perhaps if there is agreement that the RTCP packets will be marked in the same way as the sender would send its media, then we say the reports should be marked in the same was as it would if it did send media.

A receive-only device should mark in the way it would if it sent media, I agree.

> So, do we want RTCP packets to be marked the same as the media flow transmitted or the same as the received media flow?

Transmitted, I think.

Colin

> To: "Paul E. Jones" <[email-masked]>; "Ben Campbell" <[email-masked]>; "Michael Welzl" <[email-masked]>; "Colin Perkins" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked] WG" <[email-masked]>; "Black, David" <[email-masked]>

-- 
Colin Perkins
http://csperkins.org/