Subject: [AVTCORE] I-D Action: draft-ietf-avtcore-rfc5764-mux-fixes-02.txt

From: [email-masked]
Date: Tue, 24 Mar 2015 16:12:14 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Core Maintenance Working Group of the IETF.

        Title           : Multiplexing Scheme Updates for Secure Real-time Transport Protocol (SRTP) Extension for Datagram Transport Layer Security (DTLS)
        Authors         : Marc Petit-Huguenin
                          Gonzalo Salgueiro
	Filename        : draft-ietf-avtcore-rfc5764-mux-fixes-02.txt
	Pages           : 12
	Date            : 2015-03-24

Abstract:
   This document defines how Datagram Transport Layer Security (DTLS),
   Real-time Transport Protocol (RTP), Real-time Transport Control
   Protocol (RTCP), Session Traversal Utilities for NAT (STUN), and
   Traversal Using Relays around NAT (TURN) packets are multiplexed on a
   single receiving socket.  It overrides the guidance from SRTP
   Extension for DTLS [RFC5764], which suffered from three issues
   described and fixed in this document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-rfc5764-mux-fixes/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-avtcore-rfc5764-mux-fixes-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-rfc5764-mux-fixes-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 24 Mar 2015 18:19:27 -0500

Here's the merged changelog since -00:

- - Instead of allocating the values that are common on each registry, the specification now only reserves them, giving the possibility to allocate them in case muxing is irrelevant.
- - STUN range is now 0-3 with 2-3 being Designated Expert.
- - TLS ContentType 0-19 and 64-255 are now reserved.
- - If an implementation uses the source IP address/port to separate TURN channels packets then the whole channel numbers range is available.
- - If not the prefix is between 64 and 79.</t>
- - The first byte test order is now by incremental values, so failure is deterministic.
- - Packets that do not match are dropped.
- - Redrawn the demuxing diagram.
- - Adoption by WG.

Reviews are appreciated.  We would like to get to WGLC before Prague.

Thanks.

On 03/24/2015 06:12 PM, [email-masked] wrote:
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug