Subject: [AVTCORE] Scope of EKT

From: John Mattsson <[email-masked]>
Date: Mon, 23 Mar 2015 13:20:53 +0000

Hi,

When the work on EKT started, e2e secure conferencing was not in scope. In draft-jones-avtcore-private-media-framework-01 Cisco (authors of the EKT draft) is proposing to use EKT for the e2e secure conferencing use case. Several changes to EKT is also proposed:

- The position of the EKT field is changed from last in packet to before the authentication tag.

- A change to EKT such that the ROC is transmitted in the clear.

- An extension of EKT in order to negotiate the SRTP Protection Profile used for end-to-end encryption and authentication.

- An extension of EKT in order to send the participant identifier.

Without commenting on the specific changes, I agree that EKT is a good match for the e2e secure conferencing case and I support widening the scope of EKT to include this.

What does the group think?

Cheers,
John

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 23 Mar 2015 19:32:06 +0000

It probably goes without saying, but I supported that.  At the very 
least, I think we should keep this option available as we discuss the 
e2e security problem.

Paul

------ Original Message ------
From: "John Mattsson" <[email-masked]>
To: "IETF AVTCore WG" <[email-masked]>
Sent: 3/23/2015 9:20:53 AM
Subject: [AVTCORE] Scope of EKT

>Hi,
>
>When the work on EKT started, e2e secure conferencing was not in scope. 
>In draft-jones-avtcore-private-media-framework-01 Cisco (authors of the 
>EKT draft) is proposing to use EKT for the e2e secure conferencing use 
>case. Several changes to EKT is also proposed:
>
>- An extension of EKT in order to negotiate the SRTP Protection Profile 
>used for end-to-end encryption and authentication.
>
>Without commenting on the specific changes, I agree that EKT is a good 
>match for the e2e secure conferencing case and I support widening the 
>scope of EKT to include this.
>
>_______________________________________________
>Audio/Video Transport Core Maintenance
>[email-masked]
>https://www.ietf.org/mailman/listinfo/avt