Subject: Re: [AVTCORE] call for AVTcore agenda requests for IETF 93

From: Bernard Aboba <[email-masked]>
Date: Mon, 6 Jul 2015 01:41:15 -0700

I would like some agenda time to present the following document:
https://tools.ietf.org/html/draft-aboba-avtcore-sfu-rtp-00

Abstract 

 Selective Forwarding Units (SFUs) supporting Scalable Video Coding (SVC) typically parse the RTP payload in the forwarding plane, and often utilize codec-specific control messages within the control plane. As a result, the control and/or forwarding planes of these implementations need to be modified (sometimes substantially) in order to support additional video codecs. With SFUs now supporting VP8 in addition to H.264/SVC, and with additional video codecs expected to become popular, the inflexibility of SFU designs that depend on RTP payload parsing has become increasingly apparent. In addition, these designs cannot function where the RTP payload is inaccessible, such as when it is encrypted with a key not available to the SFU. Based on a summary of SFU implementation practice, this document develops requirements for codec-independent SFUs.

> On Jun 30, 2015, at 7:17 AM, Magnus Westerlund <[email-masked]> wrote:
> 
> Hi,
> 
> A reminder that the chairs like to receive the agenda requests.
> 
> Cheers
> 
> Magnus Westerlund
> WG Chair
> 
> Roni Even skrev den 2015-06-20 09:31:
>> Hi,
>> 
>> The preliminary agenda of IETF-93 was published. The AVTCORE WG meeting
>> is scheduled as follows:
>> 
>> Wednesday, July 22, 2015
>> 
>> 1300-1530  Afternoon Session I
>> 
>> Congress Hall III                 ART             avtcore
>>                     Audio/Video Transport Core Maintenance WG
>> 
>> Note that this scheduling is subject to change.
>> 
>> Please send the chairs your requests for agenda items.
>> 
>> Thanks and Regards,
>> 
>> Roni Even
>> 
>> AVTCORE co-chair
>> 
>> 
>> 
>> _______________________________________________
>> Audio/Video Transport Core Maintenance
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/avt
>> 
> 
> 
> -- 
> 
> Magnus Westerlund
> 
> ----------------------------------------------------------------------
> Services, Media and Network features, Ericsson Research EAB/TXM
> ----------------------------------------------------------------------
> Ericsson AB                 | Phone  +46 10 7148287
> Färögatan 6                 | Mobile +46 73 0949079
> SE-164 80 Stockholm, Sweden | mailto: [email-masked]
> ----------------------------------------------------------------------
> 
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: Ron Even <[email-masked]>
Date: Mon, 6 Jul 2015 13:35:28 +0300

OK
Roni

On 7/6/15, Bernard Aboba <[email-masked]> wrote:
>  Selective Forwarding Units (SFUs) supporting Scalable Video Coding (SVC)
> typically parse the RTP payload in the forwarding plane, and often utilize
> codec-specific control messages within the control plane. As a result, the
> control and/or forwarding planes of these implementations need to be
> modified (sometimes substantially) in order to support additional video
> codecs. With SFUs now supporting VP8 in addition to H.264/SVC, and with
> additional video codecs expected to become popular, the inflexibility of SFU
> designs that depend on RTP payload parsing has become increasingly apparent.
> In addition, these designs cannot function where the RTP payload is
> inaccessible, such as when it is encrypted with a key not available to the
> SFU. Based on a summary of SFU implementation practice, this document
> develops requirements for codec-independent SFUs.
>
>
>
>
>