Subject: [AVTCORE] [Technical Errata Reported] RFC3711 (4425)

From: RFC Errata System <[email-masked]>
Date: Wed, 22 Jul 2015 12:16:48 -0700 (PDT)

The following errata report has been submitted for RFC3711,
"The Secure Real-time Transport Protocol (SRTP)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3711&eid=4425

--------------------------------------
Type: Technical
Reported by: Ross Finlayson <[email-masked]>

Section: 3.4

Original Text
-------------
      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+<+
     |V=2|P|    RC   |   PT=SR or RR   |             length          | |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ |

Corrected Text
--------------
      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+<+
     |V=2|P|    RC   |   PT=SR or RR |             length          | |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ |

Notes
-----
The boundary between the "PT=SR or RR" and the "length" fields is wrong: The boundary is shown as being between bits 16 and 17; it should be between bits 15 and 16.  I.e., the "PT=SR or RR" field should be 8 bits long, not 9.

This is just a minor bug, because the equivalent diagram in RFC 3550 (the normative reference for RTCP) is correct.  Nonetheless, this bug should probably be added to the errata for RFC 3711

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3711 (draft-ietf-avt-srtp-09)
--------------------------------------
Title               : The Secure Real-time Transport Protocol (SRTP)
Publication Date    : March 2004
Author(s)           : M. Baugher, D. McGrew, M. Naslund, E. Carrara, K. Norrman
Category            : PROPOSED STANDARD
Source              : Audio/Video Transport
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 23 Jul 2015 10:41:11 +0200

Hi,

I think this errata is editorial rather than technical. This as the 
error is in the part not specified by this RFC, rather as you say 
RFC3550. I don't think it is likely to cause any interoperability issue, 
but it should be retain. Thus I propose that it is put into the

HOLD for Document update

Category. Please provide an further comments on this.

Cheers

Magnus Westerlund
(Chair)

Den 2015-07-22 kl. 21:16, skrev RFC Errata System:
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------