Subject: [AVTCORE] [Editorial Errata Reported] RFC3711 (4514)

From: RFC Errata System <[email-masked]>
Date: Thu, 29 Oct 2015 04:40:25 -0700 (PDT)

The following errata report has been submitted for RFC3711,
"The Secure Real-time Transport Protocol (SRTP)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3711&eid=4514

--------------------------------------
Type: Editorial
Reported by: Bernhard Kirchen <[email-masked]>

Section: 3.1

Original Text
-------------
The format of an SRTP packet is illustrated in Figure 1.

   0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+<+

Corrected Text
--------------
The format of an SRTP packet is illustrated in Figure 1.

 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+<+

Notes
-----
The bit index second decimal digit is shifted by two characters. These digits should align with the zeros in the second line.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3711 (draft-ietf-avt-srtp-09)
--------------------------------------
Title               : The Secure Real-time Transport Protocol (SRTP)
Publication Date    : March 2004
Author(s)           : M. Baugher, D. McGrew, M. Naslund, E. Carrara, K. Norrman
Category            : PROPOSED STANDARD
Source              : Audio/Video Transport
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Karl Norrman <[email-masked]>
Date: Thu, 29 Oct 2015 12:10:42 +0000

Hello!

I agree that the figure would look better if the proposed correction is made.
On the other hand, I can't really see that the current figure could be misinterpreted by an implementer, so I consider this to be an editorial correction.

BR
Karl

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: den 29 oktober 2015 12:40
> To: [email-masked]; [email-masked];
> [email-masked]; Mats Näslund; Karl Norrman; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Editorial Errata Reported] RFC3711 (4514)
> 
> The following errata report has been submitted for RFC3711, "The Secure
> Real-time Transport Protocol (SRTP)".
> 
> The bit index second decimal digit is shifted by two characters. These digits
> should align with the zeros in the second line.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please use
> "Reply All" to discuss whether it should be verified or rejected. When a
> decision is reached, the verifying party (IESG) can log in to change the status
> and edit the report, if necessary.
>

---

From: "David McGrew (mcgrew)" <[email-masked]>
Date: Thu, 29 Oct 2015 12:18:52 +0000

+1

David McGrew, PhD
Cisco Fellow
Advanced Security Research and Government Group, Cisco Systems

-----Original Message-----
From: Karl Norrman [mailto:[email-masked]] 
Sent: Thursday, October 29, 2015 8:11 AM
To: RFC Errata System; [email-masked]; [email-masked]; David McGrew (mcgrew); Mats Näslund; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Editorial Errata Reported] RFC3711 (4514)

Hello!

BR
Karl

> The following errata report has been submitted for RFC3711, "The 
> Secure Real-time Transport Protocol (SRTP)".
> 
> The bit index second decimal digit is shifted by two characters. These 
> digits should align with the zeros in the second line.
> 
> Instructions:
> -------------
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party (IESG) can log in to 
> change the status and edit the report, if necessary.
>