Subject: [AVTCORE] AD Evaluation of draft-ietf-avtcore-multi-media-rtp-session-10

From: "Ben Campbell" <[email-masked]>
Date: Mon, 09 Nov 2015 15:10:49 -0600

(resent with the working group address unborked. Apologies for the 
repeat.)

Hi,

Here is my AD evaluation of 
draft-ietf-avtcore-multi-media-rtp-session-10. The first substantive 
comment has consequences on how we do the IETF last call, so we need to 
resolve it prior to the last call.

Thanks!

Ben.
-------------

Substantive Comments:
=====================

- Section 4, "Equal treatment of media."

This section is made effectively normative by the "MUST" in the 
preamble. But the guidance under "Equal treatment" is a bit on the fuzzy 
side for normative requirements. And since the detailed guidance is 
delegated to the two references at the end of this section, they should 
be normative references. This is a bit problematic since they are 
informational drafts. Now, that's not a show stopper; if the references 
should be normative we can make them so--it just requires a bit more 
process.

So, please consider whether the section should be tightened up and the 
references made normative, or if it can be restated as non-normative 
guidance. This impacts how we do the IETF last call announcement, so I 
will hold the last call until we resolve it.

- 6.2, third paragraph:

5956 obsoletes 4756. Is there a need to keep the reference to 4656? 
(e.g. backwards compatibility?)

Editorial and Nits:
===================

- section 2: IDNits points out that the draft uses “NOT 
RECOMMENDED”, but does not mention it here.

- 5.3, 2nd paragraph:

s/"stream on the same SSRC"/"stream with the same SSRC"

---

From: Colin Perkins <[email-masked]>
Date: Wed, 11 Nov 2015 14:49:41 +0000

Hi,

Thanks for the review; replies inline. Let me know if you want me to submit an updated draft now, or after last call.

Colin

> On 9 Nov 2015, at 21:10, Ben Campbell <[email-masked]> wrote:
> 
> Hi,
> 
> Here is my AD evaluation of draft-ietf-avtcore-multi-media-rtp-session-10. The first substantive comment has consequences on how we do the IETF last call, so we need to resolve it prior to the last call.
> 
> Thanks!
> 
> Ben.
> -------------
> 
> Substantive Comments:
> =====================
> 
> This section is made effectively normative by the "MUST" in the preamble. But the guidance under "Equal treatment" is a bit on the fuzzy side for normative requirements. And since the detailed guidance is delegated to the two references at the end of this section, they should be normative references. This is a bit problematic since they are informational drafts. Now, that's not a show stopper; if the references should be normative we can make them so--it just requires a bit more process.
> 
> So, please consider whether the section should be tightened up and the references made normative, or if it can be restated as non-normative guidance. This impacts how we do the IETF last call announcement, so I will hold the last call until we resolve it.

My suggestion would be that the “MUST” in the preamble changes to “needs to”, since this section is less normative requirements, and more a statement of the facts about how a single RTP works.

> - 6.2, third paragraph:
> 
> 5956 obsoletes 4756. Is there a need to keep the reference to 4656? (e.g. backwards compatibility?)

I assume the reference is for backwards compatibility, but don’t have a strong opinion.

> Editorial and Nits:
> ===================
> 
> - section 2: IDNits points out that the draft uses “NOT RECOMMENDED”, but does not mention it here.

This is a bug in the RFC 2119 boilerplate, which this draft copies verbatim. I can add “NOT RECOMMENDED”, but don’t then complain that the boilerplate doesn’t match RFC 2119 ;-)

> s/"stream on the same SSRC"/"stream with the same SSRC"

Will fix.

-- 
Colin Perkins
https://csperkins.org/

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 11 Nov 2015 15:43:45 -0600

On 11 Nov 2015, at 8:49, Colin Perkins wrote:

> Hi,
>
> Thanks for the review; replies inline. Let me know if you want me to 
> submit an updated draft now, or after last call.

Please go ahead and submit a new version when you are ready. We can do 
the last call on the updated version.

More inline:

[...]

>> preamble. But the guidance under "Equal treatment" is a bit on the 
>> fuzzy side for normative requirements. And since the detailed 
>> guidance is delegated to the two references at the end of this 
>> section, they should be normative references. This is a bit 
>> problematic since they are informational drafts. Now, that's not a 
>> show stopper; if the references should be normative we can make them 
>> so--it just requires a bit more process.
>>
>> So, please consider whether the section should be tightened up and 
>> the references made normative, or if it can be restated as 
>> non-normative guidance. This impacts how we do the IETF last call 
>> announcement, so I will hold the last call until we resolve it.
>
> My suggestion would be that the “MUST” in the preamble changes to 
> “needs to”, since this section is less normative requirements, and 
> more a statement of the facts about how a single RTP works.

I think that would help. But even then, do you think the reader can 
fully understand the "Equal Treatment" section without reading 
multiplex-guidelines or dart-dscp-rtp?

> I assume the reference is for backwards compatibility, but don’t 

If it is about backwards compatibility, then it would be good to have a 
sentence or two stating that.

> This is a bug in the RFC 2119 boilerplate, which this draft copies 
> verbatim. I can add “NOT RECOMMENDED”, but don’t then complain 
> that the boilerplate doesn’t match RFC 2119 ;-)

I think we can let this one slide :-)

[...]

---

From: Colin Perkins <[email-masked]>
Date: Thu, 12 Nov 2015 15:11:47 +0000

Hi,

> On 11 Nov 2015, at 21:43, Ben Campbell <[email-masked]> wrote:
> 
> Please go ahead and submit a new version when you are ready. We can do the last call on the updated version.

Will do.

> I think that would help. But even then, do you think the reader can fully understand the “Equal Treatment" section without reading multiplex-guidelines or dart-dscp-rtp?

I’ve rephrased it slightly, but yes I think so. Those drafts are relevant for cases where non-equal treatment is needed, but in the usual cases where all media are treated the same, they’re not relevant. 

> If it is about backwards compatibility, then it would be good to have a sentence or two stating that.

Rephrased for clarity.

> I think we can let this one slide :-)

I added “NOT RECOMMENDED” to the boilerplate, since that seems clearest.

-- 
Colin Perkins
https://csperkins.org/