Subject: [AVTCORE] AD Evaluation of draft-ietf-avtcore-rtp-multi-stream-optimisation-08

From: "Ben Campbell" <[email-masked]>
Date: Mon, 09 Nov 2015 15:48:07 -0600

Hi,

Here is my AD Evaluation of 
draft-ietf-avtcore-rtp-multi-stream-optimisation-08:

Ben.

-----------

Substantive Comments:
=====================

-3.1, 4th paragraph:

Is “SHOULD NOT…unless” the actual intent? That means you 
shouldn’t do it unless that condition occurs, or you have some other 
good reason and understand the consequences. (as compared to "MUST NOT 
… unless")

-4.2, 1st paragraph:

Does this refer to third-party observers? (That is, observers not 
involved in the signaling of support for rtcp-rgrp?

-7.2, reference to RFC3264:

Should this be a normative reference? I’m not sure 3.6 will make much 
sense without it.

Editorial Comments:
===================

-3.1, 5th paragraph:

Option "A" is hard to parse. I suggest:

"... if another reporting source exists,  have it report on the remote 
SSRCs that the departing source reported ..."

- 3.2.1, 2nd paragraph:

Consider active voice for the first sentence, i.e. "This document 
defines..."

- 3.2.2, 1st paragraph:

Consider active voice for the first sentence, i.e. "This document 
defines..."

- 3.6, 2nd to last paragraph: "... neither agents SHALL use..."

Please restate as SHALL NOT/MUST NOT.

-4.1, last paragraph: "approximately 8.9"

That's a rather precise approximation :-)

---

From: Colin Perkins <[email-masked]>
Date: Wed, 11 Nov 2015 15:18:22 +0000

> On 9 Nov 2015, at 21:48, Ben Campbell <[email-masked]> wrote:
> 
> Hi,
> 
> Here is my AD Evaluation of draft-ietf-avtcore-rtp-multi-stream-optimisation-08:
> 
> Ben.
> 
> -----------
> 
> Substantive Comments:
> =====================
> 
> -3.1, 4th paragraph:
> 
> Is “SHOULD NOT…unless” the actual intent? That means you shouldn’t do it unless that condition occurs, or you have some other good reason and understand the consequences. (as compared to “MUST NOT … unless")

It’s trying to say don’t create a reporting group with only a single local SSRC, unless you expect to add more SSRCs to it later. Suggestions for better phrasing welcome.

> -4.2, 1st paragraph:
> 
> Does this refer to third-party observers? (That is, observers not involved in the signaling of support for rtcp-rgrp?

That’s the most likely example, yes.

> Should this be a normative reference? I’m not sure 3.6 will make much sense without it.

It’s normative if you use SDP offer/answer, but not for declarative SDP. Happy to move it to a normative reference.

> “... if another reporting source exists,  have it report on the remote SSRCs that the departing source reported ..."

Okay, although I’m not sure it scans so clearly.

> - 3.2.1, 2nd paragraph:
> 
> Consider active voice for the first sentence, i.e. "This document defines..."
> 
> - 3.2.2, 1st paragraph:
> 
> Consider active voice for the first sentence, i.e. “This document defines..."

Fine.

> Please restate as SHALL NOT/MUST NOT.

Is it sufficient to change this to “If the answerer does not wish to use RTCP Reporting Groups, it MUST NOT include the “a=rtcp-rgrp” in the answer.”?

> That's a rather precise approximation :-)

We like precision :-)

-- 
Colin Perkins
https://csperkins.org/

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 11 Nov 2015 15:59:06 -0600

On 11 Nov 2015, at 9:18, Colin Perkins wrote:

>> shouldn’t do it unless that condition occurs, or you have some 
>> other good reason and understand the consequences. (as compared to 
>> “MUST NOT … unless")
>
> It’s trying to say don’t create a reporting group with only a 
> single local SSRC, unless you expect to add more SSRCs to it later. 
> Suggestions for better phrasing welcome.

Two alternatives come to mind. I suspect B is closer to the intent. (And 
I don't think there's a problem with a conditional MUST, as long as the 
conditions are clear and exhaustive.)

a: An endpoint SHOULD NOT create an RTCP reporting group that comprises
    only a single local SSRC (i.e., an RTCP reporting group where the
    reporting source is the only member of the group). One situation 
where and endpoint
    might choose to create a single-SSRC group is when it
    anticipates that the group might have additional SSRCs added to it 
in
    the future.

b: An endpoint MUST NOT create an RTCP reporting group that comprises
    only a single local SSRC (i.e., an RTCP reporting group where the
    reporting source is the only member of the group), unless it is
    anticipated that the group might have additional SSRCs added to it 
in
    the future.

> That’s the most likely example, yes.

Would there ever be situations where it would apply to a first-party 
(i.e., a party involved in the SDP exchange)?

> It’s normative if you use SDP offer/answer, but not for declarative 
> SDP. Happy to move it to a normative reference.

Since the draft does talk about the offer/answer case, it seems 
appropriate to do so.

>> “... if another reporting source exists,  have it report on the 
>> remote SSRCs that the departing source reported ..."
>

Okay, how about: "...have another reporting source, if one exists, 
report on the remote SSRCs the leaving SSRC reported on..."

[...]

> Is it sufficient to change this to “If the answerer does not wish to 
> use RTCP Reporting Groups, it MUST NOT include the “a=rtcp-rgrp” 
> in the answer.”?

Even better :-)

[...]

---

From: Colin Perkins <[email-masked]>
Date: Thu, 12 Nov 2015 15:58:23 +0000

Hi,

Comments inline. I think we have agreement, so unless I hear otherwise I’ll submit an update with these fixes once the IETF last call ends.

Cheers,
Colin

> On 11 Nov 2015, at 21:59, Ben Campbell <[email-masked]> wrote:
> Two alternatives come to mind. I suspect B is closer to the intent. (And I don't think there's a problem with a conditional MUST, as long as the conditions are clear and exhaustive.)
> 
>   reporting source is the only member of the group). One situation where and endpoint
>   anticipates that the group might have additional SSRCs added to it in
>   the future.
> 
>   anticipated that the group might have additional SSRCs added to it in
>   the future.

I’m okay with B. 

> Would there ever be situations where it would apply to a first-party (i.e., a party involved in the SDP exchange)?

No, I don’t think so.

> Since the draft does talk about the offer/answer case, it seems appropriate to do so.

Will do.

> Okay, how about: “...have another reporting source, if one exists, report on the remote SSRCs the leaving SSRC reported on..."

Fine.

-- 
Colin Perkins
https://csperkins.org/

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 12 Nov 2015 10:30:20 -0600

On 12 Nov 2015, at 9:58, Colin Perkins wrote:

> Hi,
>
> Comments inline. I think we have agreement, so unless I hear otherwise 
> I’ll submit an update with these fixes once the IETF last call ends.

Works for me, thanks!

Ben.