Subject: [AVTCORE] AD Evaluation of draft-ietf-avtcore-rtp-multi-stream-09

From: "Ben Campbell" <[email-masked]>
Date: Mon, 09 Nov 2015 15:29:46 -0600

Hi,

Here is my AD evaluation of draft-ietf-avtcore-rtp-multi-stream-09:

Thanks!

Ben.

Substantive Comments:
=====================

- 3.3, last paragraph: "The endpoint MUST keep its total media sending 
rate within
    this share."

Does that need to be a 2119 "MUST"? Does it create a new normative 
requirement, or restate an existing requirement?

- 5: " ... the specification MUST be interpreted as each SSRC counting 
as a separate participant ..."

Does that really need to be a 2119 MUST? If so, please consider avoiding 
a word so open to interpretation as "interpreted".

- 5.2, Note: "... based on an TCP initial window of 4 packets, not the 
larger TCP initial windows..."

I assume this means that you borrowed the window size from tcp, not that 
this mechanism actually uses or requires tcp, right? “Based on TCP” 
is a bit confusing.

Editorial Comments:
===================

-3.3, last paragraph:

s/"to be generating" / "to generate"

- 5.3.2, last paragraph:

singular/plural mismatch between "investigations" and "has".

- 6.1, 2nd paragraph:

First sentence seems redundant to the previous paragraph.

- 6.2, 1st paragraph:

s/"...SSRCs are removed ..."/"... SSRCs be removed ..."

---

From: Colin Perkins <[email-masked]>
Date: Wed, 11 Nov 2015 15:02:15 +0000

Hi,

Thanks for the review, some responses line. Since this has gone to IETF last call, I assume these should be treated as last call comments, and an update submitted after the last call period ends.

Colin

> On 9 Nov 2015, at 21:29, Ben Campbell <[email-masked]> wrote:
> 
> Hi,
> 
> - 3.3, last paragraph: "The endpoint MUST keep its total media sending rate within
>   this share."
> 
> Does that need to be a 2119 "MUST"? Does it create a new normative requirement, or restate an existing requirement?

(4, 2nd paragraph) It’s restating an existing requirement, so could perhaps be changed to “needs to”?

> - 5: " ... the specification MUST be interpreted as each SSRC counting as a separate participant ..."
> 
> Does that really need to be a 2119 MUST? If so, please consider avoiding a word so open to interpretation as “interpreted".

This does need to be an RFC 2119 “MUST”. Maybe “for correct operation in cases where endpoints have multiple SSRC values, implementations MUST treat each SSRC as a separate participant in the RTP session” would be clearer?

> - 5.2, Note: "... based on an TCP initial window of 4 packets, not the larger TCP initial windows..."
> 
> I assume this means that you borrowed the window size from tcp, not that this mechanism actually uses or requires tcp, right? “Based on TCP” is a bit confusing.

Right. Could change to “The above is chosen to match the TCP initial window…”?

> Editorial Comments:

Will fix.

-- 
Colin Perkins
https://csperkins.org/

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 11 Nov 2015 15:45:55 -0600

On 11 Nov 2015, at 9:02, Colin Perkins wrote:

> Hi,
>
> Thanks for the review, some responses line. Since this has gone to 
> IETF last call, I assume these should be treated as last call 
> comments, and an update submitted after the last call period ends.

That is my preference. You can treat these as last call comments.

> perhaps be changed to “needs to”?

That works for me.

>> Does that really need to be a 2119 MUST? If so, please consider 
>> avoiding a word so open to interpretation as “interpreted".
>
> This does need to be an RFC 2119 “MUST”. Maybe “for correct 
> operation in cases where endpoints have multiple SSRC values, 
> implementations MUST treat each SSRC as a separate participant in the 
> RTP session” would be clearer?

Yes, thanks.

>> I assume this means that you borrowed the window size from tcp, not 
>> that this mechanism actually uses or requires tcp, right? “Based on 
>> TCP” is a bit confusing.
>

WFM.

[...]

---

From: Colin Perkins <[email-masked]>
Date: Thu, 12 Nov 2015 15:29:51 +0000

Okay, sounds like we’re in agreement on the fixes. I’ll submit an updated draft once the IETF last call ends.

Colin

> On 11 Nov 2015, at 21:45, Ben Campbell <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/