Subject: [AVTCORE] Spencer Dawkins' Yes on draft-ietf-avtcore-rfc5285-bis-12: (with COMMENT)

From: Spencer Dawkins <[email-masked]>
Date: Mon, 19 Jun 2017 13:51:02 -0700

Spencer Dawkins has entered the following ballot position for
draft-ietf-avtcore-rfc5285-bis-12: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-avtcore-rfc5285-bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I like it. I did have a couple of non-blocking questions.

I couldn't parse this sentence.

  "A transmitter may be aware that
   an intermediary may add RTP header extensions in this case, the
   transmitter SHOULD use two-byte form."

I think

   In the one-byte header form of extensions, the 16-bit value required
   by the RTP specification for a header extension, labeled in the RTP
   specification as "defined by profile", MUST have the fixed bit
   pattern 0xBEDE (the first version of this specification was written
   on the feast day of the Venerable Bede).

is flipping awesome, but likely impenetrable for folks who haven't studied
English history in the 600s and 700s. Perhaps a reference, or, more likely,
just say "May 25" so it's not a mystery?

---

From: David Singer <[email-masked]>
Date: Wed, 21 Jun 2017 09:16:20 -0400

> On Jun 19, 2017, at 16:51 , Spencer Dawkins <[email-masked]> wrote:
> 

Not sure that saying “It says BEDE because the first draft was written on May 25th” would be any clearer.  Does it matter?

David Singer
Manager, Software Standards, Apple Inc.

---

From: Warren Kumari <[email-masked]>
Date: Wed, 21 Jun 2017 09:45:25 -0400

On Wed, Jun 21, 2017 at 9:16 AM, David Singer <[email-masked]> wrote:
> Not sure that saying “It says BEDE because the first draft was written on May 25th” would be any clearer.

No, but it would make a somewhat obtuse joke significantly more so.
Depending on how perverted your sense of humor is, this may or may not
be a feature :-)

W

> Does it matter?

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 21 Jun 2017 09:17:26 -0500

I'm sorry, I wasn't clear.

> https://datatracker.ietf.org/doc/draft-ietf-avtcore-rfc5285-bis/

Not sure that saying “It says BEDE because the first draft was written on
May 25th” would be any clearer.  Does it matter?

I meant "the first version of this specification was written on May 25th, the
feast day of the Venerable Bede".

Does it matter? Probably not.

Do I hope we don't signal to readers of IETF specifications that they can
skip the parts they don't understand? I do ...

But do the right thing, of course.

Spencer

David Singer

---

From: Warren Kumari <[email-masked]>
Date: Wed, 21 Jun 2017 10:20:11 -0400

On Wed, Jun 21, 2017 at 10:17 AM, Spencer Dawkins at IETF
<[email-masked]> wrote:
> I meant "the first version of this specification was written on May 25th,
> the feast day of the Venerable Bede".
>

Well, aren't I a silly bunny? That works, maintains the "joke", and is clear...

W

---

From: David Singer <[email-masked]>
Date: Wed, 21 Jun 2017 10:42:24 -0400

I’m fine with inserting the date, but perhaps more importantly we should say “the pattern was picked for the trivial reason that…” to allay concerns about people not understanding…

> On Jun 21, 2017, at 10:20 , Warren Kumari <[email-masked]> wrote:
> 

David Singer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 21 Jun 2017 11:43:11 -0500

Hi, David,

On Jun 21, 2017 09:42, "David Singer" <[email-masked]> wrote:

I’m fine with inserting the date, but perhaps more importantly we should
say “the pattern was picked for the trivial reason that…” to allay concerns
about people not understanding…

That works for me.

And I'm enjoying the idea of a guy from the 800s being immortalized in an
RFC in 2017, so please remember that I liked you folks saying it in your
draft ...

Spencer, who should probably be scanning the list of feast days for folks
with four-byte names that are valid in hex - there can't be many more, can
there? :D

David Singer

---

From: Warren Kumari <[email-masked]>
Date: Wed, 21 Jun 2017 17:46:40 -0400

On Wed, Jun 21, 2017 at 12:43 PM, Spencer Dawkins at IETF
<[email-masked]> wrote:
> I’m fine with inserting the date, but perhaps more importantly we should say
> “the pattern was picked for the trivial reason that…” to allay concerns

I'm not religious, so I resorted to taking a list of saints from Wikipedia[0].

Taking only "real" hex characters, there are 3:
Acca of Hexham
The Venerable Bede
Cedd
($ cat saints | egrep -i -o -w '[abcdef][abcdef][abcdef][abcdef]')

Adding in some l33tsp33k (because I desperately want to avoid reading
more drafts and so am procrastinating) we get:

Abbo of Fleury (Abb0)
Saint Abib  (Ab1b)
Acca of Hexham (Acca)
Alda (A1da)
Basil the Fool for Christ (F001)
Beatrix d'Este (E57e)
Bede
Cedd
Olaf II of Norway (01af)
Ouen (Dado) (Dad0)

(cat saints | egrep -i -o -w
'[abcdefiolst][abcdefiolst][abcdefiolst][abcdefiolst]')

Some of them are, er, contrived, but I got to read about "Basil the
Fool for Christ
"(https://en.wikipedia.org/wiki/Basil_Fool_for_Christ), who
1: has possibly the most awesome name / title ever[1], and
2: according to Wikipedia (the source of all truth) "adopted an
eccentric lifestyle of shoplifting and giving to the poor to shame the
miserly..." and "went naked and weighed himself down with chains".

I now *so* want to change my name to "Warren the Fool for <something>"
(suggestions welcome)... Errr, did I mention I'm procrastinating?!

W

[0]: Even if I were religious I would resort to Wikipedia.
[1]: It even sounds like an imperative.

>>>> Please refer to
>>>> https://www.ietf.org/iesg/statement/discuss-criteria.html

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 21 Jun 2017 21:25:47 -0500

Hi, Warren,

On Wed, Jun 21, 2017 at 4:46 PM, Warren Kumari <[email-masked]> wrote:

> say

"Warren the Fool for Operations" would even have Nomcom support.

This probably needs to come up at the IETF 99 plenary :D

Spencer

---

From: Warren Kumari <[email-masked]>
Date: Thu, 22 Jun 2017 02:39:09 +0000

> "Warren the Fool for Operations" would even have Nomcom support.

WFM.

W

>> > Manager, Software Standards, Apple Inc.
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Roni Even <[email-masked]>
Date: Thu, 22 Jun 2017 11:32:28 +0000

Spencer,
According to Wikipedia https://en.wikipedia.org/wiki/Bede the date is May 26th according to http://www.catholic.org/saints/saint.php?saint_id=574 May 25th and in http://www.newadvent.org/cathen/02384a.htm it is May 27th
So is it good to write a date in the RFC? 
Roni

> -----Original Message-----
> From: Spencer Dawkins [mailto:[email-masked]]
> Sent: יום ב 19 יוני 2017 23:51
> To: The IESG
> Cc: [email-masked]; Magnus Westerlund; avtcore-
> [email-masked]; [email-masked]; [email-masked]
> Subject: Spencer Dawkins' Yes on draft-ietf-avtcore-rfc5285-bis-12: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> English history in the 600s and 700s. Perhaps a reference, or, more likely, just
> say "May 25" so it's not a mystery?
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 22 Jun 2017 07:56:32 -0500

Hi, Roni,

On Thu, Jun 22, 2017 at 6:32 AM, Roni Even <[email-masked]> wrote:

> Spencer,
> According to Wikipedia https://en.wikipedia.org/wiki/Bede the date is May
> 26th according to http://www.catholic.org/saints/saint.php?saint_id=574
> May 25th and in http://www.newadvent.org/cathen/02384a.htm it is May 27th

I'm impressed. I was expecting problems with Julian/Gregorian calendar
differences, but not what you found ...

If David's OK with putting the date he observes in the RFC (as "the first
version of this specification was written on May 25th, when the author was
observing the feast day of the Venerable Bede", or whatever the actual date
was), I'd be OK with that.

Given that we're even discussing this awesome side reference on Facebook
now, you folks could drop the whole point, but that would be sad :D ...

Spencer

> email

---

From: David Singer <[email-masked]>
Date: Thu, 22 Jun 2017 09:07:51 -0400

May 25th is right, if we care.  

<https://en.wikipedia.org/wiki/Calendar_of_saints_(Episcopal_Church)>

> On Jun 22, 2017, at 8:56 , Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Roni,
> 
> I'm impressed. I was expecting problems with Julian/Gregorian calendar differences, but not what you found ...
> 
> If David's OK with putting the date he observes in the RFC (as "the first version of this specification was written on May 25th, when the author was observing the feast day of the Venerable Bede", or whatever the actual date was), I'd be OK with that.
> 
> Given that we're even discussing this awesome side reference on Facebook now, you folks could drop the whole point, but that would be sad :D ...
> 
> Spencer
>  
> Roni
> 

David Singer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 22 Jun 2017 08:08:45 -0500

Hi, David,

> <https://en.wikipedia.org/wiki/Calendar_of_saints_(Episcopal_Church)>

Do the right thing ;-)

Spencer

> > According to Wikipedia https://en.wikipedia.org/wiki/Bede the date is
> May 26th according to http://www.catholic.org/
> saints/saint.php?saint_id=574 May 25th and in http://www.newadvent.org/
> cathen/02384a.htm it is May 27th
> > If David's OK with putting the date he observes in the RFC (as "the
> first version of this specification was written on May 25th, when the
> author was observing the feast day of the Venerable Bede", or whatever the
> actual date was), I'd be OK with that.
> >

---

From: Roni Even <[email-masked]>
Date: Thu, 22 Jun 2017 13:11:35 +0000

OK, will put May 25th 

> From: [email-masked] [mailto:[email-masked]]
> Sent: יום ה 22 יוני 2017 16:08
> To: Spencer Dawkins at IETF
> Cc: Roni Even; The IESG; [email-masked]; avtcore-
> [email-masked]; Magnus Westerlund; [email-masked]
> Subject: Re: Spencer Dawkins' Yes on draft-ietf-avtcore-rfc5285-bis-12: (with
> COMMENT)
> 
> > May 26th according to
> http://www.catholic.org/saints/saint.php?saint_id=574 May 25th and in
> http://www.newadvent.org/cathen/02384a.htm it is May 27th So is it good
> to write a date in the RFC?
> >
> > Given that we're even discussing this awesome side reference on
> Facebook now, you folks could drop the whole point, but that would be sad
> :D ...
> >
> > Spencer
> >
> > Roni
> >
> > > Cc: [email-masked]; Magnus Westerlund;
> > > avtcore- [email-masked]; [email-masked];
> > > [email-masked]
> > > When responding, please keep the subject line intact and reply to
> > > all email addresses included in the To and CC lines. (Feel free to
> > > cut this introductory paragraph, however.)
> > >
> > >
> > > Please refer to
> > > is flipping awesome, but likely impenetrable for folks who haven't
> > > studied English history in the 600s and 700s. Perhaps a reference,
> > > or, more likely, just say "May 25" so it's not a mystery?
> > >
> >
> >
> 
> David Singer