Subject: [AVTCORE] AD review of draft-ietf-payload-rtp-ttml-02

From: Barry Leiba <[email-masked]>
Date: Wed, 25 Sep 2019 23:11:03 -0400

Nicely written, and I have little to say.  My comments are minor, and can
be handled along with any other last-call comments; I will request last
call as soon as I’ve sent this note.

— Section 4.1 —

      Note that the length of data

      words will depend on the character encoding used (e.g. 8 bit words

      for UTF-8, 16 bit words for UTF-16).

A reader could be confused by “length of data words” here.  I suggest this:

NEW

      Note that the length of each data

      word depends on the character encoding used: for UTF-8 a word

      is 8 bits, while it is 16 bits for UTF-16.

— Section 4.2 —

   Documents carried in User Data Words are encoded in accordance with

   one of the defined TTML profiles specified in its registry

   [TTML-MTPR].

The antecedent to “its” isn’t clear; I suggest “in the TTML registry”.
(You might, then, even make it, “one of the defined profiles in the TTML
registry [TTML-MTPR].”)

Barry

---

From: James Sandford <[email-masked]>
Date: Thu, 26 Sep 2019 09:13:10 +0000

Noted. I'll make the changes you've suggested once last call is over. Thank you for your review.

Regards,
James

==========
James Sandford
R&D Project Engineer

BBC Research and Development
5th Floor
Dock House
MediaCityUK
Salford
M50 2LH

Tel: 030304 (09549)
Web: http://www.bbc.co.uk/rd
________________________________
From: Barry Leiba [[email-masked]]
Sent: 26 September 2019 04:11
To: [email-masked]
Cc: [email-masked]
Subject: AD review of draft-ietf-payload-rtp-ttml-02

Nicely written, and I have little to say.  My comments are minor, and can be handled along with any other last-call comments; I will request last call as soon as I’ve sent this note.

— Section 4.1 —

NEW

— Section 4.2 —

   [TTML-MTPR].

The antecedent to “its” isn’t clear; I suggest “in the TTML registry”.  (You might, then, even make it, “one of the defined profiles in the TTML registry [TTML-MTPR].”)

Barry