Subject: Re: [AVTCORE] Call for Adoption: Multiplexing Scheme Updates for QUIC

From: "Martin Thomson" <[email-masked]>
Date: Tue, 04 Aug 2020 11:46:45 +1000

On Sat, Aug 1, 2020, at 03:43, Justin Uberti wrote:
> If the goal is to be able to mux QUIC and TURN channels on the same 
> 5-tuple, I imagine that we'd probably want to first design some sort of 
> new QTURN that uses QUIC to address TURN's many shortcomings (e.g., 
> TURN authentication).

That seems to be the goal for MASQUE, but we'll see.

---

From: Justin Uberti <[email-masked]>
Date: Mon, 3 Aug 2020 22:38:52 -0700

> That seems to be the goal for MASQUE, but we'll see.

Hmm, hopefully that layer can be general enough to allow for cases like
TURN. If so, all of TURN becomes half a dozen RPCs.