Subject: Re: [AVTCORE] New Version Notification for draft-ietf-avtcore-multi-party-rtt-mix-09.txt

From: Gunnar Hellström <[email-masked]>
Date: Tue, 13 Oct 2020 20:10:56 +0200

Version --09 of draft-ietf-avtcore-multi-party-rtt-mix has been submitted.

It is intended to fulfill all comments by Paul, one earlier by James 
Hamlin, and a number of editorials.

Regards

Gunnar

Den 2020-10-13 kl. 19:53, skrev [email-masked]:
> A new version of I-D, draft-ietf-avtcore-multi-party-rtt-mix-09.txt
> has been successfully submitted by Gunnar Hellstrom and posted to the
> IETF repository.
>
> Name:		draft-ietf-avtcore-multi-party-rtt-mix
> Revision:	09
> Title:		RTP-mixer formatting of multi-party Real-time text
> Document date:	2020-10-13
> Group:		avtcore
> Pages:		37
> URL:            https://www.ietf.org/archive/id/draft-ietf-avtcore-multi-party-rtt-mix-09.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-avtcore-multi-party-rtt-mix/
> Html:           https://www.ietf.org/archive/id/draft-ietf-avtcore-multi-party-rtt-mix-09.html
> Htmlized:       https://tools.ietf.org/html/draft-ietf-avtcore-multi-party-rtt-mix-09
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-avtcore-multi-party-rtt-mix-09
>
> Abstract:
>     Real-time text mixers for multi-party sessions need to identify the
>     source of each transmitted group of text so that the text can be
>     presented by endpoints in suitable grouping with other text from the
>     same source.
>
>     Regional regulatory requirements specify provision of real-time text
>     in multi-party calls.  RFC 4103 mixer implementations can use
>     traditional RTP functions for source identification, but the mixer
>     source switching performance is limited when using the default
>     transmission characteristics with redundancy.
>
>     Enhancements for RFC 4103 real-time text mixing is provided in this
>     document, suitable for a centralized conference model that enables
>     source identification and source switching.  The intended use is for
>     real-time text mixers and multi-party-aware participant endpoints.
>     The specified mechanism build on the standard use of the CSRC list in
>     the RTP packet for source identification.  The method makes use of
>     the same "text/red" format as for two-party sessions.
>
>     A capability exchange is specified so that it can be verified that a
>     participant can handle the multi-party coded real-time text stream.
>     The capability is indicated by use of a media attribute "rtt-mixer".
>
>     The document updates RFC 4103[RFC4103]
>
>     A specifications of how a mixer can format text for the case when the
>     endpoint is not multi-party aware is also provided.
>
>                                                                                    
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
-- 
Gunnar Hellström
GHAccess
[email-masked]

---

From: Dan Mongrain <[email-masked]>
Date: Mon, 26 Oct 2020 11:20:06 -0400

After careful review of this draft, Motorola Solutions have no comments to
raise and recommend this to move forward to become a full fledged standard
at the earliest opportunity.

Thanx,
Dan

*Dan Mongrain, eng.*Principal Engineer, Standards
*Motorola Solutions*

*o*: +1.819.931.2129
*m*: +1.613.558.0764
e: [email-masked]
www.linkedin.com/in/DanMongrain

*[image:
https://www.motorolasolutions.com/content/dam/msi/images/logos/corporate/msiemailsignature.png]*

On Tue, Oct 13, 2020 at 2:11 PM Gunnar Hellström <
[email-masked]> wrote:

> > URL:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09.txt&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=3vzvIBNhRf9LbPWy-kJNRYlXYwhO2-s6Uxg7GJviNdo&e=
> > Status:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix_&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=s9XbzCiCnQhKeh4JEGH4vANFhJdcfQ_gVzYscWS6bo0&e=
> > Html:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09.html&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=mrElP6tJczLqtVLYBiW44oUVcG1uWnuBq4R7NT9rxlE&e=
> > Htmlized:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=Di3C9m1q6hBGDBoFSNkfQ-F37GKEryWXR6Tnd_tvvYs&e=
> > Diff:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=r9zRt3afJOejpUMIE5_l9arncleVqHGVcWJs3ajh_YU&e=
> >
> > Abstract:
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=DWRj6IrFQMAiIBt1g2yId8iSKSxp34jwJp38lDfsrrk&e=
>

-- 

*For more information on how and why we collect your personal 
information, please visit our Privacy Policy 
<https://www.motorolasolutions.com/en_us/about/privacy-policy.html?elqTrackId=8980d888905940e39a2613a7a3dcb0a7&elqaid=2786&elqat=2#privacystatement>.*

---

From: Brian Rosen <[email-masked]>
Date: Mon, 26 Oct 2020 11:31:51 -0400

Dan

In the IETF, you don’t represent a company.  You are an individual contributor.  Basically, we don’t care what Motorola Solutions thinks about the draft, we only care what Dan Mongrain thinks.  We acknowledge that your employer pays you to participate, and we’re clearly aware of what limits any employee has on company positions.  But if you can’t say “I think it’s ready to go”, then best be silent.

You can say “we did an internal review and I have no comments, and I recommend this draft to move forward”.

Also, there is this real oddity that nearly all standards track RFCs are “Proposed Standard” instead of a full standard.  It’s possibly to move from Proposed Standard to Standard, but a) it’s rare, b) it takes deployment experience and c) it’s a new document.

Brian

> On Oct 26, 2020, at 11:20 AM, Dan Mongrain <[email-masked]> wrote:
> 
> After careful review of this draft, Motorola Solutions have no comments to raise and recommend this to move forward to become a full fledged standard at the earliest opportunity.
> 
> Thanx,
> Dan
> Dan Mongrain, eng.
> Principal Engineer, Standards
> Motorola Solutions
> 
> 
> o: +1.819.931.2129 
> m: +1.613.558.0764
> e: [email-masked] <mailto:[email-masked]>
> www.linkedin.com/in/DanMongrain <http://www.linkedin.com/in/DanMongrain>
> 
> 
> 
> 
> On Tue, Oct 13, 2020 at 2:11 PM Gunnar Hellström <[email-masked] <mailto:[email-masked]>> wrote:
> Den 2020-10-13 kl. 19:53, skrev [email-masked] <mailto:[email-masked]>:
> > URL:            https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09.txt&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=3vzvIBNhRf9LbPWy-kJNRYlXYwhO2-s6Uxg7GJviNdo&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09.txt&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=3vzvIBNhRf9LbPWy-kJNRYlXYwhO2-s6Uxg7GJviNdo&e=> 
> > Status:         https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix_&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=s9XbzCiCnQhKeh4JEGH4vANFhJdcfQ_gVzYscWS6bo0&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix_&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=s9XbzCiCnQhKeh4JEGH4vANFhJdcfQ_gVzYscWS6bo0&e=> 
> > Html:           https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09.html&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=mrElP6tJczLqtVLYBiW44oUVcG1uWnuBq4R7NT9rxlE&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09.html&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=mrElP6tJczLqtVLYBiW44oUVcG1uWnuBq4R7NT9rxlE&e=> 
> > Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=Di3C9m1q6hBGDBoFSNkfQ-F37GKEryWXR6Tnd_tvvYs&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=Di3C9m1q6hBGDBoFSNkfQ-F37GKEryWXR6Tnd_tvvYs&e=> 
> > Diff:           https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=r9zRt3afJOejpUMIE5_l9arncleVqHGVcWJs3ajh_YU&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Davtcore-2Dmulti-2Dparty-2Drtt-2Dmix-2D09&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=r9zRt3afJOejpUMIE5_l9arncleVqHGVcWJs3ajh_YU&e=> 
> >
> > Abstract:
> > until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> >
> > The IETF Secretariat
> >
> >
> -- 
> Gunnar Hellström
> GHAccess
> [email-masked] <mailto:[email-masked]>
> 
> [email-masked] <mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=DWRj6IrFQMAiIBt1g2yId8iSKSxp34jwJp38lDfsrrk&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwIGaQ&c=q3cDpHe1hF8lXU5EFjNM_A&r=n9aaU9xSQM4-mK_yF4tJzi7SeOWS3tTUWut1BhcRBI5vMR5LUWrTKzC_1DF8wC_4&m=OpRq9nvR8Lgu7YGKMW6o__WavC2gf5iXqSYN_L4p9qA&s=DWRj6IrFQMAiIBt1g2yId8iSKSxp34jwJp38lDfsrrk&e=> 
> 
> For more information on how and why we collect your personal information, please visit our Privacy Policy <https://www.motorolasolutions.com/en_us/about/privacy-policy.html?elqTrackId=8980d888905940e39a2613a7a3dcb0a7&elqaid=2786&elqat=2#privacystatement>.
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/avt <https://www.ietf.org/mailman/listinfo/avt>

---

From: Gunnar Hellström <[email-masked]>
Date: Mon, 26 Oct 2020 20:51:02 +0100

Thanks, Dan,

Appreciated.

The only issue I have right now is that there is a dependency on 
RFC-to-be 8865  "T.140 Real-Time Text Conversation over WebRTC Data 
Channels", that has got its RFC number but is not yet published, because 
it is included in cluster C238 waiting for some other dependencies.

I hope that is sorted out soon.

Regards

Gunnar

Den 2020-10-26 kl. 16:20, skrev Dan Mongrain:
> After careful review of this draft, Motorola Solutions have no 
> comments to raise and recommend this to move forward to become a full 
> fledged standard at the earliest opportunity.
>
> Thanx,
> Dan
>
> *Dan Mongrain, eng.
> <mailto:[email-masked]>
> /https://www.motorolasolutions.com/content/dam/msi/images/logos/corporate/msiemailsignature.png/
>
>
>
>
> On Tue, Oct 13, 2020 at 2:11 PM Gunnar Hellström 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     > until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>     >
>     > The IETF Secretariat
>     >
>     >
>     -- 
>     Gunnar Hellström
>     GHAccess
> /For more information on how and why we collect your personal 
> <https://www.motorolasolutions.com/en_us/about/privacy-policy.html?elqTrackId=8980d888905940e39a2613a7a3dcb0a7&elqaid=2786&elqat=2#privacystatement>./
>