Subject: [AVTCORE] I-D Action: draft-ietf-payload-rtp-jpegxs-05.txt

From: [email-masked]
Date: Thu, 01 Oct 2020 04:47:26 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Core Maintenance WG of the IETF.

        Title           : RTP Payload Format for ISO/IEC 21122 (JPEG XS)
        Authors         : Sébastien Lugan
                          Antonin Descampe
                          Corentin Damman
                          Thomas Richter
                          Alexandre Willeme
	Filename        : draft-ietf-payload-rtp-jpegxs-05.txt
	Pages           : 28
	Date            : 2020-10-01

Abstract:
   This document specifies a Real-Time Transport Protocol (RTP) payload
   format to be used for transporting JPEG XS (ISO/IEC 21122) encoded
   video.  JPEG XS is a low-latency, lightweight image coding system.
   Compared to an uncompressed video use case, it allows higher
   resolutions and frame rates, while offering visually lossless
   quality, reduced power consumption, and end-to-end latency confined
   to a fraction of a frame.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-payload-rtp-jpegxs/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-payload-rtp-jpegxs-05
https://datatracker.ietf.org/doc/html/draft-ietf-payload-rtp-jpegxs-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-payload-rtp-jpegxs-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Antonin Descampe <[email-masked]>
Date: Mon, 5 Oct 2020 06:20:24 +0000

Dear all,

As the notification you received indicates, a new version of the RTP payload format for ISO/IEC 21122 (JPEG XS) has been submitted.

Compared to version 4, a number of changes have been brought to the document, which I summarise hereunder:

- "Marker (M) [1 bit]" (page 9) was updated to handle progressive and interlaced video streams.
- "Last (L) [1 bit]" (page 10) was re-worded.
- Figures 7 and 9 were adjusted to correctly show M and L bits.
- "Optional parameters" (page 18) was amended to cover spaces in names (replace spaces with dash).
- "level" (page 18) was amended to cover spaces in names (replace spaces with dash).
- "sublevel" (page 19) was amended to cover spaces in names (replace spaces with dash).
- Page 19-20: Some parameters were reordered.
- SDP "sampling" (page 19-20) were rewritten, an UNSPECIFIED was added.
- SDP "colorimetry" (page 20-21) now has UNSPECIFIED.
- SDP "TCS" (page 21) now has UNSPECIFIED.
- SDP "RANGE" (page 22) handles UNSPECIFIED.
- Section 6.2.4 was shortened.
- MUST was replaced by SHALL for consistency in the document and with ISO (IETF treats MUST and SHALL as the same).

We believe this new version addresses all the comments received so far. If you have any additional comment or question, please let us know. If there is none, we would appreciate guidance on how to proceed to publication.

Kind regards,

Antonin

Le 1 oct. 2020 à 13:47, [email-masked]<mailto:[email-masked]> a écrit :

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dpayload-2Drtp-2Djpegxs_&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=WQOeNxfS7RKBxTlA-1zAXS3apj-ZE2eY-7uk8JqFVBI&m=HUCR72dWSyf_VBi5Bq4aQ1G5JlqugFuZVi2Daq3Vw2M&s=lU438aH0QuhINqzWsOX_i2J7ZwYk2sEN2rn40hMcLMI&e=

There are also htmlized versions available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dpayload-2Drtp-2Djpegxs-2D05&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=WQOeNxfS7RKBxTlA-1zAXS3apj-ZE2eY-7uk8JqFVBI&m=HUCR72dWSyf_VBi5Bq4aQ1G5JlqugFuZVi2Daq3Vw2M&s=PlJ5g0cYEvgCLfBjWY78oEx-zkG4S1LZNgxd7Ds6L8M&e=
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dpayload-2Drtp-2Djpegxs-2D05&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=WQOeNxfS7RKBxTlA-1zAXS3apj-ZE2eY-7uk8JqFVBI&m=HUCR72dWSyf_VBi5Bq4aQ1G5JlqugFuZVi2Daq3Vw2M&s=b6sZwIiiMSxf0aTCEwFmvbdWUxhrFZX_I926oDLf_fY&e=

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dpayload-2Drtp-2Djpegxs-2D05&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=WQOeNxfS7RKBxTlA-1zAXS3apj-ZE2eY-7uk8JqFVBI&m=HUCR72dWSyf_VBi5Bq4aQ1G5JlqugFuZVi2Daq3Vw2M&s=3viuz9CNcXFOnA6vDMf1dCQiDj9gVgF753FLoPTzenI&e=

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=WQOeNxfS7RKBxTlA-1zAXS3apj-ZE2eY-7uk8JqFVBI&m=HUCR72dWSyf_VBi5Bq4aQ1G5JlqugFuZVi2Daq3Vw2M&s=gj39DaVJ8A5MZV62Ir9YLMBN1gTQf6Mltoc5e5-4ne8&e=.

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=WQOeNxfS7RKBxTlA-1zAXS3apj-ZE2eY-7uk8JqFVBI&m=HUCR72dWSyf_VBi5Bq4aQ1G5JlqugFuZVi2Daq3Vw2M&s=Bc6kSII4SFnmnMXgDr_ywQl01fK05FO6lu_skSrvI94&e=

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwIGaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=WQOeNxfS7RKBxTlA-1zAXS3apj-ZE2eY-7uk8JqFVBI&m=HUCR72dWSyf_VBi5Bq4aQ1G5JlqugFuZVi2Daq3Vw2M&s=gNj18sVKfY38-ZswKI8AsooIzl7TSEO0V_uXoWd95c8&e=

--
Antonin Descampe - Ph.D.
Compression technologist

IntoPIX s.a.
+32 10 23 84 70 (Office)
[email-masked]<mailto:[email-masked]>

CONFIDENTIALITY NOTICE: Unless otherwise explicitly or implictly stated, this email message and any of its attachments are the property of intoPIX SA and are strictly confidential.
If you are an unintended recipient, please notify the sender immediately.