Subject: Re: [AVTCORE] Draft Reply to Liaison Letter about Green-Mpeg Updates

From: Stephan Wenger <[email-masked]>
Date: Thu, 9 Dec 2021 16:32:43 +0000

Hi,

Wearing no hat except that of a long-time AVT (plus suborgs) contributor.

In the last sentence, I would suggest replacing “draft proposals” with “Internet Drafts” or, “at least one Internet Draft”.  In the IETF, and more specifically in AVT, we don’t generally deliberate on small, incremental, and localized proposals like MPEG does.  Instead, we expect initially self-appointed “drivers” to produce half-baked, but still fairly complete solutions to an understood problem space and improve those over time based on discussions here on the list, their own insight, and perhaps in meetings.  Note the order, which is not chosen randomly.  I would assume that the MPEG guys here on the list know all this, but it would be wrong to give the MPEG-only people the wrong impression in a reply-liaison.

As for bootstrapping the work: liaison statements don’t count.  I think the first step you MPEG folks should think about would be to present in AVT a problem/requirements statement.  That doesn’t need to be formal, you don’t have to wait for a meeting, no fancy PPT are needed, nor is the involvement of MPEG’s requirements group.  But you want to have something in writing that helps people decide whether they should pay attention to possible work in this field.  I would write an I-D.  A good second step IMO would be an I-D with enough content, including a handful of meaningful examples, that people can associate with.  Green metadata is not a topic most folks are familiar with.  You may choose to combine the two.

The submission of such an I-D (as well as other contributions to the IETF) would also trigger the IETF’s IP disclosure mechanisms, and I know many folks who would take such information into account to decide whether they are interested to contribute to a certain topic.

I leave it to you to decide whether above info should go into a reply liaison statement, or be conveyed through informal ways.  The IETF’s culture generally prefers the latter.

Stephan

From: avt <[email-masked]> on behalf of Edouard Francois <[email-masked]>
Date: Thursday, December 9, 2021 at 04:57
To: Waqar Zia <[email-masked]>, "christian.herglotz" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [AVTCORE] Draft Reply to Liaison Letter about Green-Mpeg Updates

Hi Christian, Waqar, all,

The proposed draft response looks also fine to me.
At this stage I don’t see additional points to raise in this response.

Best regards,
Edouard

De : Waqar Zia <[email-masked]>
Envoyé : Wednesday, December 8, 2021 7:45 PM
À : christian.herglotz <[email-masked]>; [email-masked]
Objet : RE: Draft Reply to Liaison Letter about Green-Mpeg Updates

Hi Christian, all,

@Christian thanks for the draft. We discussed the received MPEG LS during 112e and the following response looks appropriate. Further comments, and how to follow-up on this?

Best regards,
Waqar.

From: avt <[email-masked]<mailto:[email-masked]>> On Behalf Of Herglotz, Christian
Sent: 22 November 2021 10:38
To: [email-masked]<mailto:[email-masked]>
Subject: [AVTCORE] Draft Reply to Liaison Letter about Green-Mpeg Updates

WARNING: This email originated from outside of Qualcomm. Please be wary of any links or attachments, and do not enable macros.

Dear AVTcore experts,

at the last AVTCORE meeting, we were asked to prepare a draft reply for the LS letter from MPEG-Systems concerning green metadata. Here is our proposal:

 The IETF AVTCORE working group replies to the Liaison letter "Liaison statement to IETF on MPEG Green Metadata", Serial number 21052, from October 2021.
IETF AVTCORE working group acknowledges and appreciates your work on updating the specifications of the GREEN-MPEG standard and thinks that the following aspects could be of interest for IETF AVTCORE working group:
- The green metadata for "interactive signalling for remote decoder power reduction" is of interest for return channel signalling via, e.g., RTCP.
- It remains to be seen whether metadata signaling from the sender to the receiver could be included in IETF specifications, in particular when the content of the metadata is codec-independent (e.g., "quality recovery after low power encoding").
The AVTCORE working group is contributions driven and further work in the group can be pursued by providing draft proposals to be discussed via the AVTCORE working group email reflector.

We're happy to receive your feedback,
Best regards

Christian

---

From: Christian Herglotz <[email-masked]>
Date: Mon, 13 Dec 2021 15:18:45 +0100

Dear Stephan, dear everyone,

thanks a lot for the detailed descriptions, they are very helpful. As 
MPEG appreciates a reply to the LS letter, we propose to send the 
following reply letter for the next MPEG meeting in January. As 
mentioned by Stephan, we adopt the recommendation  to change "draft 
proposal" to "Internet Drafts".

  The IETF AVTCORE working group replies to the Liaison letter "Liaison 
statement to IETF on MPEG Green Metadata", Serial number 21052, from 
October 2021.

IETF AVTCORE working group acknowledges and appreciates your work on 
updating the specifications of the GREEN-MPEG standard and thinks that 
the following aspects could be of interest for IETF AVTCORE working group:

- The green metadata for "interactive signalling for remote decoder 
power reduction" is of interest for return channel signalling via, e.g., 
RTCP.
- It remains to be seen whether metadata signaling from the sender to 
the receiver could be included in IETF specifications, in particular 
when the content of the metadata is codec-independent (e.g., "quality 
recovery after low power encoding").

The AVTCORE working group is contributions driven and further work in 
the group can be pursued by providing Internet Drafts to be discussed 
via the AVTCORE working group email reflector.

Please let us know if you have any more feedback.

Best regards,
Christian

Am 09.12.2021 um 17:32 schrieb Stephan Wenger:
> In the last sentence, I would suggest replacing “draft proposals” with 
> “Internet Drafts” or, “at least one Internet Draft”.  In the IETF, and 
> more specifically in AVT, we don’t generally deliberate on small, 
> incremental, and localized proposals like MPEG does.  Instead, we 
> expect initially self-appointed “drivers” to produce half-baked, but 
> still fairly complete solutions to an understood problem space and 
> improve those over time based on discussions here on the list, their 
> own insight, and perhaps in meetings.  Note the order, which is not 
> chosen randomly.  I would assume that the MPEG guys here on the list 
> know all this, but it would be wrong to give the MPEG-only people the 
> wrong impression in a reply-liaison.
>
> As for bootstrapping the work: liaison statements don’t count.  I 
> think the first step you MPEG folks should think about would be to 
> present in AVT a problem/requirements statement.  That doesn’t need to 
> be formal, you don’t have to wait for a meeting, no fancy PPT are 
> needed, nor is the involvement of MPEG’s requirements group. But you 
> want to have something in writing that helps people decide whether 
> they should pay attention to possible work in this field.  I would 
> write an I-D.  A good second step IMO would be an I-D with enough 
> content, including a handful of meaningful examples, that people can 
> associate with.  Green metadata is not a topic most folks are familiar 
> with.  You may choose to combine the two.
>
> The submission of such an I-D (as well as other contributions to the 
> IETF) would also trigger the IETF’s IP disclosure mechanisms, and I 
> know many folks who would take such information into account to decide 
> whether they are interested to contribute to a certain topic.
>
> I leave it to you to decide whether above info should go into a reply 
> liaison statement, or be conveyed through informal ways.  The IETF’s 
> culture generally prefers the latter.
>
> Stephan
>
> *From: *avt <[email-masked]> on behalf of Edouard Francois 
> <[email-masked]>
> *Date: *Thursday, December 9, 2021 at 04:57
> *To: *Waqar Zia <[email-masked]>, "christian.herglotz" 
> <[email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *Re: [AVTCORE] Draft Reply to Liaison Letter about 
> Green-Mpeg Updates
>
> *De :*Waqar Zia <[email-masked]>
> *Envoyé :* Wednesday, December 8, 2021 7:45 PM
> *À :* christian.herglotz <[email-masked]>; [email-masked]
> *Objet :* RE: Draft Reply to Liaison Letter about Green-Mpeg Updates
>
> Hi Christian, all,
>
> @Christian thanks for the draft. We discussed the received MPEG LS 
> during 112e and the following response looks appropriate. Further 
> comments, and how to follow-up on this?
>
> Best regards,
>
> Waqar.
>
> *From:* avt <[email-masked]> *On Behalf Of *Herglotz, Christian
> *Sent:* 22 November 2021 10:38
> *To:* [email-masked]
> *Subject:* [AVTCORE] Draft Reply to Liaison Letter about Green-Mpeg 
> Updates
>
> *WARNING:*This email originated from outside of Qualcomm. Please be 
> wary of any links or attachments, and do not enable macros.
>
> Dear AVTcore experts,
>
> at the last AVTCORE meeting, we were asked to prepare a draft reply 
> for the LS letter from MPEG-Systems concerning green metadata. Here is 
> our proposal:
>
>  The IETF AVTCORE working group replies to the Liaison letter "Liaison 
> statement to IETF on MPEG Green Metadata", Serial number 21052, from 
> October 2021.
>
> IETF AVTCORE working group acknowledges and appreciates your work on 
> updating the specifications of the GREEN-MPEG standard and thinks that 
> the following aspects could be of interest for IETF AVTCORE working 
> group:
>
> - The green metadata for "interactive signalling for remote decoder 
> power reduction" is of interest for return channel signalling via, 
> e.g., RTCP.
> - It remains to be seen whether metadata signaling from the sender to 
> the receiver could be included in IETF specifications, in particular 
> when the content of the metadata is codec-independent (e.g., "quality 
> recovery after low power encoding").
>
> The AVTCORE working group is contributions driven and further work in 
> the group can be pursued by providing draft proposals to be discussed 
> via the AVTCORE working group email reflector.
>
-- 
Dr.-Ing. Christian Herglotz

Chair of Multimedia Communications and Signal Processing
Friedrich-Alexander University Erlangen-Nürnberg
Cauerstr. 7, D-91058 Erlangen, Germany
Tel. +49 9131 85-27117