Subject: Re: [AVTCORE] [dispatch] Request for agenda time for Game Moves over RTP

From: Cullen Jennings <[email-masked]>
Date: Mon, 7 Mar 2022 18:15:06 -0700

Perhaps AVTCORE is the right place but I'm not sure. ( Adding Avt@ietf 
to thread  )

This draft is more about defining the encoding of the position of 
objects and players than defining RTP Payload Format. It's more like the 
MIDI 1.0 specification, which I think of as a Media Format, plus the 
stuff in RFC 6295 that defined the Payload Format for MIDI.

This game state draft also needs the RTP Payload Format and clearly the 
expertise for Payload Format is in AVTCORE, but it was less clear to me 
that the other parts of actually defining the data and encoding of what 
goes in the Payload Format is in scope for AVTCORE.

I would be fine with doing this all in AVTCORE if that is all in the 
scope of AVTCORE. I can also imagine some scheme where it got split into 
two drafts (one for payload format and one for media format) but I am 
less keen on that as it just spreads stuff around too much for something 
that is pretty basic.

You have pretty solid history on all groups AVT and what is in scope so 
if you thought this fits in AVTCORE, I would glad to just pursue that 
path. I do want to figure out where to move this forward at this IETF 
and not still be asking where to do the work 6 months from now.

On 3/4/2022 1:54 PM, Magnus Westerlund wrote:
> Hi Cullen,
> 
> As AVTCORE is the WG that is chartered to standardized RTP Payload 
> formats I would think it belongs there. Any specific reason you have for 
> not taking it there? I would note that this appear to have some 
> similarities with the MIDI RTP payload format. Although you appear to 
> indicate that is actually have less problematic issues than what 
> resulted in the recovery journal solution in RFC 6295 
> https://datatracker.ietf.org/doc/rfc6295/ 
> <https://datatracker.ietf.org/doc/rfc6295/>
> 
> I think the input aspects like head, and hands location and direction 
> are fairly straight forward streaming sources that appears to match RTP 
> model for sources.
> 
> Cheers
> 
> Magnus
> 
> 
> On Fri, 2022-03-04 at 12:28 -0700, Cullen Jennings wrote:
>> I would like to figure out how/where to proceed with
>>
>> draft-jennings-dispatch-game-state-over-rtp
>>
>> This draft describes a format for encoding game moves and the state of
>> game objects over RTP. Cisco is using it for an AR/VR hologram
>> conferencing system but there are a range of uses cases.
>>
>> Could we get some time to discuss where to do this work?
>>
>> Thank you, Cullen
>>
>>
>>
>>
>> _______________________________________________
>> dispatch mailing list
>> [email-masked]  <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/dispatch  <https://www.ietf.org/mailman/listinfo/dispatch>
>>

---

From: Patrick McManus <[email-masked]>
Date: Mon, 7 Mar 2022 21:46:53 -0500

I hope AVTCORE will have a discussion about adopting this. If they decline
to do so we can certainly make room for that on the dispatch agenda as a
backup.

On Mon, Mar 7, 2022 at 8:15 PM Cullen Jennings <[email-masked]> wrote:

> >> https://www.ietf.org/mailman/listinfo/dispatch  <
> https://www.ietf.org/mailman/listinfo/dispatch>
> >>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>
>

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 7 Mar 2022 19:00:24 -0800

Do you want time on the AVTCORE agenda?

> On Mar 7, 2022, at 18:48, Patrick McManus <[email-masked]> wrote:
> 
> 
> I hope AVTCORE will have a discussion about adopting this. If they decline to do so we can certainly make room for that on the dispatch agenda as a backup.
> 
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 11 Mar 2022 14:32:16 -0800

On 3/7/2022 6:46 PM, Patrick McManus wrote:
> I hope AVTCORE will have a discussion about adopting this. If they 
> decline to do so we can certainly make room for that on the dispatch 
> agenda as a backup.
> 

Slight problem is that AVTCORE meeting is after the Dispatch meeting but 
this is going to be on the AVTCORE agenda so I think this sounds like a 
reasonable plan as long as the AVTCORE chairs don't see it as outside 
the scope of AVTCORE.