Subject: [Banana] TR: I-D Action: draft-boucadair-mptcp-plain-mode-00.txt

From: <[email-masked]>
Date: Tue, 22 Sep 2015 07:55:04 +0000

Dear all,

We submitted this I-D to discuss a proposal that aims to get rid of the encapsulation when aggregating multiple network attachments. 

Comments are more than welcome.

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : lundi 21 septembre 2015 15:31
> À : [email-masked]
> Objet : I-D Action: draft-boucadair-mptcp-plain-mode-00.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : An MPTCP Option for Network-Assisted MPTCP
> Deployments: Plain Transport Mode
>         Authors         : Mohamed Boucadair
>                           Christian Jacquenet
> 	Filename        : draft-boucadair-mptcp-plain-mode-00.txt
> 	Pages           : 12
> 	Date            : 2015-09-21
> 
> Abstract:
>    One of the promising deployment scenarios for Multipath TCP (MPTCP)
>    is to enable a Customer Premises Equipment (CPE) that is connected to
>    multiple networks (e.g., DSL, LTE, WLAN) to optimize the usage of its
>    network attachments.  Because of the lack of MPTCP support at the
>    server side, some service providers now consider a "network-assisted
>    mode" that relies upon the activation of a dedicated function called
>    MPTCP Concentrator.  This document focuses on a deployment scheme
>    where the identity of the MPTCP Concentrator(s) is explicitly
>    configured on connected hosts.
> 
>    This document specifies an MPTCP option that is used to get rid of an
>    encapsulation scheme between the CPE and the MPTCP Concentrator.
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-boucadair-mptcp-plain-mode/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-boucadair-mptcp-plain-mode-00
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Mingui Zhang <[email-masked]>
Date: Thu, 24 Sep 2015 07:31:43 +0000

Hi Med,

Thanks for the sharing. 

The draft details the addressing issue which is definitely an important issue that falls in the problem space of the bonding service. In particular, the solution for NAT-pass-through issue is described. It assumes the tunneling techniques cannot support NAT-pass-through between the CPE and the Concentrator. This document addresses that issue. I guess this is the major motivation for proposing the "plain" mode. Here, I would like to add another way to solve the same issue: the tunnel encapsulated packet can be wrapped with a UDP header, which forms a tunnel-over-UDP. By doing that, NAT-pass-through can be addressed as well. 

Traffic distribution issue is another important issue for the bonding service. This had ever been discussed on the list. I know MPTCP can well support flow based traffic distribution. However, I remember it was mentioned somewhere that MPTCP can be adapted to support per-packet load sharing among the multipaths. Will this direction be considered?

A clarification questions: from Figure 1, it is clear that one peer of the MPTCP proxy will be deployed on the CPE. What is not clear to me is where the other end is to be deployed? Will the L4 capable Concentrator be deployed on physical routers or servers?

Thanks,
Mingui

> -----Original Message-----
> From: Banana [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, September 22, 2015 3:55 PM
> To: [email-masked]
> Cc: JACQUENET Christian IMT/OLN
> Subject: [Banana] TR: I-D Action: draft-boucadair-mptcp-plain-mode-00.txt
> 
> Dear all,
> 
> We submitted this I-D to discuss a proposal that aims to get rid of the
> encapsulation when aggregating multiple network attachments.
> 
> > [email-masked] Envoyé : lundi 21 septembre 2015 15:31 À :
> > [email-masked] Objet : I-D Action:
> > draft-boucadair-mptcp-plain-mode-00.txt
> >
> >
> > submission until the htmlized version and diff are available at
> > tools.ietf.org.
> >
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Banana mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/banana