Subject: Re: [Banana] mix up the tunnel based and the MPTCP-proxy based?//RE: Slides

From: Margaret Wasserman <[email-masked]>
Date: Fri, 30 Sep 2016 06:52:43 -0400

I don't think we can really predict the relative performance, cost of deployment and congestion characteristics of a solution until that solution has been implement and used in a substantial deployment.

The existing "tunnel bonding" implementation is getting good performance  in practice and working well in a DSL/LTE environment, except in cases where the LTE quality is poor. 

MPTCP (in general) is known to perform very well, but I haven't heard any information about the performance or operational parameters of large scale MPTCP proxies, never mind for this particular use case.  I don't think that proves anything other than the fact that the MPTCP-based solution is not as far along in development, yet.

There are several known trade offs between these solutions that might make one better than another for a particular operator's network and/or for a particular use case.

I don't think it makes sense to pick one solution in this area, because of those trade-offs and because of the fact that these are all "in the network" solutions -- they don't require support on the end nodes.  So there is no negative impact on end hosts or the Internet if one provider uses one solution, and another provider uses another solution.

There may be parts of these solutions that we could harmonize (like control traffic) or there may not.  At this point though, I don't think we are in a position to say "here is the one solution that optimally meets everyone's needs".

Margaret

Sent from my iPhone

> On Aug 3, 2016, at 3:47 AM, <[email-masked]> <[email-masked]> wrote:
> 
> Hi Mingui,
> 
> 
> 
> <snip>
> Let
>> us think about the way to make the tunnel techniques handle the non-TCP traffic
>> while let MPTCP proxy handle TCP traffic.
>> 
>> Thanks,
>> Mingui
>> 
>> 
> </snip>
> 
> For sure, you can do that, but it's an (your) implementation choice, you don't need standardization, i.e. specific protocol, to set up tunnels and configuring routing policy...
> 
> Pierrick
> 
> _________________________________________________________________________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
> 
> _______________________________________________
> Banana mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/banana

---

From: Olivier Bonaventure <[email-masked]>
Date: Fri, 30 Sep 2016 23:02:43 +0200

Margaret,

> I don't think we can really predict the relative performance, cost of
> deployment and congestion characteristics of a solution until that
> solution has been implement and used in a substantial deployment.
>
> The existing "tunnel bonding" implementation is getting good performance
> in practice and working well in a DSL/LTE environment, except in cases
> where the LTE quality is poor.

I haven't seen any public information about the performance of tunnel 
bonding solutions.

> MPTCP (in general) is known to perform very well, but I haven't heard
> any information about the performance or operational parameters of large
> scale MPTCP proxies, never mind for this particular use case.

There are three network operators in Korea that use MPTCP proxies to 
bond WiFi and LTE together on smartphones and this is a massive 
deployment. A similar approach is used in Turkey as well. There is clear 
operational experience with MPTCP proxies at a large scale.

Olivier

-- 

------------------------------
DISCLAIMER.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the system manager. 
This message contains confidential information and is intended only for the 
individual named. If you are not the named addressee you should not 
disseminate, distribute or copy this e-mail. Please notify the sender 
immediately by e-mail if you have received this e-mail by mistake and 
delete this e-mail from your system. If you are not the intended recipient 
you are notified that disclosing, copying, distributing or taking any 
action in reliance on the contents of this information is strictly 
prohibited.

---

From: Margaret Cullen <[email-masked]>
Date: Fri, 30 Sep 2016 18:12:21 -0400

> On Sep 30, 2016, at 5:02 PM, Olivier Bonaventure <[email-masked]> wrote:
> 
> I haven't seen any public information about the performance of tunnel bonding solutions.

Nic Leymann has done multiple presentations on their deployment at our Bar BOFs, at least some of which have included information about performance.  His slides were sent here, but I don’t remember how much was on the slides, and how much was in response to questions. 
> There are three network operators in Korea that use MPTCP proxies to bond WiFi and LTE together on smartphones and this is a massive deployment. A similar approach is used in Turkey as well. There is clear operational experience with MPTCP proxies at a large scale.

That’s great!  Can we get one of them to come talk to us about their deployment in November?

Margaret