Subject: [Banana] BOF Description and Agenda

From: Margaret Cullen <[email-masked]>
Date: Wed, 2 Nov 2016 06:57:00 -0400

Hi All,

Here is the current BOF description and agenda (which will be posted in the next few minutes) for our upcoming BANANA BOF. 

As you can see, there is room in the agenda for someone to do a short presentation on the state of the MPTCP solution(s) that are applicable to this problem space, however a presenter has not been assigned.  We know that Olivier will not be in Seoul.  Will any of the advocates of an MPTCP solution (Med, perhaps?) be in Seoul and willing to present a quick overview?

Also, please let us know if you have any comments on the description or would like to add anything to the agenda.

Margaret

---

From: Margaret Cullen <[email-masked]>
Date: Wed, 2 Nov 2016 06:59:07 -0400

Oh, it might have helped to include the description… :-)

- Name: BANdwidth Aggregation for interNet Access (BANANA)

- Description: 
This BOF will discuss how we can take advantage of multiple access links, provided by one or more access providers, in cases where end nodes and applications may not be multi-access-aware.  Use of multiple access links could provide bandwidth aggregation when multiple links are available (i.e. improved performance), and session continuation when a link becomes unavailable (i.e. increased reliability).  

Solutions to this problem are intended to apply to home and small-office networks, so solutions must support load-sharing of a small number of flows (in some cases only one) over multiple paths, recombining the traffic in ways that do not cause problems for the network (i.e. congestion, multi-level retransmission, etc.) or for upper-layer protocols (i.e. packet reordering within flows).  Solutions in this area must allow for some traffic to bypass bandwidth aggregation (e.g. for flows that are mandated to travel a specific path, or for flows that are already using a more end-to-end bandwidth aggregation solution).  Solutions should provide minimal (if any) performance degradation when multiple links are not available, or when one or more of the links is not performing sufficiently to support increased performance to the end nodes.

This is a Non-WG-forming BOF.  The purposes of the BOF are to discuss the problem space, and determine if there is sufficient interest and energy in the IETF to pursue any work in this area.  If the interest and energy exist, further effort may be exerted to scope and charter an IETF WG.

There has been an informal group, also called BANANA, looking at a subset of this space:  the case where multiple links are provided by a single Internet access provider/operator.  Multiple solutions that could apply to this subset have been discussed within that group, including:  a MIP-Based Solution (draft-ietf-dmm-mag-multihoming), an MPTCP Proxy-based solution (merged draft forthcoming), a GRE Tunnel Bonding Solution (draft-zhang-gre-tunnel-bonding), and a 3GPP-specific solution (draft-muley-bonding-solution-hybrid-access).  The MIP-based solution was developed in the DMM WG and is proposed for publication as a Standards Track RFC.  The GRE Tunnel Bonding solution, proposed for publication as an Independent Stream RFC, has been deployed by Deutsche Telecom in a large-scale operational network.  The MPTCP solution, though not yet fully documented, presents a promising, minimal-overhead solution, especially for situations where it is only necessary to share TCP traffic between multiple links.  There are significant differences between these proposals, resulting in different technical trade-offs, many of which have been explored in the BANANA Considerations Draft (draft-mrc-banana-considerations).  Some of the solutions that have been under discussion may apply (with or without additional signaling mechanisms) to the broader problem space where the access links may not be provided by a single operator.  This ongoing work will be discussed during the BOF, as it applies to the more general problem.

There has also been ongoing work in multiple other standards organizations to describe related problems.   The Broadband Forum has produced a “Hybrid Access” problem statement for DSL/LTE bandwidth aggregation specifically for the case where the DSL and LTE links are provided by a single operator (TR-348).  Documents from the other groups are not yet publicly available.

- Agenda:
0) Administrivia (5 mins)
1) BOF Scope and Problem Description (Chairs, 10 min)
2) BANANA Solution Space & Experiences
   - GRE Tunnel Bonding
     	 - Solution Overview (Mingui Zhang, 5 min)
	 - Deployment Experience (Nicolai Leymann, 5 min)
   - MPTCP Proxy (??, 10 min)
   - Others?
3) Related Research
   - Multipath Bonding at Layer 3 (Brian Trammel, 10 min)
4) Related Work in Other SDOs
   - Broadband Forum TR-348 (Dave Allan, 5 mins)
   - Others?
5) Open Discussion (30 mins)
6) Questions & Next Steps (Chairs & ADs, 10 mins)

- Status: Non-WG Forming 
- Responsible AD: Suresh Krishnan <[email-masked]>
- BoF proponents: Mingui Zhang <[email-masked]>, Nicolai Leymann <[email-masked]>, Margaret Cullen <[email-masked]>
- BoF chairs: Brian Trammel <[email-masked]>, Margaret Cullen <[email-masked]>
- Number of people expected to attend: 100 
- Length of session (1, 1.5, 2, or 2.5 hours): 1.5 hours 
- Conflicts to avoid (whole Areas and/or WGs): Entire INT Area, Entire TSV area, TSVAREA, INTAREA WG, MPTCP, DMM, TRILL, HOMENET, BABEL, CAPPORT
- Mailing List: https://www.ietf.org/mailman/listinfo/banana 
- Draft charter:  None

- Relevant drafts/documents:
https://datatracker.ietf.org/doc/draft-zhang-banana-problem-statement 
https://datatracker.ietf.org/doc/draft-mrc-banana-considerations 
https://datatracker.ietf.org/doc/draft-zhang-gre-tunnel-bonding 
https://datatracker.ietf.org/doc/draft-boucadair-mptcp-plain-mode
https://datatracker.ietf.org/doc/draft-peirens-mptcp-transparent
https://datatracker.ietf.org/doc/draft-ietf-dmm-mag-multihoming-02
https://www.ietf.org/staging/draft-muley-bonding-solution-hybrid-access-00.txt
https://irtf.org/anrw/2016/anrw16-final21.pdf
https://www.broadband-forum.org/technical/download/TR-348.pdf

> On Nov 2, 2016, at 6:57 AM, Margaret Cullen <[email-masked]> wrote:
> 
> Hi All,
>