Subject: Re: [Banana] Charter Text w/Milestones

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 25 May 2017 20:23:03 +0200

CCs trimmed.  Nothing personal.

> It is the explicit intention that “BANANA Boxes” may be separate
> hardware components or software components running on CPE, an end
> system, etc.

I've explained (my understanding of) BANANA three times, twice in English
and once in French, and I've found the current terminology to be
reasonably practical.  "In this case, the mobile phone itself is acting as
a BANANA Box".  "Dans ce cas, le téléphone implémente lui-même BANANA."

> I am not familiar with the use of the term “functions” as you describe
> it, so it doesn’t immediately seem clearer to me.  Does it to others?

I agree, the specific term "function" is specific to a fairly specific
community.

-- Juliusz

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Fri, 26 May 2017 06:27:35 +0000

Well, the specific community seems to be networking community. Don't you agree?

- Hannu

-----Original Message-----
From: Juliusz Chroboczek [mailto:[email-masked]] 
Sent: Thursday, May 25, 2017 9:23 PM
To: Margaret Cullen <[email-masked]>
Cc: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>; [email-masked]
Subject: Re: [Banana] Charter Text w/Milestones

-- Juliusz

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 26 May 2017 10:54:06 +0200

> Well, the specific community seems to be networking community. Don't you

No, it's very specific to a certain culture.  Other cultures would use
different terms -- the Iron Age "Seven Layers" culture would say "BANANA
Service", the Broze Age "Internet" culture would say "BANANA Protocol",
while the Neolithic "ARPANET" culture would say "BANANA Program".

-- Juliusz

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Fri, 26 May 2017 11:23:17 +0000

I disagree. This term is all over in the IETF documents. It is not limited to any particular wg as such. 
Please have a look at for example:

https://tools.ietf.org/html/draft-wu-opsawg-service-model-explained-05

Service Function Chaining (SFC) Architecture
https://tools.ietf.org/html/rfc7665#page-15

and the whole set of documents from the sfc wg.

Problem Statement: Overlays for Network Virtualization uses term functionality, not "boxes"
https://www.rfc-editor.org/rfc/rfc7364.txt
  Overlay gateway functionality could be combined with other network
   functionality into a network device that implements the overlay
   functionality and then forwards traffic between other internal
   components that implement functionality such as full router service,
   load balancing, firewall support, VPN gateway, etc.

Can you show the otherwise?

- Hannu

-----Original Message-----
From: Juliusz Chroboczek [mailto:[email-masked]] 
Sent: Friday, May 26, 2017 11:54 AM
To: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>
Cc: Margaret Cullen <[email-masked]>; [email-masked]
Subject: Re: [Banana] Charter Text w/Milestones

-- Juliusz

---

From: Jordan Melzer <[email-masked]>
Date: Fri, 26 May 2017 13:09:57 +0000

"Function" means an activity or purpose of an object.  It's used widely outside of computing and networking (eg, biology and medicine).  One can make reasonable sentences with the word function.  Eg: "The gateway may perform the BANANA function in addition to its other duties."  "The brain is responsible for any number of vital physiological functions."

"Box" means a container with a flat bottom.  Computer servers have sometimes been called boxes because they are shaped like boxes and many operating systems end in "X", making for nice ear-worms: eg VAX box, UNIX box, Linux box.  Similarly, we are only having this discussion because BANANA box sounds good.  If there weren't a "B" in BANANA, nobody would want to use BANANA box.  Box makes no sense -- one thinks of a yellow box with bananas inside it -- but it is fun to say.  If we're good with BANANA, though, it's hard to argue that "box" is the problem!

I don't really care what anyone calls it.  As long as there is CMT-SCTP or some other mostly-baked solution hidden somewhere in the pile of bananas, I'm good.

-----Original Message-----
From: Banana [mailto:[email-masked]] On Behalf Of Flinck, Hannu (Nokia - FI/Espoo)
Sent: May 26, 2017 07:23 AM
To: Juliusz Chroboczek <[email-masked]>
Cc: Margaret Cullen <[email-masked]>; [email-masked]
Subject: Re: [Banana] Charter Text w/Milestones

- Hannu

-----Original Message-----
From: Juliusz Chroboczek [mailto:[email-masked]]
Sent: Friday, May 26, 2017 11:54 AM
To: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>
Cc: Margaret Cullen <[email-masked]>; [email-masked]
Subject: Re: [Banana] Charter Text w/Milestones

>> I agree, the specific term "function" is specific to a fairly 
>> specific community.

> Well, the specific community seems to be networking community. Don't 

No, it's very specific to a certain culture.  Other cultures would use different terms -- the Iron Age "Seven Layers" culture would say "BANANA Service", the Broze Age "Internet" culture would say "BANANA Protocol", while the Neolithic "ARPANET" culture would say "BANANA Program".

-- Juliusz

_______________________________________________
Banana mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/banana

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 26 May 2017 10:46:29 -0400

The charter is not a protocol specification.  We used the term "BANANA box" specifically to avoid specifying whether it was a service or a function, a router or a proxy, a piece of hardware or software, etc.  I was picturing a "box" in the sense of the "boxes and arrows" in an architectural diagram.  A "box" that, in turn, contains a BANANA signaling protocol and a BANANA encapsulation.

Presumably in each of the "encapsulations", the BANANA Box will have a more specific name like "GRE tunnel endpoint", or "MPTCP proxy", etc.

Personally I consider a GRE tunnel endpoint to perform a decapsulation _function_, while an MPTCP proxy provides a proxy _service_. So, in my lexicon (which may not match yours), neither "service" nor "function" covers all of the possibilities.

Margaret

> On May 26, 2017, at 9:09 AM, Jordan Melzer <[email-masked]> wrote:
>

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Fri, 26 May 2017 17:26:04 +0200

+1 to "banana box" is fine, but perhaps since in my milieu 90% of the time is spent looking at boxes on whiteboards and 10% of the time is spent messing around with experimental infrastructure... most of which runs on VM images we call

( +2 to "banana box" because it is much more satisfying in bikeshed discussions to ask "what color should the banana box be?" )

Cheers,

B

> On 26 May 2017, at 16:46, Margaret Wasserman <[email-masked]> wrote:
>