Subject: [Banana] FW: New Version Notification for draft-zuo-banana-mptcp-integration-00.txt

From: "Zuojing (2012 Laboratories)" <[email-masked]>
Date: Fri, 9 Jun 2017 07:51:31 +0000

Dear All，

As a follow up of the discussion we carried out on this mailing list (https://mailarchive.ietf.org/arch/msg/banana/rgItU_-OM_-FYFJMtFD12Pnj68w), we posted a draft on the “Integration of Bonding Tunnels and MPTCP” which specifies the extensions for tunnel bonding protocols to realize integrative deployment of tunnel boding solutions and MPTCP. 

The main goal of the integration is to make use of advantages of both technologies. As we know, MPTCP excels at conducting TCP traffic since its flow/congestion control scheme have been well developed while tunnel bonding protocols support not only TCP traffic but also UDP traffic.

More details are described in the draft. Comments are welcome. 

Kind regards,
Jing

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, June 08, 2017 4:49 PM
To: Cornelius Heidemann; Geng Liang; Liang Geng; Zuojing (2012 Laboratories); Vero Zheng; Nicolai Leymann
Subject: New Version Notification for draft-zuo-banana-mptcp-integration-00.txt

A new version of I-D, draft-zuo-banana-mptcp-integration-00.txt
has been successfully submitted by Jing Zuo and posted to the IETF repository.

Name:		draft-zuo-banana-mptcp-integration
Revision:	00
Title:		Integration of Bonding Tunnels and MPTCP
Document date:	2017-06-08
Group:		Individual Submission
Pages:		12
URL:            https://www.ietf.org/internet-drafts/draft-zuo-banana-mptcp-integration-00.txt
Status:         https://datatracker.ietf.org/doc/draft-zuo-banana-mptcp-integration/
Htmlized:       https://tools.ietf.org/html/draft-zuo-banana-mptcp-integration-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-zuo-banana-mptcp-integration-00

Abstract:
   BANdwidth Aggregation for interNet Access (BANANA) based on tunnel
   bonding protocols and Multipath TCP (MPTCP) are two different
   technology suites that offer subscribers with higher bandwidth and
   reliability. MPTCP excels at conducting TCP traffic since its
   flow/congestion control scheme has been well developed while tunnel
   bonding protocols support not only TCP traffic but also UDP traffic.
   The integration of the two kinds of technologies can be considered to
   make use of advantages of both. Moreover, extensions made to the
   tunnel bonding protocols can simplify the MPTCP stack and keep it
   intact. This document specifies the extensions for tunnel bonding
   protocols to realize integrative deployment of tunnel bonding
   solutions and MPTCP.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Michael Menth <[email-masked]>
Date: Tue, 13 Jun 2017 14:50:56 +0200

Dear Jing,

thanks for this draft. I agree traffic intended for a specific link
should be scheduled by the BANANA load balancer on that link
irrespective of its current state and the BANANA box must account for
that traffic to work properly. That pertains to the coexistence of
MPTCP-proxies and Banana-boxes.

Regards,

Michael

Am 09.06.2017 um 09:51 schrieb Zuojing (2012 Laboratories):
> _______________________________________________
> Banana mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/banana
> 

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: "Zuojing (2012 Laboratories)" <[email-masked]>
Date: Wed, 14 Jun 2017 09:11:56 +0000

Hi, Michael, 

Thanks for your comments.

Right, the intent of the integration is to make better use of MPTCP and bonding tunnels in those co-existence scenarios. It looks that the bonding tunnels could be easily updated to realize such integration. Hence, I would suggest our group to cover the work as specified in this draft.

Kind regards,
Jing

> From: Banana [mailto:[email-masked]] On Behalf Of Michael Menth
> Sent: Tuesday, June 13, 2017 8:51 PM
> To: Zuojing (2012 Laboratories); [email-masked]
> Subject: Re: [Banana] FW: New Version Notification for
> draft-zuo-banana-mptcp-integration-00.txt
> 
> Dear Jing,
> 
> thanks for this draft. I agree traffic intended for a specific link should be
> scheduled by the BANANA load balancer on that link irrespective of its current
> state and the BANANA box must account for that traffic to work properly. That
> pertains to the coexistence of MPTCP-proxies and Banana-boxes.
> 
> Regards,
> 
> Michael
> 
> 
> > As a follow up of the discussion we carried out on this mailing list
> (https://mailarchive.ietf.org/arch/msg/banana/rgItU_-OM_-FYFJMtFD12Pnj68
> w), we posted a draft on the “Integration of Bonding Tunnels and MPTCP”
> which specifies the extensions for tunnel bonding protocols to realize
> integrative deployment of tunnel boding solutions and MPTCP.
> >
> > The main goal of the integration is to make use of advantages of both
> technologies. As we know, MPTCP excels at conducting TCP traffic since its
> flow/congestion control scheme have been well developed while tunnel
> > To: Cornelius Heidemann; Geng Liang; Liang Geng; Zuojing (2012
> > Laboratories); Vero Zheng; Nicolai Leymann
> > Subject: New Version Notification for
> > draft-zuo-banana-mptcp-integration-00.txt
> >
> >
> > URL:
> https://www.ietf.org/internet-drafts/draft-zuo-banana-mptcp-integration-00.t
> xt
> > Status:
> https://datatracker.ietf.org/doc/draft-zuo-banana-mptcp-integration/
> > Htmlized:
> https://tools.ietf.org/html/draft-zuo-banana-mptcp-integration-00
> > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-zuo-banana-mptcp-integration-00
> >
> >
> > Abstract:
> > Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >