Subject: [Banana] How many links can be BANANA'd together?

From: Dave Dolson <[email-masked]>
Date: Tue, 18 Jul 2017 11:04:47 +0000

In the 3GPP/IETF meeting, I'm hearing a 5G end-user device may connect to up to 8 slices.
In contrast, I think some BANANA documents have explicitly referred to 2 slices.

My opinion is that BANANA should in theory permit any number of links.
And thinking of primary/secondary links might be problematic too. More of a symmetric approach to links seems appropriate.

David Dolson
Senior Software Architect
Sandvine

---

From: Jim Reid <[email-masked]>
Date: Tue, 18 Jul 2017 12:16:35 +0100

> On 18 Jul 2017, at 12:04, Dave Dolson <[email-masked]> wrote:
> 

[citation needed]

AFAICT the banana WG has just about got a charter done and there are no other documents yet.

I think a 5G pipe would be one "path" for a banana device -- handwave! -- alongside wi-fi, DSL or whatever. And if that 5G pipe uses up to 8 network slices, that'll be implementation detail for the 5G provider which is invisible to the banana device. It seems the internal workings of the 5G infrastructure is not going to be exposed to the end user devices that access it. YMMV.

---

From: David Allan I <[email-masked]>
Date: Tue, 18 Jul 2017 11:32:50 +0000

The discussion is conflating a few concepts....

We have physical interfaces, which can be subdivided for the purpose of accessing the internet or specific closed user groups or VPNs a.k.a. slices.

A BANANA function (not box) would serve for access to a slice where access was available on multiple interfaces. If my CPE wanted to do bandwidth aggregation to more than one slice, more than one function instance would be required. 

Cheers 
Dave

-----Original Message-----
From: Banana [mailto:[email-masked]] On Behalf Of Jim Reid
Sent: Tuesday, July 18, 2017 1:17 PM
To: Dave Dolson <[email-masked]>
Cc: [email-masked]
Subject: Re: [Banana] How many links can be BANANA'd together?

[citation needed]

_______________________________________________
Banana mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/banana

---

From: Pierre Pfister <[email-masked]>
Date: Tue, 18 Jul 2017 13:52:51 +0200

One single interface/link can also be used to provide multiple ways to access the network (e.g. in case of network multi-homing).
This distinction between interface and "Provisioning Domains" has been defined in [rfc7556].

A BANANA box should be able to aggregate traffic between multiple Provisioning Domains (PvDs) regardless whether those PvDs are on distinct interfaces or not.

- Pierre

> Le 18 juil. 2017 à 13:32, David Allan I <[email-masked]> a écrit :
>

---

From: Dave Dolson <[email-masked]>
Date: Tue, 18 Jul 2017 13:43:40 +0000

Let me state it another way: I think it should be possible to utilize N BANANA tunnels, where N may exceed 2.

I don't recall which draft or email I read that assumed 2.

David Dolson
Sandvine
  Original Message
From: Pierre Pfister
Sent: Tuesday, July 18, 2017 1:52 PM
To: David Allan I
Cc: Jim Reid; Dave Dolson; [email-masked]
Subject: Re: [Banana] How many links can be BANANA'd together?

- Pierre

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Tue, 18 Jul 2017 15:59:58 +0200

> On 18 Jul 2017, at 15:43, Dave Dolson <[email-masked]> wrote:
> 

+N to this.

Cheers,

Brian (as individual)

---

From: <[email-masked]>
Date: Tue, 18 Jul 2017 14:12:10 +0000

Hi,

I think there are "banana-like" deployments out there, using two links. But I agree that there is no reason to limit banana to two.

Regards

Nic

-----Ursprüngliche Nachricht-----
Von: Banana [mailto:[email-masked]] Im Auftrag von Dave Dolson
Gesendet: Dienstag, 18. Juli 2017 15:44
An: Pierre Pfister; David Allan I
Cc: Jim Reid; [email-masked]
Betreff: Re: [Banana] How many links can be BANANA'd together?

David Dolson
Sandvine
  Original Message
From: Pierre Pfister

- Pierre

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 18 Jul 2017 16:55:07 +0200

some banana-like trials started with two 3G USB dongles and ended with 
dedicated boards including up to 6 SIM cards.