Subject: Re: [Banana] Charter

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 25 Sep 2017 16:43:00 +0000

Hi Nic,

> I do not agree here. Yes, DLS+LTE is a very valid use case with a lot of
>momentum, but there are other use cases which were also mentioned during
>the BoF. E.g. Bundling of SAT + DSL (and in fact there are offerings,
>providing Internet over Satellite for home users as well with - very
>small bandwidth DSL - as a backup). Why do you assume that WiFi means
>WAN? Most of the home routers today provide WLAN and there are scenarios
>where the WLAN of different customers is being aggregated.

Ok. Lets quickly review the PS document that was used for this
discussions, draft-zhang-banana-problem-statement-03.txt ("Problem
Statement: Bandwidth Aggregation for Internet Access²)

"
1. Introduction

   Use cases of BANdwidth Aggregation for interNet Access (BANANA,
   a.k.a., Hybrid Access) are described in the Technical Report [TR-348]
   published by Broadband Forum: by providing Hybrid Access, Service

³

Your use-cases are what BBF has defined per your PS. I assumed its clearly
about DSL + LTE aggregation, that is driving this work. Now, if the
argument is we need DSL + SATRAN, please point me to one RG that has
support for DSL and Satellite, or a deployment where an RG uses Wi-Fi as a
WAN link. Sure, I also saw the comment from Margaret that "one person on
this thread mentioned wanted to aggregate two WiFi links, another person
has talked about aggregating VPN links².  I wonder, if we have we made it
so easy that we can create IETG WG¹s so easily, based on such individual
wishes, with no details on how and where its used. Its well understood
that link-aggregation has value and nothing new there. But, please present
very specific use-cases beyond BBF use-case.

Regards
Sri

On 9/25/17, 1:42 AM, "[email-masked]" <[email-masked]> wrote:

>Hi Sri,
>
>I do not agree here. Yes, DLS+LTE is a very valid use case with a lot of
>momentum, but there are other use cases which were also mentioned during
>the BoF. E.g. Bundling of SAT + DSL (and in fact there are offerings,
>providing Internet over Satellite for home users as well with - very
>small bandwidth DSL - as a backup). Why do you assume that WiFi means
>WAN? Most of the home routers today provide WLAN and there are scenarios
>where the WLAN of different customers is being aggregated.
>
>I think we should not rule out any technology for the BANANA work.
>
>Regards
>
>Nic
>
>
>-----Ursprüngliche Nachricht-----
>Von: Banana [mailto:[email-masked]] Im Auftrag von Sri
>Gundavelli (sgundave)
>Gesendet: Freitag, 22. September 2017 19:21
>An: Margaret Cullen <[email-masked]>
>Cc: David Allan I <[email-masked]>; Muley, Praveen (Nokia -
>US/Mountain View) <[email-masked]>; Alexandre Petrescu
><[email-masked]>; Suresh Krishnan
><[email-masked]>; David Sinicrope
><[email-masked]>; Henderickx, Wim (Nokia - BE/Antwerp)
><[email-masked]>; [email-masked]
>Betreff: Re: [Banana] Charter
>
>
>
>On 9/22/17, 10:09 AM, "Margaret Cullen" <[email-masked]> wrote:
>
>>
>>> On Sep 22, 2017, at 11:53 AM, Sri Gundavelli (sgundave)
>>><[email-masked]> wrote:
>>> 
>>> IF we step back, the motivation for this work is DSL + LTE aggregation.
>>
>>Actually, there are quite a few people who have indicated that they
>>would like to aggregate other link types.  There was a presentation at
>>IETF-97 about aggregating LTE and Wifi, one person on this thread
>>mentioned wanted to aggregate two WiFi links, another person has talked
>>about aggregating VPN links. etc.
>>
>
>So, LTE and DSL are out;  WiFi as a WAN link to home is not a known
>service; SATRAN access to home is unheard of.
>
>So, what are the two remaining links that are not WiFi, LTE, DSL, SATRAN
>and not aggregation?
>
>
>
>
>_______________________________________________
>Banana mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/banana

---

From: Margaret Cullen <[email-masked]>
Date: Mon, 25 Sep 2017 13:43:44 -0400

Hi Sri,

The problem statement you are quoting was never presented in a BOF, and there is no expectation that it will be a work item of the currently proposed WG.  It is an old, expired I-D, from before the group had reached an understanding of our current scope and focus  Even at the time it was posted, feedback indicate that it was too DSL/LTE & BBF-specific. 

The “BANANA Scope and Problem Description” presented at the Informational BOF at IETF-97 can be found here:
https://datatracker.ietf.org/meeting/97/materials/slides-97-banana-banana-scope-and-problem-description/ <https://datatracker.ietf.org/meeting/97/materials/slides-97-banana-banana-scope-and-problem-description/>

That presentation represents where we were in discussing/refining our problem statement and scope as of November of 2016.  As you can see, it is not DSL/LTE-specific, at all. 

Our thinking about the problem was refined considerably on the BANANA mailing list after IETF-97, and at this point the current problem statement and scope for the proposed WG can be found in the first few paragraphs of the charter text.

Margaret

> On Sep 25, 2017, at 12:43 PM, Sri Gundavelli (sgundave) <[email-masked]> wrote:
> 
> Hi Nic,
>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 25 Sep 2017 17:57:37 +0000

Hi Margaret,

Ok. But, the IETF 97 discussions have closed with no agreement on the problem statement.

Please point me to a document where a CPE uses multiple Wi-Fi interfaces as WAN links, who is the provider, deployment model and the use-case driving that link aggregation.

Also, the use case around the idea of using a satellite link and DSL link (with such asymmetric link characteristics) for link aggregation and the idea of per-packet load balancing.

Some pointers will help…

Sri

From: Margaret Cullen <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 25, 2017 at 10:43 AM
To: Microsoft Office User <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Banana] Charter

Hi Sri,

The “BANANA Scope and Problem Description” presented at the Informational BOF at IETF-97 can be found here:
https://datatracker.ietf.org/meeting/97/materials/slides-97-banana-banana-scope-and-proble-description/<https://datatracker.ietf.org/meeting/97/materials/slides-97-banana-banana-scope-and-problem-description/>

Margaret

On Sep 25, 2017, at 12:43 PM, Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Nic,

"
1. Introduction

³

Regards
Sri

On 9/25/17, 1:42 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sri,

Regards

Nic

-----Ursprüngliche Nachricht-----
Von: Banana [mailto:[email-masked]] Im Auftrag von Sri
Gundavelli (sgundave)
Gesendet: Freitag, 22. September 2017 19:21
An: Margaret Cullen <[email-masked]<mailto:[email-masked]>>
Cc: David Allan I <[email-masked]<mailto:[email-masked]>>; Muley, Praveen (Nokia -
US/Mountain View) <[email-masked]<mailto:[email-masked]>>; Alexandre Petrescu
<[email-masked]<mailto:[email-masked]>>; Suresh Krishnan
<[email-masked]<mailto:[email-masked]>>; David Sinicrope
<[email-masked]<mailto:[email-masked]>>; Henderickx, Wim (Nokia - BE/Antwerp)
<[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [Banana] Charter

On 9/22/17, 10:09 AM, "Margaret Cullen" <[email-masked]<mailto:[email-masked]>> wrote:

On Sep 22, 2017, at 11:53 AM, Sri Gundavelli (sgundave)
<[email-masked]<mailto:[email-masked]>> wrote:

_______________________________________________
Banana mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/banana

_______________________________________________
Banana mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/banana

---

From: <[email-masked]>
Date: Tue, 26 Sep 2017 07:12:49 +0000

Hi,

the document expired in May. It was written quite a while ago in order to support the initial discussions around bandwidth aggregation based on one use case. We already said at that time, that the scope of BANANA should be broader and not focus only on two specific technologies (like DSL/LTE). With the existing charter I see the draft more in a "historic" context and clearly not as a potential working group document.

Regards

Nic

-----Ursprüngliche Nachricht-----
Von: Sri Gundavelli (sgundave) [mailto:[email-masked]] 
Gesendet: Montag, 25. September 2017 18:43
An: Leymann, Nicolai <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Betreff: Re: AW: [Banana] Charter

Hi Nic,

> I do not agree here. Yes, DLS+LTE is a very valid use case with a lot 
>of momentum, but there are other use cases which were also mentioned 
>during the BoF. E.g. Bundling of SAT + DSL (and in fact there are 
>offerings, providing Internet over Satellite for home users as well 
>with - very small bandwidth DSL - as a backup). Why do you assume that 
>WiFi means WAN? Most of the home routers today provide WLAN and there 
>are scenarios where the WLAN of different customers is being aggregated.

Ok. Lets quickly review the PS document that was used for this discussions, draft-zhang-banana-problem-statement-03.txt ("Problem
Statement: Bandwidth Aggregation for Internet Access²)

"
1. Introduction

³

Your use-cases are what BBF has defined per your PS. I assumed its clearly about DSL + LTE aggregation, that is driving this work. Now, if the argument is we need DSL + SATRAN, please point me to one RG that has support for DSL and Satellite, or a deployment where an RG uses Wi-Fi as a WAN link. Sure, I also saw the comment from Margaret that "one person on this thread mentioned wanted to aggregate two WiFi links, another person has talked about aggregating VPN links².  I wonder, if we have we made it so easy that we can create IETG WG¹s so easily, based on such individual wishes, with no details on how and where its used. Its well understood that link-aggregation has value and nothing new there. But, please present very specific use-cases beyond BBF use-case.

Regards
Sri

On 9/25/17, 1:42 AM, "[email-masked]" <[email-masked]> wrote:

>Hi Sri,
>
>I do not agree here. Yes, DLS+LTE is a very valid use case with a lot 
>of momentum, but there are other use cases which were also mentioned 
>during the BoF. E.g. Bundling of SAT + DSL (and in fact there are 
>offerings, providing Internet over Satellite for home users as well 
>with - very small bandwidth DSL - as a backup). Why do you assume that 
>WiFi means WAN? Most of the home routers today provide WLAN and there 
>are scenarios where the WLAN of different customers is being aggregated.
>
>>mentioned wanted to aggregate two WiFi links, another person has 
>>talked about aggregating VPN links. etc.
>>
>
>So, what are the two remaining links that are not WiFi, LTE, DSL, 
>SATRAN and not aggregation?
>
>
>
>