Subject: [Banana] Use of Existing IETF Protocols

From: Margaret Cullen <[email-masked]>
Date: Tue, 19 Sep 2017 08:44:13 -0400

The current text in the charter can be interpreted to say that we intend to produce three new “BANANA protocols" for provisioning, signaling and encapsulation, even if there are existing IETF protocols that would work for that purpose.  I don’t think that was anyone’s intention.  For instance, I think we would all expect to produce a DHCP option or RA record, or something similar, for provisioning, rather than inventing a new provisioning protocol.  To make this more clear in the charter, I would propose the following change:

OLD:

The BANANA WG will consider existing IETF protocols, where applicable, as the basis for the work items listed above.

NEW:

The BANANA WG will consider existing IETF protocols, or extensions to existing IETF protocols, as the basis for the work items listed above.  If an existing protocol is used, the WG deliverable could be a document describing the use of that protocol for Bandwidth Aggregation and/or a set of options or extensions to an existing IETF protocol to make it useful for Bandwidth Aggregation.

Thoughts?

Sri, would this address your concern about the WG intending to produce three new protocols, even if suitable IETF protocols already exist?

Margaret

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 19 Sep 2017 16:15:48 -0700

This approach looks good to me. I think we could be still more explicit that the intention is to use existing protocols, if we'd like to err on that side.

"When applicable, the BANANA WG will use existing IETF protocols, or extensions to existing IETF protocols, as the basis for the work items listed above.  Whenever an existing protocol is used, the WG deliverable will be a document describing the use of that protocol for Bandwidth Aggregation and/or a set of options or extensions to an existing IETF protocol to make it useful for Bandwidth Aggregation."

This is just a more extreme version; your proposed text would work quite well as-is.

Thanks,
Tommy

> On Sep 19, 2017, at 5:44 AM, Margaret Cullen <[email-masked]> wrote:
> 
> _______________________________________________
> Banana mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/banana

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 19 Sep 2017 22:17:49 -0400

At the BOF, when we first wrote extent about the use of existing IETF protocols, there was pushback that we should only use existing IETF protocols if they are the best choice for this application.  I was attempting to find a line between some people's insistence that we should use existing protocols if at all possible, and others' opinion that we should build the best solution, using existing protocols when that makes sense.  Personally, I think we should leave it up to the WG to make those trade-offs.

Margaret

Margaret

Sent from my iPhone

> On Sep 19, 2017, at 7:15 PM, Tommy Pauly <[email-masked]> wrote:
>