Subject: [BEHAVE] RE: ICE performance

From: "Dan Wing" <[email-masked]>
Date: Tue, 17 Jul 2007 11:10:53 -0700

> > > Is it also subsecond on average between any two points on 
> > > the globe?
> > 
> > Most of the time, yes.
> 
> Er, I don't mean to be contrarian, but without data or direct 
> experience, how can you claim this? 

By analyzing the protocol.

> I think you'll find as you get real-world data and experience 
> that all this works much slower and less reliably than you'd
> expect.  At least, that has been my experience.  Thus I'd 
> respectfully ask that we stick to the data, and avoid (or at 
> least label) guesswork.

That's fair.

> > ICE always establishes a direct, peer-to-peer connection 
> > when it can.
> 
> Heh, this is a safe statement!

ICE doesn't perform magic; many people think it does.

> > In some cases [such as two endpoints behind 'symmetric' 
> > NATs (RFC3489
> > terminology) or non-Endpoint-Independent Mapping NATs (RFC4787
> > terminology)] there is no reliable technique to get a 
> > direct peer-to-
> > peer connection.  The unreliable technique to establish a direct
> > peer-to-peer connection in that situation is to guess the 
> > port number assigned by the remote NAT.
> 
> Correct.  Does ICE support this? 

No, ICE doesn't do that.  Doing such hunting is only has a chance 
of success if the NAT is quiescent and if the NAT has some 
predictability in its UDP port assignment (assigns the next-
higher port, for example).

> I haven't had great luck with it myself,
> but I haven't put a lot of energy into it yet.

Some NAT traversal techniques (such as in some games) try to 
guess ports, and exchange tokens (much like ICE's usernames) to
see if they're talking to the intended peer. 

I wouldn't recommend using that technique.

-d

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Philip Matthews <[email-masked]>
Date: Thu, 19 Jul 2007 09:05:30 -0400

> I wouldn't recommend using that technique.

I will just note that Saikat implemented port prediction in his TCP  
study
and found it worked pretty well.

http://www.guha.cc/saikat/pub/imc05-tcpnat.pdf

However, I think his setup was more of
a test setup rather than a production setup.

Perhaps Saikat can tell us more.

- Philip