Subject: Re: [BEHAVE] NAT64 and MIPv6

From: Dave Thaler <[email-masked]>
Date: Tue, 1 Sep 2009 15:21:22 +0000

Hesham writes:
> At the very least any solution should highlight this as a requirement for
> MNs because 3775 doesn't limit the DNS queries to the home DNS. But I
> don't
> know how to do that if the presence of a NAT is not known to the host.

I agree that 3775 is defective by not mentioning this,
since again the presence of a NAT does not introduce
this problem... it already breaks with private namespaces
and 3775 should have pointed out how to make DNS work.

-Dave

---

From: Dave Thaler <[email-masked]>
Date: Tue, 1 Sep 2009 15:24:36 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Dave Thaler
> Sent: Tuesday, September 01, 2009 8:21 AM
> To: Hesham Soliman; Wassim Haddad
> Cc: Wassim Haddad; [email-masked]
> Subject: Re: [BEHAVE] NAT64 and MIPv6
>
> Hesham writes:

Another thing... I disagree that the NAT64 or DNS64
document should discuss this issue.  I believe it
belongs in a separate document that covers the issues
with mobile IP resulting from both private namespaces
and private address spaces.  It's not specific to
translation so it's arguably better done in a MIP
group rather than Behave, although Behave should certainly
review it.  That's what I'd recommend anyway.

-Dave

---

From: Cameron Byrne <[email-masked]>
Date: Tue, 1 Sep 2009 08:25:59 -0700

> review it.  That's what I'd recommend anyway.

Agreed.

---

From: Wassim Haddad <[email-masked]>
Date: Tue, 1 Sep 2009 12:13:54 -0400

> At the very least any solution should highlight this as a requirement
> for MNs because 3775 doesn't limit the DNS queries to the home DNS.
> But I don't know how to do that if the presence of a NAT is not known
> to the host.

I agree that 3775 is defective by not mentioning this, since again the presence of a NAT does not introduce this problem... it already breaks with private namespaces and 3775 should have pointed out how to make DNS work.

=> Just to clarify: you mean RFC 3775 is defective by not mentioning that "the MN should NOT rely on the DNS in the foreign network when using MIPv6 (i.e., its home address). Instead, it should/must rely on the home DNS".

Is that correct?

Wassim H.

---

From: Dave Thaler <[email-masked]>
Date: Tue, 1 Sep 2009 16:16:15 +0000

Yes.

> From: Wassim Haddad [mailto:[email-masked]]
> Sent: Tuesday, September 01, 2009 9:14 AM
> To: Dave Thaler; [email-masked]
> Cc: [email-masked]; Wassim Haddad
> Subject: RE: [BEHAVE] NAT64 and MIPv6
>
> I agree that 3775 is defective by not mentioning this, since again the
> presence of a NAT does not introduce this problem... it already breaks
> with private namespaces and 3775 should have pointed out how to make DNS
> work.
>
> => Just to clarify: you mean RFC 3775 is defective by not mentioning that
> "the MN should NOT rely on the DNS in the foreign network when using MIPv6
> (i.e., its home address). Instead, it should/must rely on the home DNS".
>
> Is that correct?
>
>
> Wassim H.
>

---

From: Wassim Haddad <[email-masked]>
Date: Tue, 1 Sep 2009 12:30:09 -0400

Yes.

=> OK. This also means:

"When the MN reboots in the foreign network, then it should/must rely on the foreign 
DNS in order to be able to communicate with its HA (i.e., turn on MIPv6)". 

Thanks!
Wassim H.

> > At the very least any solution should highlight this as a 
> > requirement for MNs because 3775 doesn't limit the DNS queries to the home DNS.
> > But I don't know how to do that if the presence of a NAT is not 
> > known to the host.
>
> with private namespaces and 3775 should have pointed out how to make 
> DNS work.
>
> => Just to clarify: you mean RFC 3775 is defective by not mentioning 
> that "the MN should NOT rely on the DNS in the foreign network when 
> using MIPv6 (i.e., its home address). Instead, it should/must rely on the home DNS".
>
> Is that correct?
>
>
> Wassim H.
>

_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 01 Sep 2009 11:12:52 -0700

Hello folks,

I disagree that this represents a defect in RFC 3775.
Mobile IPv6 is a network-layer protocol, and does not
depend in any way on DNS for its operation.

Now if, in the future, all IETF documents are required to
include a "Incompatible IP Address Domains Considerations"
section -- then in that case, I would agree that this problem
would then require a remedy in RFC 3775bisbisbisbis...

On the other hand, I would not oppose an appendix
describing the pitfalls.

On the third hand (or is that a foot?) any such discussion
about defects in Mobile IPv6 deserves to have at least
some visibility in the [mext] working group.  Doesn't
seem quite right for [behave] to quickly adopt a consensus
position without even asking about it in [mext].

Does someone want to contribute a problem report
against RFC 3775 on this issue?

Regards,
Charlie P.

---

From: Dave Thaler <[email-masked]>
Date: Tue, 1 Sep 2009 18:30:18 +0000

> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Tuesday, September 01, 2009 11:13 AM
> To: Dave Thaler
> Cc: Wassim Haddad; [email-masked]; [email-masked]

IPv6 is a network-layer protocol and does not depend
in any way on upper-layer protocols for its operation,
but RFC 2460 contains section 8 "upper-layer protocol issues".

> On the other hand, I would not oppose an appendix

That's along the lines of what I was referring to yes.

> position without even asking about it in [mext].

I don't know why you're referring to a [behave]
consensus position.  I already stated in the thread
that such a document belongs in a MIP related WG not
in Behave.  Perhaps you missed that.

-Dave

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 01 Sep 2009 11:34:56 -0700

Hello Dave,

Yes, I did miss the email where you said that.
I thought I'd read through all thousand of them,
but now I see there are more :-)  And, my
suggestion of a [behave] consensus was
purely hypothetical and not based on any
formal position, but instead only on what
I had read from the previous emails.

Regards,
Charlie P.

---

From: Wassim Haddad <[email-masked]>
Date: Tue, 1 Sep 2009 17:42:47 -0400

Hi Charles,

AFAIK, there is no consensus nor an attempt to build consensus within Behave WG. There was a
comment from Dave about MIPv6 which I tried to clarify with him in my previous email in the
form of a "text".

Personally, I am not in favor of limiting MIPv6 to work only in such configuration.

Regards,

Wassim H.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Charles E. Perkins
Sent: Tuesday, September 01, 2009 12:35 PM
To: Dave Thaler
Cc: [email-masked]
Subject: Re: [BEHAVE] NAT64 and MIPv6

Hello Dave,

Yes, I did miss the email where you said that.
I thought I'd read through all thousand of them, but now I see there are more :-)  And, my suggestion of a [behave] consensus was purely hypothetical and not based on any formal position, but instead only on what I had read from the previous emails.

Regards,
Charlie P.

Dave Thaler wrote:
>
>> On the third hand (or is that a foot?) any such discussion about
>> defects in Mobile IPv6 deserves to have at least some visibility in
>> the [mext] working group.  Doesn't seem quite right for [behave] to
>> quickly adopt a consensus position without even asking about it in
>> [mext].
>>
>
> I don't know why you're referring to a [behave] consensus position.  I
> already stated in the thread that such a document belongs in a MIP
> related WG not in Behave.  Perhaps you missed that.
>
> -Dave
>

---

From: Xing Li <[email-masked]>
Date: Wed, 02 Sep 2009 12:04:32 +0800

Dave Thaler 写道:
>> for

I think this should be the way to move forward. xing