Subject: [BEHAVE] using IPv4-mapped DNS/DNS64 resolvers for dual-stack/IPv6-only hosts

From: "Dan Wing" <[email-masked]>
Date: Fri, 12 Feb 2010 12:00:39 -0800

A few weeks ago there was an active thread on BEHAVE and [email-masked],
worrying about how a network containing a mix of dual-stack hosts and
IPv6-only hosts would work.  Ideally, to prevent unnecessary address family
translation, the dual-stack hosts should use a 'normal' DNS resolver and the
IPv6-only hosts should use a DNS64 resolver.  However, it is difficult to
detect if a host is dual-stack or is IPv6-only.

So, I wrote an Internet Draft describing details of several approaches that
had been discussed on the mailing list, and attempted to provide a list of
advantages/disadvantages to each.

While writing them down, I came up with another approach which uses an
IPv4-mapped address in the list of IPv6 DNS servers.  An IPv6-only host cannot
use that address, so it would use the next DNS server on the list; a
dual-stack host can use such a DNS server.  Details are in:

http://tools.ietf.org/html/draft-wing-behave-dns64-config-02#section-3.1

Please comment on this approach.  For whatever it's worth, the idea seems to
work.

-d

---

From: Simon Perreault <[email-masked]>
Date: Fri, 12 Feb 2010 15:31:15 -0500

> http://tools.ietf.org/html/draft-wing-behave-dns64-config-02#section-3.1

I'm slow... What's the advantage of this over using a plain IPv4 address?

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 12 Feb 2010 13:10:38 -0800

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Simon Perreault
> Sent: Friday, February 12, 2010 12:31 PM
> To: [email-masked]
> Subject: Re: [BEHAVE] using IPv4-mapped DNS/DNS64 resolvers 
> for dual-stack/IPv6-only hosts
> 

DHCPv6 only allows IPv6 addresses, 
http://tools.ietf.org/html/rfc3646#section-3

-d

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 12 Feb 2010 17:39:47 -0500

> Please comment on this approach.  For whatever it's worth, the idea seems to

This is _before_ any DNS64 is happening, right?  That is, it's a way
to convince the dual-homed host to use the "plain" DNS for v4 queries
and the DNS64 for v6 queries, without a lot of complicated
co-ordination?  If I've read it right, it seems like a good idea to
me.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 17 Feb 2010 09:44:45 -0800

> [mailto:[email-masked]] On Behalf Of Andrew Sullivan
> Sent: Friday, February 12, 2010 2:40 PM
> To: [email-masked]
> Subject: Re: [BEHAVE] using IPv4-mapped DNS/DNS64 
> resolversfor dual-stack/IPv6-only hosts
> 
> This is _before_ any DNS64 is happening, right? 

Correct.

-d

> That is, it's a way
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave