Subject: Re: [BEHAVE] draft-korhonen-edns0-synthesis-flag splitted and updated

From: Cameron Byrne <[email-masked]>
Date: Fri, 1 Oct 2010 21:01:08 -0700

On Fri, Sep 24, 2010 at 8:26 AM,  <[email-masked]> wrote:
> Hi Behave,
>
> We updated and split draft-korhonen-edns0-synthesis-flag into two.
>
> Now there is:
>
> draft-korhonen-edns0-synthesis-flag-01.txt that describes a EDNS0 *option* for communicating the address format used by DNS64 in the synthesis. This replaces the previous proposal of using EDNS0 flag bits. This requires support from DNS64.
>
> draft-savolainen-heuristic-nat64-discovery (sorry I forgot "behave" on the name) that describes solution where host queries AAAA record of known IPv4-only name and then heuristically tries to resolve the address format used by the DNS64. This does not require any support from DNS64.
>

I think  draft-savolainen-heuristic-nat64-discovery is a very good
effort and should solve many  of the IPv4 referral issues.

Do you think it makes sense to add guidance that a /96 is the
preferred Pref64 and that aids in extracting the IPv4 address?  /96 is
also the size of the WKP.  I imagine that the extraction process has
to iterates to find the IPv4 address, so providing some guidance about
the use of /96 can assist in a quicker match?

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 4 Oct 2010 11:37:28 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Cameron Byrne
> Sent: Friday, October 01, 2010 9:01 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [BEHAVE] draft-korhonen-edns0-synthesis-flag splitted and
> updated
> 
> > draft-korhonen-edns0-synthesis-flag-01.txt that describes a EDNS0
> *option* for communicating the address format used by DNS64 in the
> synthesis. This replaces the previous proposal of using EDNS0 flag
> bits. This requires support from DNS64.
> >
> > draft-savolainen-heuristic-nat64-discovery (sorry I forgot "behave"
> on the name) that describes solution where host queries AAAA record of
> known IPv4-only name and then heuristically tries to resolve the
> address format used by the DNS64. This does not require any support
> from DNS64.
> >
> 

Any address discovery mechanism needs to support all address formats 
described in draft-ietf-behave-address-format.   Otherwise, we would 
effectively profile (limit) draft-ietf-behave-address-format.  The
address formats described in draft-ietf-behave-address-format include
a non-/96 prefix because CERNET2 made a conscious and deliberate 
operational decision to use a prefix other than /96 in their network.
Other operators may reach that same decision.  It's too early to 
say, as there are only a few IPv6-only networks.

To aid draft-savolainen-heuristic-nat64-discovery with finding a prefix
other than /96, it could perform multiple AAAA queries in order to find 
the prefix.  In the /96 case, it can perform its work with one DNS
query.

-d