Subject: Re: [BEHAVE] CGN Requirements: logging (draft-ietf-behave-lsn-requirements)

From: Qiong <[email-masked]>
Date: Tue, 1 Nov 2011 16:41:11 +0800

Hi Olivier,

On Tue, Nov 1, 2011 at 1:32 PM, Olivier Vautrin <[email-masked]>wrote:

> I agree. What about "SHOULD" support per-connection if logging is not
> needed. "SHOULD" support bulk port allocation if Logging is needed.
>
> +1. I also think bulk port allocation is rather important for logging,
especially for large-scale operators.

Best wishes

Qiong

> Cheers,
> Olivier
>
> On 10/28/11 8:21 PM, "Benson Schliesser" <[email-masked]> wrote:
>
> >
> >On Oct 28, 2011, at 7:44 PM, Olivier Vautrin wrote:
> >
> >> What about the "bulk port allocation"? The draft is explaining in detail
> >> the mechanism but do not give any recommendation. I think we should at
> >> least have a "SHOULD" to support the bulk port allocation. It is
> >>difficult
> >> to believe that in the future, service providers we will still log all
> >>the
> >> sessions on a CGN device.
> >
> >I tend to agree with your conclusion.  However, if we do per-connection
> >allocation of ports, then there might be benefits to the CGN operator and
> >users.  For instance, there might be improved security and more efficient
> >utilization of CGN port resources.  Thus, an operator that doesn't care
> >about logging might not want to use bulk port allocation.
> >
> >My opinion is that if we say that a CGN "SHOULD" do bulk port allocation,
> >then we should also say that it "MAY" do per-connection port allocation
> >(based on the rationale I just described).  Thoughts on this?
> >
> >Cheers,
> >-Benson
> >
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

---

From: Maglione Roberta <[email-masked]>
Date: Tue, 1 Nov 2011 17:45:28 +0100

Hello,
    I support Olivier’s proposal, the "bulk port allocation" is an important feature for logging reduction.

Roberta

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Olivier Vautrin [[email-masked]]
Sent: Tuesday, November 01, 2011 6:32 AM
To: Benson Schliesser
Cc: [email-masked]; Dan Wing
Subject: Re: [BEHAVE] CGN Requirements: logging (draft-ietf-behave-lsn-requirements)

Cheers,
Olivier

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Simon Perreault <[email-masked]>
Date: Tue, 01 Nov 2011 21:03:58 -0400

> needed. "SHOULD" support bulk port allocation if Logging is needed.

But we don't necessarily need bulk port allocation even when logging is needed.
See for example draft-donley-behave-deterministic-cgn, which significantly
reduces the need for logging without bulk port allocation (even if it does work
well with bulk port allocation).

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Cameron Byrne <[email-masked]>
Date: Tue, 1 Nov 2011 18:38:37 -0700

> well with bulk port allocation).

Sounds to me there is no ONE recommendation. That being the case, no
recommendation should be made unless their is a desire to account for all
the combinations with pros and cons, or cover this topic in seperate
document.

Cb

---

From: Simon Perreault <[email-masked]>
Date: Tue, 01 Nov 2011 21:44:52 -0400

Cameron Byrne wrote, on 11/01/2011 09:38 PM:
> recommendation should be made unless their is a desire to account for all the
> combinations with pros and cons, or cover this topic in seperate document.

Yes, that's what I was getting to. I don't think we have enough operational
experience at this point to make a recommendation that will stand. People seem
to be exploring all directions, which is good, but I think that we need to move
on and stay with the "no normative text" guidance we had at the last meeting.

Simon