Subject: [BEHAVE] Logging drafts port block allocation/deallocation - feedback required

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Tue, 3 Dec 2013 03:42:02 +0000

Tom and I had some offline discussions on the port block allocation/deallocation mechanics. We would like to solicit some feedback on this.
Essentially, the questions boil down to these two:
1. If the non-contiguous ports are useful/necessary. What we mean is if 32 ports are allocated for a user, can they be 1024, 1026, 1028…. Etc?
2. If multiple ranges is to be logged in a single log event. For eg. Ports 1024-1047 and 5000-5010 are allocated for a user, can we log them as two events.
I think the answer to this question probably goes to if NAT implementations would/should do this.

Thanks
Senthil

---

From: Simon Perreault <[email-masked]>
Date: Tue, 03 Dec 2013 10:11:08 -0500

I vividly remember an exchange about this very topic in the BEHAVE 
meeting at IETF 87. But it's not in the minutes. I bet you could find it 
by listening to the audio:

http://www.ietf.org/audio/ietf87/ietf87-charlottenburg1-20130729-1300-pm.mp3

It should be in the fist ~10 minutes.

Simon

Le 2013-12-02 22:42, Senthil Sivakumar (ssenthil) a écrit :
> Tom and I had some offline discussions on the port block
> allocation/deallocation mechanics. We would like to solicit some
> feedback on this.
> 1. If the non-contiguous ports are useful/necessary. What we mean is if
> 32 ports are allocated for a user, can they be 1024, 1026, 1028…. Etc?
> 2. If multiple ranges is to be logged in a single log event. For eg.
> Ports 1024-1047 and 5000-5010 are allocated for a user, can we log them
> as two events.

-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Tom Taylor <[email-masked]>
Date: Tue, 03 Dec 2013 10:32:04 -0500

It was the final issue discussed. The conclusion I recorded was to use 
IPFIX encoding. What we have had up to now is a difference in 
interpretation of that encoding. I also recorded that we would look at 
two use cases: single contiguous range, and sequence of equally-spaced, 
equal-length ranges. I'm not sure I trust that latter observation 
without listening again to the audio, but I'm prepared to accept that 
the second use case is unrealistic.

Tom