Subject: [BEHAVE] [Errata Held for Document Update] RFC5389 (3737)

From: RFC Errata System <[email-masked]>
Date: Fri, 17 Apr 2015 12:20:19 -0700 (PDT)

The following errata report has been held for document update 
for RFC5389, "Session Traversal Utilities for NAT (STUN)". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5389&eid=3737

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Spencer Dawkins <[email-masked]>
Date Reported: 2013-09-25
Held by: Martin Stiemerling (IESG)

Section: 17

Original Text
-------------
The IAB has mandated that protocols developed for this purpose
document a specific set of considerations. 

Corrected Text
--------------
The IAB has suggested that protocols developed for this purpose
document a specific set of considerations. 

Notes
-----
The IAB UNSAF RFC (http://tools.ietf.org/html/rfc3424) is Informational, and the IAB hasn't "mandated" what IETF protocol documents contain for something like 20 years, if I understand correctly.

--------------------------------------
RFC5389 (draft-ietf-behave-rfc3489bis-18)
--------------------------------------
Title               : Session Traversal Utilities for NAT (STUN)
Publication Date    : October 2008
Author(s)           : J. Rosenberg, R. Mahy, P. Matthews, D. Wing
Category            : PROPOSED STANDARD
Source              : Behavior Engineering for Hindrance Avoidance
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Dave Thaler <[email-masked]>
Date: Fri, 17 Apr 2015 19:48:19 +0000

Disclaimer: I wasn't on the IAB at the time, nor was I active in Behave at the time.

My opinion: The status "Hold for Document Update" is probably correct given the
guidelines for errata processing, but I think the proposed "corrected" text is wrong.
The original text is not inherently flawed, just potentially confusing,
but not in a way that would affect any implementation.

What RFC 3484 said was specifically:
  "the IAB believes the following considerations must be explicitly addressed in
   any proposal"

The use of "must" above is far stronger than the "corrected" text's use of
"suggested" (or even "recommended") which is why I believe the correct text is wrong.
The potential confusion in the original text is just that what the IAB believes/believed is
must be done, is enforced (or not) by the IESG, so if anything is mandated per se, 
it's mandated by the IESG.

A more accurate corrected text would read:

> The IAB has stated that protocols developed for this purpose must document a
> specific set of considerations.

Dave

> -----Original Message-----
> From: Behave [mailto:[email-masked]] On Behalf Of RFC Errata
> System
> Sent: Friday, April 17, 2015 12:20 PM
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; rfc-editor@rfc-
> editor.org
> Subject: [BEHAVE] [Errata Held for Document Update] RFC5389 (3737)
> 
> The following errata report has been held for document update for RFC5389,
> "Session Traversal Utilities for NAT (STUN)".
> 
> Reported by: Spencer Dawkins <[email-masked]> Date
> Reported: 2013-09-25 Held by: Martin Stiemerling (IESG)
> 
> Section: 17
> 
> Original Text
> -------------
> The IAB has mandated that protocols developed for this purpose document a
> specific set of considerations.
> 
> Corrected Text
> --------------
> The IAB has suggested that protocols developed for this purpose document a
> specific set of considerations.
> 
> Notes
> -----
> The IAB UNSAF RFC (http://tools.ietf.org/html/rfc3424) is Informational, and
> the IAB hasn't "mandated" what IETF protocol documents contain for
> something like 20 years, if I understand correctly.
> 
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave