Subject: [bess] Lack of implementation for draft-ietf-bess-virtual-subnet-fib-reduction - submit to IESG?

From: Martin Vigoureux <[email-masked]>
Date: Tue, 11 Oct 2016 17:00:56 +0200

WG,

we have recently LCed draft-ietf-bess-virtual-subnet-fib-reduction and 
there was sufficient support to move forward. However we haven't 
received any input on existing implementations.

As per [1] we are thus asking the WG whether we should nevertheless move 
this to IESG or wait until implementations exist.

Please respond. Thank you.

M&T

[1]: https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 13 Oct 2016 09:37:51 +0000

Hi Martin,

We have just implemented RFC7814 a couple of months before in response to the demands of some of our customers, and those customers have deployed this L3-based overlay technology within their hyper-scale cloud data center network environment recently. We are planning to implement draft-ietf-bess-virtual-subnet-fib-reduction in the next step.

I have just noticed the following statement from (https://www.ravellosystems.com/blog/cloud-networking-layer-2-access-amazon-ec2/):

"... All major clouds, including Amazon EC2, Amazon VPC, Google Compute Engine and Microsoft Azure, allow only unicast datagrams with IP payloads. Broadcast datagrams and non-IP payloads are not allowed (with very limited exceptions to make parts of the essential ARP and DHCP protocols work). "

IMHO, when the L3 overlay technology is more widely deployed in hyper-scale data centers, the on-demand FIB installation mechanism as described in draft-ietf-bess-virtual-subnet-fib-reduction would become significantly important to the operators of those hyper-scale data centers . Once this mechanism becomes an IETF standard, those operators would ask their vendors to implement it. In fact, this is the case of our implementation of RFC7814. Hence, I strongly suggest to move this to IESG.

BTW, since it has become a fact that various data plane encapsulation schemes could be used for the L3VPN solution, hence I wonder whether the implementation of L3 Conversational Learning of DFA as described on page 36 of (http://www.valleytalk.org/wp-content/uploads/2013/08/ciscoDFA.pdf) could be looked as an existing implementation:)

Best regards,
Xiaohu

> -----邮件原件-----
> 发件人: BESS [mailto:[email-masked]] 代表 Martin Vigoureux
> 发送时间: 2016年10月11日 23:01
> 收件人: BESS
> 主题: [bess] Lack of implementation for
> draft-ietf-bess-virtual-subnet-fib-reduction - submit to IESG?
> 
> WG,
> 
> we have recently LCed draft-ietf-bess-virtual-subnet-fib-reduction and there was
> sufficient support to move forward. However we haven't received any input on
> existing implementations.
> 
> As per [1] we are thus asking the WG whether we should nevertheless move this
> to IESG or wait until implementations exist.
> 
> [1]:
> https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw
> 
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess