Subject: [bess] AD Review of draft-ietf-bess-fat-pw-bgp-03

From: Alvaro Retana <[email-masked]>
Date: Fri, 26 Jan 2018 16:54:22 -0500

Dear authors:

I just finished reading this document.  Thank you for a well written and
straight forward document!!

I have some comments (see below) that I think are easy to address.  I am
then starting the IETF Last Call.

Thanks!

Alvaro.

Major:

M1. All the rfc2119 keywords in this text should not be capitalized because
they are part of an example:

   For example, a PE part of a VPLS and with a local T = 1,
   MUST only transmit traffic with a flow label to those peers that
   signaled R = 1.  And if the same PE has local R = 1, it MUST only
   expect to receive traffic with a flow label from peers with T = 1.
   Any other traffic MUST NOT have a flow label.

M2. Security Considerations: I agree that there are no new issues.
However, please also point to rfc4761 and any other document that defines
the base functionality being modified here.

Minor:

P1. "This draft introduces an OPTIONAL mode of operation..."  There's no
need for "OPTIONAL" to be Normative in this sentence since it is just
describing what it is, not specifying behavior.  s/OPTIONAL/optional

P2. The new registry has a policy of "IETF Review", which basically means
that any RFC (not just Standards Track RFCs) can use the bits in the
registry.  I ask because there are only 4 bits left.  Note that I'm not
asking you to necessarily change the policy...just pointing it out.

P3. "T   When the bit value is 1, the PE is requesting the ability..."  Did
you mean "announce the ability" instead?

P4. s/NUST NOT/MUST NOT

P5. References:  I think these can be Informative: rfc4385, rfc8077, rfc4928

---

From: Sami Boutros <[email-masked]>
Date: Sat, 27 Jan 2018 00:27:02 +0000

Hi Albaro,

Agreed with all comments, and we can change the “is requesting the ability” to “announce the ability”.

Do we need to submit a new draft with the changes?

Thanks,

Sami
From: Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Date: Friday, January 26, 2018 at 1:54 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Martin Vigoureux <[email-masked]<mailto:[email-masked]>>
Subject: AD Review of draft-ietf-bess-fat-pw-bgp-03
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, Sami Boutros <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Friday, January 26, 2018 at 1:54 PM

Dear authors:

I just finished reading this document.  Thank you for a well written and straight forward document!!

I have some comments (see below) that I think are easy to address.  I am then starting the IETF Last Call.

Thanks!

Alvaro.

Major:

M1. All the rfc2119 keywords in this text should not be capitalized because they are part of an example:

M2. Security Considerations: I agree that there are no new issues.  However, please also point to rfc4761 and any other document that defines the base functionality being modified here.

Minor:

P1. "This draft introduces an OPTIONAL mode of operation..."  There's no need for "OPTIONAL" to be Normative in this sentence since it is just describing what it is, not specifying behavior.  s/OPTIONAL/optional

P2. The new registry has a policy of "IETF Review", which basically means that any RFC (not just Standards Track RFCs) can use the bits in the registry.  I ask because there are only 4 bits left.  Note that I'm not asking you to necessarily change the policy...just pointing it out.

P3. "T   When the bit value is 1, the PE is requesting the ability..."  Did you mean "announce the ability" instead?

P4. s/NUST NOT/MUST NOT

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 29 Jan 2018 12:46:51 -0800

On January 26, 2018 at 7:27:04 PM, Sami Boutros ([email-masked]) wrote:

Hi!

You can wait until other Last Call comments come in — but please do so
before the IESG Telechat.

Thanks!

Alvaro.