Subject: [bess] Some questions on E-Tree (RFC8317) services with VXLAN Encapsulation: is it feasible? is it necessary? is it under definition already?

From: <[email-masked]>
Date: Wed, 7 Feb 2018 15:22:31 +0800 (CST)

Hi folks,

I have some questions on E-Tree services with VXLAN Encapsulation,

1) It seems that RFC8317 only defines E-Tree service in MPLS (or PBB over MPLS EVPN) encapsulation.

  but there are other EVPN encapsulations, VXLAN and SRv6,

  and the SRv6 EVPN solution also defined the E-Tree procedures framework with Arg.FE2 included in DT2M SIDs

  so, is the E-Tree service with VXLAN Encapsulation feasible? is it necessary? is it under definition already?

2) i think the primary design with E-tree over MPLS EVPN is ESI/Leaf Label,

  but in VXLAN encapsulation, there is no ESI Label or Leaf Label,

  so, although it can do ESI filtering procedures with "Local Bias" procedure and without ESI Label information,

  the VXLAN Encapsulation can't do E-tree filtering procedures without Leaf Label?

  is it right or i have missed something?

Best Regards,

Wang Yubao

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Wed, 7 Feb 2018 07:40:25 +0000

Hi,

Since the overlay tunnel encapsulation selected by NVO3 is GENEVE, IMHO we should only work on EVPN extensions for GENEVE. VXLAN does not have the required extensibility.
And indeed, we are working on EVPN extensions for GENEVE that will address RFC8317 E-Tree services.

SRv6 is a different beast.

Finally, Local Bias can be used for all-active multi-homing, but not for E-Tree, or at least I fail to see how you would do it.

My 2 cents.
Jorge

From: "[email-masked]" <[email-masked]>
Date: Wednesday, February 7, 2018 at 8:22 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Some questions on E-Tree (RFC8317) services with VXLAN Encapsulation: is it feasible? is it necessary? is it under definition already?

Hi folks,

Best Regards,

Wang Yubao