Subject: [bess] [Errata Held for Document Update] RFC7543 (5258)

From: RFC Errata System <[email-masked]>
Date: Wed, 14 Mar 2018 12:45:51 -0700 (PDT)

The following errata report has been held for document update 
for RFC7543, "Covering Prefixes Outbound Route Filter for BGP-4". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5258

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Alexander ("Sasha") Vainshtein <[email-masked]>
Date Reported: 2018-02-08
Held by: Alvaro Retana (IESG)

Section: Section 5

Original Text
-------------
The UMR is characterized as follows:

   o  EVPN Route Type is equal to MAC/IP Advertisement Route

   o  MAC address length is equal to 0

   o  IP address length is equal to 0

Corrected Text
--------------
In Section 5:

The UMR is characterized as follows:

   o  EVPN Route Type is equal to MAC/IP Advertisement Route

   o  MAC address length is equal to 48

   o  IP address length is equal to 0

Notes
-----
The original text provides conflicting definitions of the MAC Address Length in the Unknown MAC Route (UMR).

Since the UMR is a MAC/IP Advertisement Route defined in RFC 7432, and since this RFC states that the MAC Address Length in these routes is 48, the text in Section 5 should be corrected to match RFC 7432 as well as the text in Section 1 of this RFC (where MAC Address Length in the UMR is correctly defined as 48).

--------------------------------------
RFC7543 (draft-ietf-bess-orf-covering-prefixes-06)
--------------------------------------
Title               : Covering Prefixes Outbound Route Filter for BGP-4
Publication Date    : May 2015
Author(s)           : H. Jeng, L. Jalil, R. Bonica, K. Patel, L. Yong
Category            : PROPOSED STANDARD
Source              : BGP Enabled Services
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Ron Bonica <[email-masked]>
Date: Thu, 15 Mar 2018 15:10:02 +0000

Folks,

Alexander is correct. This was a case of fat-fingers.

                                        Ron

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: Wednesday, March 14, 2018 3:46 PM
> To: [email-masked]; [email-masked];
> [email-masked]; Ron Bonica <[email-masked]>;
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; rfc-editor@rfc-
> editor.org
> Subject: [Errata Held for Document Update] RFC7543 (5258)
> 
> The following errata report has been held for document update for RFC7543,
> "Covering Prefixes Outbound Route Filter for BGP-4".
> 
> https://urldefense.proofpoint.com/v2/url?u=http-3A__www.rfc-
> 2Deditor.org_errata_eid5258&d=DwIBaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeM
> K-ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-
> AWF2EfpHcAwrDThKP8&m=1rbrHpi8nOKLOcUVsROcxPWNv9KRKf8BDaXjkQ
> _VMh8&s=w2BpUoiUWk7bDOPH9WYqLPGrtKMCCrmCC67fjCR8uZs&e=
> 
> Since the UMR is a MAC/IP Advertisement Route defined in RFC 7432, and
> since this RFC states that the MAC Address Length in these routes is 48, the
> text in Section 5 should be corrected to match RFC 7432 as well as the text in
> Section 1 of this RFC (where MAC Address Length in the UMR is correctly
> defined as 48).
>