Subject: [bess] Discussion on the UMR format difference between <draft-ietf-bess-dci-evpn-overlay> and RFC7543

From: <[email-masked]>
Date: Fri, 11 Sep 2020 09:16:43 +0800 (CST)

Hi Authors,

In <draft-ietf-bess-dci-evpn-overlay>, there isn't any reference to RFC7543 (2015) before its revision 09 (2018.2).

But the UMR format in this draft is a bit different from RFC7543 almost from its beginning revision.

The difference is in the MAC Address Length field.

In this draft, it should be 48 from its beginning revision.

But in RF7543, it should be 0.

Before the revision 09, I think it is no doubt that the MAC Address Length should be set to 48.

But after the revision 09, although RFC7543 is referred, it also says that the MAC Address Length should be 48 at the same time.

The details can be found at:

https://tools.ietf.org/rfcdiff?url2=draft-ietf-bess-dci-evpn-overlay-09.txt

So when a UMR is advertised, which value should the MAC Address Length be set to?

Thanks,

Bob

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Fri, 11 Sep 2020 09:20:25 +0000

Hi Bob,

The reason why the dci-evpn-overlay draft does not have RFC7543 as a reference before rev 09 was because the first time the UMR was specified was in the dci-evpn-overlay draft. However, later, RFC7543 progressed faster and hence we had to add the reference in the dci draft.

The length is definitively 48.

Note that there is errata filed against RFC7543, pointing out at that error in the RFC. Even in RFC7543, in the terminology section the UMR routes is defined as length 48.

Thanks.
Jorge

From: [email-masked] <[email-masked]>
Date: Friday, September 11, 2020 at 3:17 AM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Discussion on the UMR format difference between <draft-ietf-bess-dci-evpn-overlay> and RFC7543

Hi Authors,

Thanks,

Bob