Subject: [bess] Second try: Router's MAC Extended Community in draft-ietf-bess-evpn-inter-subnet-forwarding

From: John Scudder <[email-masked]>
Date: Thu, 8 Oct 2020 18:12:33 +0000

Hi Authors,

I haven’t seen a reply to this message from almost a month ago, trying again. Even if you are still debating the answer amongst yourselves, it would be comforting to me to receive a reply to the effect of “we’re still thinking about this and will get back to you by $date”.

Thanks,

—John

Begin forwarded message:

From: "John G. Scudder" <[email-masked]<mailto:[email-masked]>>
Subject: Router's MAC Extended Community in draft-ietf-bess-evpn-inter-subnet-forwarding
Date: September 10, 2020 at 9:27:31 AM EDT
To: [email-masked]<mailto:[email-masked]>
Cc: BESS <[email-masked]<mailto:[email-masked]>>

Hi Authors,

I just went through draft-ietf-bess-evpn-inter-subnet-forwarding to look for answers to two questions:

1. Can a router advertise multiple different Router’s MAC values? If yes, what is the receiver supposed to do?
2. Assuming the answer to question 1 is “no”, what is the receiver supposed to do if it receives multiple Router’s MAC Extended Communities (with different values) anyway, for example due to a bug or configuration error? This is a very real possibility since many BGP implementations allow policy to produce arbitrary communities.

Thanks,

—John

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 8 Oct 2020 18:42:47 +0000

Hi John,

Sorry for the delay.

The answer to your 1st question is no and the answer to your 2nd question is that the receiver should pick the first one in the list and ignore the rest. If it helps, I can add couple of lines to that affect to the corresponding section.

Cheers,
Ali

From: John Scudder <[email-masked]>
Date: Thursday, October 8, 2020 at 11:12 AM
To: "[email-masked]" <[email-masked]>
Cc: BESS <[email-masked]>
Subject: Second try: Router's MAC Extended Community in draft-ietf-bess-evpn-inter-subnet-forwarding
Resent-From: <[email-masked]>
Resent-To: Cisco Employee <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Thursday, October 8, 2020 at 11:12 AM

Hi Authors,

Thanks,

—John

Begin forwarded message:

Hi Authors,

Thanks,

—John

---

From: John Scudder <[email-masked]>
Date: Thu, 8 Oct 2020 18:57:30 +0000

Thanks, Ali.

Yes, I think this should be explicit in the spec. I’d also suggest being explicit about what “ignore the rest” means. It could mean one of two things —

1. Don’t pay attention to the extra ones for purposes of computing the local forwarding table, but store them and propagate them.
2. Also don’t store or propagate them.

I’m guessing option 2 is better in this case. The problem with propagating them is sometimes implementations reorder things, so you could end up with inconsistency in the network.

—John

On Oct 8, 2020, at 2:42 PM, Ali Sajassi (sajassi) <[email-masked]<mailto:[email-masked]>> wrote:

Hi John,

Sorry for the delay.

Cheers,
Ali

From: John Scudder <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 8, 2020 at 11:12 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: BESS <[email-masked]<mailto:[email-masked]>>
Subject: Second try: Router's MAC Extended Community in draft-ietf-bess-evpn-inter-subnet-forwarding
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Thursday, October 8, 2020 at 11:12 AM

Hi Authors,

Thanks,

—John

Begin forwarded message:

Hi Authors,

Thanks,

—John

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 8 Oct 2020 19:14:02 +0000

Hi John,

Thanks for your feedback. I was also thinking along the line of (2). I’ll take care of it in the next rev. soon.

Cheers,
Ali

From: John Scudder <[email-masked]>
Date: Thursday, October 8, 2020 at 11:57 AM
To: Cisco Employee <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, BESS <[email-masked]>
Subject: Re: Second try: Router's MAC Extended Community in draft-ietf-bess-evpn-inter-subnet-forwarding
Resent-From: <[email-masked]>
Resent-To: Cisco Employee <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Thursday, October 8, 2020 at 11:57 AM

Thanks, Ali.

—John

Hi John,

Sorry for the delay.

Cheers,
Ali

Hi Authors,

Thanks,

—John

Begin forwarded message:

Hi Authors,

Thanks,

—John