Subject: [bess] Mail regarding draft-ietf-bess-bgp-sdwan-usage

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Mon, 2 Nov 2020 03:32:01 +0000

Hi authors,

 About the section 4.1 BGP Walk Through for Homogeneous SDWAN.
  It shows an example that:
      - MP-NLRI Path Attribute: to indicate multiple routes attached to
     the C-PE2:
         10.1.x.x/16
         VLAN #15
         12.1.1.x/24
     - Tunnel-Encap Path Attribute: to describe the IPsec attributes

 This is a way of associating routea with tunnels, but each route has a large amount of information.

  However, there is another way to advertise routes with Tunnel Encapsulation Extend Community attributes, like draft-ietf-idr-segment-routing-te-policy.
In this method, tunnel information is advertised using independent SAFIs. Routes are associated with tunnels based on the Tunnel Encap EC.
Regards,
Haibo

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 2 Nov 2020 04:14:33 +0000

Haibo,

Thank you very much for the suggestion.

How about using "Color Extended Community"? i.e. Client UPDATE recursive to the node address with "Color Extended Community" attached. And the UPDATE for the Node describes the detailed IPsec attributes with the matching Color Extended Community value.

UPDATE #1:
      - MP-NLRI Path Attribute: to indicate multiple routes attached to
     the C-PE2:
          NextHop: C-PE2
         Prefix:
         10.1.x.x/16
         VLAN #15
         12.1.1.x/24
        Color Extended community: RED

UPDATE #2:

  *   MP-NLRI Path Attribute:
     *   Tunnel-Encap Path Attribute: to describe the IPsec attributes
     *   Color Extended Community: RED

Thank you,

Linda
From: Wanghaibo (Rainsword) <[email-masked]>
Sent: Sunday, November 1, 2020 9:32 PM
To: [email-masked]; [email-masked]
Subject: Mail regarding draft-ietf-bess-bgp-sdwan-usage

Hi authors,

Regards,
Haibo