Subject: [bess] RFC 8584: EVPN DF Election - Originating Router's IP Address of different address family

From: TULASI RAM REDDY <[email-masked]>
Date: Thu, 4 Feb 2021 19:58:04 +0530

Hi All,

As mentioned in the Problem Statement of RFC8584 Sec 1.3, Default DF
algorithm is expected to have
all multihomed PEs to have Originating IP of the same address family.
Do we see any interop issue if the different address families are
considered, i.e. ordering in
ascending order based on numerical value in Originating IP here? For IPv4
read 4 octets as unsigned integer
and IPv6 is considered as 16 octet unsigned integer.

1.3 <https://tools.ietf.org/html/rfc8584#section-1.3>.  Problem Statement

Default DF election algorithm assumes
that all the PEs who are multihomed to the same ES (and interested in
the DF election by exchanging EVPN routes) use an Originating
Router's IP address [RFC7432 <https://tools.ietf.org/html/rfc7432>] of
the same family.

Thanks,
TULASI RAMI REDDY N

---

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Fri, 5 Feb 2021 15:15:47 +0530

Hi Tulasi,

I think the problem is, there is no standard way to numerically compare
IPv4 with IPv6 addresses to form an ordered list. So, all the PEs
multihomed to an ES may not always arrive at the same DF (or BFD in the
case of single-active L-LINE service) with the default DF election algo.
This is problematic (and may cause traffic loops). Hence, the default DF
election algo works only when all PEs multihomed to an ES have Originating
Router's IP Address of the same AF..

Regards,
Muthu

On Thu, Feb 4, 2021 at 7:58 PM TULASI RAM REDDY <[email-masked]>
wrote:

> Router's IP address [RFC7432 <https://tools.ietf.org/html/rfc7432>] of the same family.
>
>
> Thanks,
> TULASI RAMI REDDY N
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: TULASI RAM REDDY <[email-masked]>
Date: Fri, 5 Feb 2021 18:44:37 +0530

Thanks Muthu.
Shouldn't numeric value here mean simply the 4byte or 16 byte unsigned
value representation of the IP address field?
Thinking loudly on how to interpret numeric value  and the limitations
here. Any comments?

each PE builds an ordered list of the IP
addresses of all the PE nodes connected to the Ethernet segment
(including itself), in *increasing numeric value*

Thanks,
Tulasi.
On Fri, Feb 5, 2021 at 3:15 PM Muthu Arul Mozhi Perumal <

-- 
TULASI RAMI REDDY N

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Fri, 5 Feb 2021 14:04:22 +0000

Hi Tulasi,

For the default DF algorithm, I think at that point it will be up to the implementation how to resolve the candidate list PEs with originating IPs of different family.
I know of some implementations that do what you are saying, but you can’t assume all RFC7432/8584 implementations will do that.

Thanks.
Jorge

From: BESS <[email-masked]> on behalf of TULASI RAM REDDY <[email-masked]>
Date: Friday, February 5, 2021 at 2:15 PM
To: Muthu Arul Mozhi Perumal <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [bess] RFC 8584: EVPN DF Election - Originating Router's IP Address of different address family
Thanks Muthu.
Shouldn't numeric value here mean simply the 4byte or 16 byte unsigned value representation of the IP address field?
Thinking loudly on how to interpret numeric value  and the limitations here. Any comments?

(including itself), in increasing numeric value

Thanks,
Tulasi.
On Fri, Feb 5, 2021 at 3:15 PM Muthu Arul Mozhi Perumal <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tulasi,

I think the problem is, there is no standard way to numerically compare IPv4 with IPv6 addresses to form an ordered list. So, all the PEs multihomed to an ES may not always arrive at the same DF (or BFD in the case of single-active L-LINE service) with the default DF election algo. This is problematic (and may cause traffic loops). Hence, the default DF election algo works only when all PEs multihomed to an ES have Originating Router's IP Address of the same AF..

Regards,
Muthu

On Thu, Feb 4, 2021 at 7:58 PM TULASI RAM REDDY <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

As mentioned in the Problem Statement of RFC8584 Sec 1.3, Default DF algorithm is expected to have
all multihomed PEs to have Originating IP of the same address family.
Do we see any interop issue if the different address families are considered, i.e. ordering in
ascending order based on numerical value in Originating IP here? For IPv4 read 4 octets as unsigned integer
and IPv6 is considered as 16 octet unsigned integer.

1.3<https://tools.ietf.org/html/rfc8584#section-1.3>.  Problem Statement

Router's IP address [RFC7432<https://tools.ietf.org/html/rfc7432>] of the same family.

Thanks,
TULASI RAMI REDDY N
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

--
TULASI RAMI REDDY N

---

From: "Satya Mohanty (satyamoh)" <[email-masked]>
Date: Wed, 10 Feb 2021 03:07:20 +0000

Hi Tulasi and Muthu,

Yes, the numeric value here refers to the 4byte or 16byte unsigned value representation of the IP address field.
Maybe in the 7432-bis this can be stated explicitly.

We did envision this possibility in RFC 8584 (the HRW hash already takes care of the fact that the IP address could be either IPV4 or IPV6).

However, with respect to deployment do you have a case in mind of this “mixed v4/v6” that will necessitate such a tie-break?
I mean one of the MH PEs has an ipv4 originator address and the other a v6 originator address.

Thanks,
--Satya

From: BESS <[email-masked]> on behalf of TULASI RAM REDDY <[email-masked]>
Date: Friday, February 5, 2021 at 5:17 AM
To: Muthu Arul Mozhi Perumal <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bess] RFC 8584: EVPN DF Election - Originating Router's IP Address of different address family

Thanks Muthu.

Thanks,
Tulasi.

Regards,
Muthu

Thanks,
TULASI RAMI REDDY N

--
TULASI RAMI REDDY N

---

From: "Satya Mohanty (satyamoh)" <[email-masked]>
Date: Wed, 10 Feb 2021 03:11:16 +0000

Hi Jorge,

Inline.

From: BESS <[email-masked]> on behalf of "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Friday, February 5, 2021 at 6:05 AM
To: TULASI RAM REDDY <[email-masked]>, Muthu Arul Mozhi Perumal <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bess] RFC 8584: EVPN DF Election - Originating Router's IP Address of different address family

Hi Tulasi,

For the default DF algorithm, I think at that point it will be up to the implementation how to resolve the candidate list PEs with originating IPs of different family.
<Satya> This is should be standardized as otherwise It will result in different decisions in different PEs. I suggest a mention in 7432-bis.
I know of some implementations that do what you are saying, but you can’t assume all RFC7432/8584 implementations will do that.

Thanks.
Jorge

Thanks,
Satya

Thanks,
Tulasi.

Regards,
Muthu

Thanks,
TULASI RAMI REDDY N

--
TULASI RAMI REDDY N

---

From: Muthu Arul Mozhi Perumal <[email-masked]>
Date: Wed, 10 Feb 2021 09:10:25 +0530

Hi Satya,

Please see inline..

> Maybe in the 7432-bis this can be stated explicitly.

Agree, this is important to clarify in 7432-bis and simple to fix in
implementations that don't compare IPv4 and IPv6 addresses this way for
default DF election algo..

>
>
> We did envision this possibility in RFC 8584 (the HRW hash already takes
> care of the fact that the IP address could be either IPV4 or IPV6).
>
>
>
> However, with respect to deployment do you have a case in mind of this
> “mixed v4/v6” that will necessitate such a tie-break?
>

Yes, in a dual-stack environment, there could be multihomed PEs running (1)
BGP over IP4 w/ IPv4 NH, (2) BGP over IPv6 w/ IPv4 NH, (3) BGP over IPv6 w/
IPv6 NH, say connected thru' an RR in control plane, and all part of the
same ES group. In this case, the Originating Router's IP address in the ES
route could be an IPv4 or IPv6 address (implementation specific)..

Regards,
Muthu

>
>
> Thanks,
>
> --Satya
>
>
>
>
>
> *From: *BESS <[email-masked]> on behalf of TULASI RAM REDDY <
> [email-masked]>
> *Date: *Friday, February 5, 2021 at 5:17 AM
> *To: *Muthu Arul Mozhi Perumal <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [bess] RFC 8584: EVPN DF Election - Originating Router's
> IP Address of different address family
>
>
>
> Thanks Muthu.
>