Subject: Re: [bess] Murray Kucherawy's Discuss on draft-ietf-bess-evpn-igmp-mld-proxy-14: (with DISCUSS and COMMENT)

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Wed, 17 Nov 2021 20:03:46 +0000

Hi Murray,
Thanks for comment . Please find inlinecomment.

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Wednesday, October 27, 2021 at 11:34 PM
To: The IESG <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Murray Kucherawy's Discuss on draft-ietf-bess-evpn-igmp-mld-proxy-14: (with DISCUSS and COMMENT)
Murray Kucherawy has entered the following ballot position for
draft-ietf-bess-evpn-igmp-mld-proxy-14: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-igmp-mld-proxy/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

There's an IPR disclosure on this document.  In the shepherd writeup, where a
summary of the discussion of it is requested, it simply says "There are 3 IPRs
disclosed".  I'd like to hear that summary, or at least confirm the discussion
was had and there were no concerns as a result.

Mankamana : @Stephane Litkowski (slitkows)<mailto:[email-masked]> to address this comment.

The IANA Considerations section needs some work:

(0) I suggest making each of the actions you want to take (there are four) into
their own subsections of this section.

(1) "EVPN Extended Community sub-types registry" should be "EVPN Extended
Community Sub-Types sub-registry of the BGP Extended Communities registry",
which makes it easier to find.

(2) "Multicast Flags Extended Community" appears to be a new registry you're
creating in the final action here.  BCP 26, for a First Come First Served
registry, advises that a change controller column be included.  Are you
intentionally omitting this here?  Or if this is referring to an existing
registry, I wasn't able to find it.

Mankamana :The registry in (1), above, is also FCFS and it does not have a change controller column.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 3 defines "NV" and "NVO", but these terms appear nowhere in the
document.

Every SHOULD in this document, other than the ones that talk about logging,
left me wondering why an implementer might decide not to follow that advice.
Since SHOULD presents a choice, I suggest including some guidance about why
it's a SHOULD, i.e., when one might decide not to do what it says and still
expect to interoperate.  Or should some of these really be MUSTs?

Mankamana : My understanding should gives more flexibility to implementation to make choices. And may not be good idea to make every thing MUST until without it protocol breaks. Is there any specific instance which you want to make MUST ?

---

From: John E Drake <[email-masked]>
Date: Fri, 19 Nov 2021 16:25:10 +0000

Stephane,

Would you please answer Murray's DISCUSS, below, regarding IPR for this draft?

Yours Irrespectively,

John

Juniper Business Use Only

> -----Original Message-----
> Sent: Thursday, October 28, 2021 2:34 AM
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> [External Email. Be cautious of content]
> 
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Please refer to
> https://urldefense.com/v3/__https://www.ietf.org/blog/handling-iesg-ballot-
> positions/__;!!NEt6yMaO-
> gk!W78AS0i7NtIrTH6bLPDFceHsaPVHeM_Ej8CtuxDjgVuYYEhgGas-JhLfoo_6Pyg$
> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-bess-
> evpn-igmp-mld-proxy/__;!!NEt6yMaO-
> gk!W78AS0i7NtIrTH6bLPDFceHsaPVHeM_Ej8CtuxDjgVuYYEhgGas-JhLf0GO7d-I$
> 
> 
> 
> disclosed".  I'd like to hear that summary, or at least confirm the discussion was
> had and there were no concerns as a result.
> 
> creating in the final action here.  BCP 26, for a First Come First Served registry,
> advises that a change controller column be included.  Are you intentionally
> omitting this here?  Or if this is referring to an existing registry, I wasn't able to
> find it.
> 
> 
> Every SHOULD in this document, other than the ones that talk about logging, left
> me wondering why an implementer might decide not to follow that advice.
> it's a SHOULD, i.e., when one might decide not to do what it says and still expect
> to interoperate.  Or should some of these really be MUSTs?
> 
>

---

From: <[email-masked]>
Date: Mon, 22 Nov 2021 11:14:39 +0100

Hi Murray,

>There's an IPR disclosure on this document.  In the shepherd writeup, where a summary of the discussion of it is requested, it simply says "There are 3 IPRs disclosed".  I'd like to hear that summary, or at least confirm the discussion was had and there were no concerns as a result.

The WG didn't raised any concern about the IPR disclosed for this document.

Brgds,

Stephane

-----Original Message-----
From: Murray Kucherawy via Datatracker <[email-masked]> 
Sent: jeudi 28 octobre 2021 08:34
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Murray Kucherawy's Discuss on draft-ietf-bess-evpn-igmp-mld-proxy-14: (with DISCUSS and COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

There's an IPR disclosure on this document.  In the shepherd writeup, where a summary of the discussion of it is requested, it simply says "There are 3 IPRs disclosed".  I'd like to hear that summary, or at least confirm the discussion was had and there were no concerns as a result.

(0) I suggest making each of the actions you want to take (there are four) into their own subsections of this section.

(1) "EVPN Extended Community sub-types registry" should be "EVPN Extended Community Sub-Types sub-registry of the BGP Extended Communities registry", which makes it easier to find.

(2) "Multicast Flags Extended Community" appears to be a new registry you're creating in the final action here.  BCP 26, for a First Come First Served registry, advises that a change controller column be included.  Are you intentionally omitting this here?  Or if this is referring to an existing registry, I wasn't able to find it.

Section 3 defines "NV" and "NVO", but these terms appear nowhere in the document.

Every SHOULD in this document, other than the ones that talk about logging, left me wondering why an implementer might decide not to follow that advice. 
Since SHOULD presents a choice, I suggest including some guidance about why it's a SHOULD, i.e., when one might decide not to do what it says and still expect to interoperate.  Or should some of these really be MUSTs?