Subject: [bfcpbis] Data type clarifications of Conference ID + User ID

From: Kristoffer Gleditsch <[email-masked]>
Date: Fri, 23 Mar 2012 14:34:51 +0100

Hi!

See the attached diffs to the 4582bis and 4853bis drafts.

The motivation of the 4582bis change is to make sure nobody thinks
Conference ID = -42 is legal.  (I left Transaction ID as it was, since
it carries no meaning apart from uniqueness.)

The motivation of the 4583bis change is to make sure nobody thinks they
can put "a=userid: 0xa" in the SDP to express User ID = 10.

Regards,
Kristoffer
--- draft-ietf-bfcpbis-rfc4582bis-02.txt.orig	2012-03-23 09:32:01.229176880 +0100
+++ draft-ietf-bfcpbis-rfc4582bis-02.txt	2012-03-23 14:22:51.914181291 +0100
@@ -985,14 +985,14 @@
    Payload Length: This 16-bit field contains the length of the message
    in 4-octet units, excluding the common header.
 
-   Conference ID: This 32-bit field identifies the conference the
-   message belongs to.
+   Conference ID: This 32-bit unsigned integer field identifies the
+   conference the message belongs to.
 
    Transaction ID: This field contains a 16-bit value that allows users
    to match a given message with its response (see Section 8).
 
-   User ID: This field contains a 16-bit value that uniquely identifies
-   a participant within a conference.
+   User ID: This field contains a 16-bit unsigned integer that
+   uniquely identifies a participant within a conference.
 
       The identity used by a participant in BFCP, which is carried in
       the User ID field, is generally mapped to the identity used by the
--- draft-ietf-bfcpbis-rfc4583bis-00.txt.orig	2012-03-23 09:33:08.461505016 +0100
+++ draft-ietf-bfcpbis-rfc4583bis-00.txt	2012-03-23 09:33:22.777284417 +0100
@@ -357,7 +357,7 @@
    userid-attribute      = "a=userid:" user-id
    user-id               = token
 
-   The 'confid' and the 'userid' attributes carry the integer
+   The 'confid' and the 'userid' attributes carry the decimal integer
    representation of a conference ID and a user ID, respectively.
 
    Endpoints that use the offer/answer model to establish BFCP

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 26 Mar 2012 02:09:16 -0700

Hi Kristoffer,

The clarifications you have proposed all look helpful to me. I would be happy to see them adopted in the drafts being worked within this group.

Cheers,
Charles (as an individual)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Kristoffer Gleditsch (kgledits)
> Sent: Friday, March 23, 2012 2:35 PM
> To: [email-masked]
> Subject: [bfcpbis] Data type clarifications of Conference ID + User ID
> 
> Hi!
>

---

From: Tom Kristensen <[email-masked]>
Date: Thu, 29 Mar 2012 11:12:12 +0200

I agree. I will present these clarifications in the IETF-83 WG session tomorrow.

-- Tom

On 26/03/2012, Charles Eckel (eckelcu) <[email-masked]> wrote:
> Hi Kristoffer,
>
> The clarifications you have proposed all look helpful to me. I would be
> happy to see them adopted in the drafts being worked within this group.
>
> Cheers,
> _______________________________________________
> bfcpbis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bfcpbis
>

-- 
# Cisco                         |  http://www.cisco.com/telepresence/
## [email-masked]  |  http://www.tandberg.com
###                               |  http://folk.uio.no/tomkri/