Subject: [bfcpbis] RFC4583bis examples

From: "Alfred E. Heggestad" <[email-masked]>
Date: Sun, 20 Jan 2013 19:08:35 +0100

hi,

I have some comments to the Example section in:

   http://tools.ietf.org/id/draft-ietf-bfcpbis-rfc4583bis-05.txt

    m=application 50000 UDP/TLS/BFCP *
    a=setup:actpass
    a=fingerprint:SHA-1 \
         4A:AD:B9:B1:3F:82:18:3B:54:02:12:DF:3E:5D:49:6B:19:E5:7C:AB
    a=floorctrl:c-only, s-only
    a=confid:4321
    a=userid:1234
    a=floorid:1 mstrm:10
    a=floorid:2 mstrm:11
    m=audio 50002 RTP/AVP 0
    a=label:10
    m=video 50004 RTP/AVP 31
    a=label:11

    The following is the answer returned by the server.

    m=application 9 UDP/TLS/BFCP *
    a=setup:active
    a=fingerprint:SHA-1 \
         3D:B4:7B:E3:CC:FC:0D:1B:5D:31:33:9E:48:9B:67:FE:68:40:E8:21
    a=floorctrl:s-only
    a=confid:4321
    a=userid:1234
    a=floorid:1 mstrm:10
    a=floorid:2 mstrm:11
    m=audio 55000 RTP/AVP 0
    m=video 55002 RTP/AVP 31

1. can the "floorctrl" attribute have several values, and are they
    separated by COMMA or SPACE ?

2. is it normal to use port 9 for UDP sockets ...? perhaps it is better
    to use a port number from the example range (1024-65535) ?

/alfred

---

From: Tom Kristensen <[email-masked]>
Date: Mon, 21 Jan 2013 10:58:02 +0100

> hi,

[...]

>    separated by COMMA or SPACE ?
Yes, several values allowed separated by SP:

---

    floor-control-attribute  = "a=floorctrl:" role *(SP role)
    role                     = "c-only" / "s-only" / "c-s"

---

>    to use a port number from the example range (1024-65535) ?

Nope. Discard port only applicable for a TCP connection. For UDP we have 
to use the port the BFCP messages shall be sent to.

Thanks, Alfred! This needs to be fixed.

-- Tom

---

From: Tom Kristensen <[email-masked]>
Date: Mon, 21 Jan 2013 11:12:44 +0100

Fixed for upcoming version.

XML diff enclosed, if any interest ;-)

-- Tom
Index: draft-ietf-bfcpbis-rfc4583bis.xml
===================================================================
--- draft-ietf-bfcpbis-rfc4583bis.xml	(revision 1677)
+++ draft-ietf-bfcpbis-rfc4583bis.xml	(working copy)
@@ -4,7 +4,7 @@
 
 <?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
 
-<rfc category="std" ipr="trust200902" docName="draft-ietf-bfcpbis-rfc4583bis-05" obsoletes="4583">
+<rfc category="std" ipr="trust200902" docName="draft-ietf-bfcpbis-rfc4583bis-06" obsoletes="4583">
 
 <?rfc strict="yes"?>
 <?rfc toc="yes"?>
@@ -232,7 +232,7 @@
 a=setup:actpass
 a=fingerprint:SHA-1 \
      4A:AD:B9:B1:3F:82:18:3B:54:02:12:DF:3E:5D:49:6B:19:E5:7C:AB
-a=floorctrl:c-only, s-only
+a=floorctrl:c-only s-only
 a=confid:4321
 a=userid:1234	
 a=floorid:1 mstrm:10
@@ -246,7 +246,7 @@
     <t>The following is the answer returned by the server.</t>
     <figure>
       <artwork>
-m=application 9 UDP/TLS/BFCP *
+m=application 55000 UDP/TLS/BFCP *
 a=setup:active
 a=fingerprint:SHA-1 \
      3D:B4:7B:E3:CC:FC:0D:1B:5D:31:33:9E:48:9B:67:FE:68:40:E8:21
@@ -255,8 +255,8 @@
 a=userid:1234	
 a=floorid:1 mstrm:10
 a=floorid:2 mstrm:11
-m=audio 55000 RTP/AVP 0
-m=video 55002 RTP/AVP 31
+m=audio 55002 RTP/AVP 0
+m=video 55004 RTP/AVP 31
       </artwork>
     </figure>
   </section>