Subject: [bfcpbis] UDP Only

From: Alan Johnston <[email-masked]>
Date: Thu, 21 Feb 2013 10:54:32 -0600

Here is a question that came up here at SIPit where we have been testing
BFCP over UDP and TCP.

Can an implementation only support BFCP over UDP and still be compliant?
 Or do endpoints need to support both UDP and TCP?

- Alan -

---

From: Mary Barnes <[email-masked]>
Date: Sat, 23 Feb 2013 11:56:12 -0600

Since no one else has responded, my understanding is that one could be
considered compliant if they support UDP only.

Mary.

On Thu, Feb 21, 2013 at 10:54 AM, Alan Johnston
<[email-masked]> wrote:
> Can an implementation only support BFCP over UDP and still be compliant?  Or
> do endpoints need to support both UDP and TCP?
>
> - Alan -
>
> _______________________________________________
> bfcpbis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bfcpbis
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 26 Feb 2013 20:37:27 +0000

As an individual, my take on this is the same as Mary's. Section 6 of draft-ietf-bfcpbis-rfc4582bis-08 specifies both TCP and UDP as available transport protocols, and it says either may be used depending on the environment.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mary Barnes
> Sent: Saturday, February 23, 2013 9:56 AM
> To: Alan Johnston
> Cc: [email-masked]
> Subject: Re: [bfcpbis] UDP Only
>

---

From: Alan Johnston <[email-masked]>
Date: Tue, 26 Feb 2013 14:54:10 -0600

Great. Thanks for the responses. 

- Alan -

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 27 Feb 2013 03:35:26 +0100

This part of text apparently talks only about use, not support.

Reinterpreting what it says the other way round, it says you should use TCP in all cases where it works, and UDP only where you have problems.

(as another individual)

Keith

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Charles Eckel (eckelcu)
> Sent: 26 February 2013 20:37
> To: Mary Barnes; Alan Johnston
> Cc: [email-masked]
> As an individual, my take on this is the same as Mary's. Section 6 of
> draft-ietf-bfcpbis-rfc4582bis-08 specifies both TCP and UDP as available
> transport protocols, and it says either may be used depending on the
> environment.
> 
> Cheers,
> Charles
>