Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

From: Alissa Cooper <[email-masked]>
Date: Tue, 25 Oct 2016 10:50:22 -0400

> On Aug 22, 2016, at 4:07 PM, Charles Eckel (eckelcu) <[email-masked]> wrote:
> 
> Thanks Christer.
> I don’t think a separate “BUNDLE Considerations” section is warranted. Adding the agreed upon text to section 10 is sufficient.
> We can continue to specify the MUX category in the rfc4583bis draft and am okay with TBD.

Having just reviewed draft-ietf-mmusic-sdp-mux-attributes again, I’m wondering why TBD would be specified here rather than choosing a value. Is there some future document where the WG would expect to specify the value or some implementation experience that people feel is necessary before the value can be specified? If not, then 4583bis seems like the right place to specify the value.

Alissa

> 
> Thank s again,
> Charles
> 
> From: Christer Holmberg <[email-masked] <mailto:[email-masked]>>
> Date: Friday, August 19, 2016 at 12:39 PM
> To: Charles Eckel <[email-masked] <mailto:[email-masked]>>, Tom Kristensen <[email-masked] <mailto:[email-masked]>>, Tom Kristensen <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Cc: "Suhas Nandakumar (snandaku)" <[email-masked] <mailto:[email-masked]>>
> Subject: RE: SV: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt
> 
>> Hi,
>>  
>> I agree that we should say that BUNDLE multiplexing is not supported  in this specification, and that BFCP m- lines MUST NOT be included in a bundle group.
>>  
>> Perhaps you could put that text in a small “BUNDLE Considerations” chapter, or something similar?
>>  
>> Regarding where to define the MUX category for the new attribute, I suggest we do it in this draft, since that is part of the information you need to specify when registering a new attribute.
>>  
>> Regarding the mux category value, I guess IDENTICAL would work – eventhough it’s a little strange considering we don’t define BFCP multiplexing to begin with. Would TBD be more suitable?
>>  
>> Regards,
>>  
>> Christer
>>   <>
>> From: Charles Eckel (eckelcu) [mailto:[email-masked] <mailto:[email-masked]>] 
>> Sent: 02 August 2016 17:43
>> To: Tom Kristensen (tomkrist) <[email-masked] <mailto:[email-masked]>>; Tom Kristensen <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>> Cc: Suhas Nandakumar (snandaku) <[email-masked] <mailto:[email-masked]>>; Christer Holmberg <[email-masked] <mailto:[email-masked]>>
>> Subject: Re: SV: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt
>>  
>> Thanks Tom.
>> Suhas, Christer, any thoughts?
>>  
>> Cheers,
>> Charles
>>  
>> From: Tom Kristensen <[email-masked] <mailto:[email-masked]>>
>> Date: Monday, August 1, 2016 at 4:49 AM
>> To: Charles Eckel <[email-masked] <mailto:[email-masked]>>, Tom Kristensen <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> Cc: "Suhas Nandakumar (snandaku)" <[email-masked] <mailto:[email-masked]>>, Christer Holmberg <[email-masked] <mailto:[email-masked]>>
>> Subject: SV: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt
>>  
>>> It would be ideal to treat bfcpver the same way as the other, existing attributes. Hopefully, the authors of  draft-ietf-mmusic-sdp-mux-attributes​ will add them to this draft.
>>>  
>>> I do like to move the BUNDLE reference to informational, so I support Charles' text proposal in his last paragraph below.
>>>  
>>> -- Tom
>>> Fra: Charles Eckel (eckelcu)
>>> Sendt: 8. juli 2016 23:39
>>> Til: Tom Kristensen; [email-masked] <mailto:[email-masked]>
>>> Kopi: Tom Kristensen (tomkrist); Suhas Nandakumar (snandaku); Christer Holmberg
>>> Emne: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt
>>>  
>>> Hi Tom,
>>>  
>>> Thanks for incorporating the changes. The dtls-id change looks good. Unfortunately, the MUX category change suffers from the fact we are chasing a moving target. draft-ietf-mmusic-sdp-mux-attributes was updated recently and the NOT RECOMMENDED category was replaced with the CAUTION category. 
>>>  
>>> Upon taking another look at draft-ietf-mmusic-sdp-mux-attributes, my previous suggestion was not good. draft-ietf-mmusic-sdp-mux-attributes already defines the Mux category for all SDP attribute defined in rfc4583bis except the newly added bfcpver SDP attribute. For this, I think the Mux category should be IDENTICAL. However, I’m not sure if it should be added to rfc4583bis or to draft-ietf-mmusic-sdp-mux-attributes directly. I have cc’d Suhas to Christer to get their input, both on the mux category selected and where it should be specified.
>>>  
>>> As for multiplexing of BFCP lines, perhaps rfc4583bis should simply say, "Multiplexing of BFCP ‘m' lines, as defined in BUNDLE [16], is not defined by this specification.”
>>> If we agree to this, the reference to BUNDLE should be Informational instead of Normative.
>>>  
>>> Cheers,
>>> Charles
>>>  
>>>  
>>> From: bfcpbis <[email-masked] <mailto:[email-masked]>> on behalf of Tom Kristensen <[email-masked] <mailto:[email-masked]>>
>>> Date: Wednesday, July 6, 2016 at 11:13 PM
>>> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>>> Cc: Tom Kristensen <[email-masked] <mailto:[email-masked]>>
>>> Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt
>>>  
>>>> Incorporates the two issues spotted by Charles in the -14 version. The draft should most likely and hopefully be ready to proceed through the next stages now. 
>>>>  
>>>> -- Tom
>>>>  
>>>> On 7 July 2016 at 08:10, <[email-masked] <mailto:[email-masked]>> wrote:
>>>>> 
>>>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>>>> This draft is a work item of the Binary Floor Control Protocol Bis  of the IETF.
>>>>> 
>>>>>         Title           : Session Description Protocol (SDP) Format for Binary Floor Control Protocol (BFCP) Streams
>>>>>         Authors         : Gonzalo Camarillo
>>>>>                           Tom Kristensen
>>>>>                           Paul E. Jones
>>>>>         Filename        : draft-ietf-bfcpbis-rfc4583bis-15.txt
>>>>>         Pages           : 21
>>>>>         Date            : 2016-07-06
>>>>> 
>>>>> Abstract:
>>>>>    This document specifies how to describe Binary Floor Control Protocol
>>>>>    (BFCP) streams in Session Description Protocol (SDP) descriptions.
>>>>>    User agents using the offer/answer model to establish BFCP streams
>>>>>    use this format in their offers and answers.
>>>>> 
>>>>>    This document obsoletes RFC 4583.  Changes from RFC 4583 are
>>>>>    summarized in Section 14.
>>>>> 
>>>>> 
>>>>> The IETF datatracker status page for this draft is:
>>>>> https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-rfc4583bis/ <https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-rfc4583bis/>
>>>>> 
>>>>> There's also a htmlized version available at:
>>>>> https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-15 <https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-15>
>>>>> 
>>>>> A diff from the previous version is available at:
>>>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-bfcpbis-rfc4583bis-15 <https://www.ietf.org/rfcdiff?url2=draft-ietf-bfcpbis-rfc4583bis-15>
>>>>> 
>>>>> 
>>>>> Please note that it may take a couple of minutes from the time of submission
>>>>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>>>>> 
>>>>> Internet-Drafts are also available by anonymous FTP at:
>>>>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>>>>> 
>>>>> _______________________________________________
>>>>> bfcpbis mailing list
>>>>> [email-masked] <mailto:[email-masked]>
>>>>> https://www.ietf.org/mailman/listinfo/bfcpbis <https://www.ietf.org/mailman/listinfo/bfcpbis>
>>>> 
>>>> 
>>>>  
>>>> --
>>>> # Cisco                         |  http://www.cisco.com/telepresence/ <http://www.cisco.com/telepresence/>
>>>> ## [email-masked] <mailto:[email-masked]>  |  http://www.tandberg.com <http://www.tandberg.com/>
>>>> ###                               |  http://folk.uio.no/tomkri/ <http://folk.uio.no/tomkri/>_______________________________________________
> bfcpbis mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/bfcpbis <https://www.ietf.org/mailman/listinfo/bfcpbis>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 26 Oct 2016 17:18:19 +0000

Hi Alissa,

This draft simply states that BUNDLE multiplexing is not supported in this specification and that BFCP m- lines MUST NOT be included in a bundle group. If someone wanted to define how BUNDLE multiplexing could be done or to use the SDP attributes defined here with BUNDLE m lines for something else, they would need to specify this in another draft. Within this working group, we do not have plans for such a draft.

We were going to specify the MUX category as IDENTICAL, but then switched to TBD. I thought this was as advised by Suhas, but I cannot find evidence of that now. IDENTICAL would be fine with me. Suhas, any thoughts?

Cheers,
Charles

On 10/25/16, 4:50 PM, "Alissa Cooper" <[email-masked]<mailto:[email-masked]>> wrote:

On Aug 22, 2016, at 4:07 PM, Charles Eckel (eckelcu) <[email-masked]<mailto:[email-masked]>> wrote:

Thanks Christer.

Alissa

Thank s again,
Charles

From: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Friday, August 19, 2016 at 12:39 PM
To: Charles Eckel <[email-masked]<mailto:[email-masked]>>, Tom Kristensen <[email-masked]<mailto:[email-masked]>>, Tom Kristensen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Suhas Nandakumar (snandaku)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: SV: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

Hi,

Regards,

Christer

From: Charles Eckel (eckelcu) [mailto:[email-masked]]
Sent: 02 August 2016 17:43
To: Tom Kristensen (tomkrist) <[email-masked]<mailto:[email-masked]>>; Tom Kristensen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Suhas Nandakumar (snandaku) <[email-masked]<mailto:[email-masked]>>; Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Subject: Re: SV: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

Thanks Tom.

Cheers,
Charles

From: Tom Kristensen <[email-masked]<mailto:[email-masked]>>
Date: Monday, August 1, 2016 at 4:49 AM
To: Charles Eckel <[email-masked]<mailto:[email-masked]>>, Tom Kristensen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Suhas Nandakumar (snandaku)" <[email-masked]<mailto:[email-masked]>>, Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Subject: SV: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

-- Tom
________________________________
Fra: Charles Eckel (eckelcu)
Sendt: 8. juli 2016 23:39
Til: Tom Kristensen; [email-masked]<mailto:[email-masked]>
Kopi: Tom Kristensen (tomkrist); Suhas Nandakumar (snandaku); Christer Holmberg
Emne: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

Hi Tom,

Cheers,
Charles

From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Tom Kristensen <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 6, 2016 at 11:13 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Tom Kristensen <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

-- Tom

On 7 July 2016 at 08:10, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-rfc4583bis/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bfcpbis-rfc4583bis-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

--
# Cisco                         |  http://www.cisco.com/telepresence/
## [email-masked]<mailto:[email-masked]>  |  http://www.tandberg.com<http://www.tandberg.com/>
###                               |  http://folk.uio.no/tomkri/
_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: "Suhas Nandakumar (snandaku)" <[email-masked]>
Date: Wed, 26 Oct 2016 17:59:18 +0000

​Hello Charles

  The mux attributes draft specifies category of IDENTICAL for floorctrl and NORMAL for other RFC4583 attributes. I do think RFC4583bis should reflect the same.

Cheers

Suhas

PS: The category IDENTICAL was concluded after having a discussion with you back in 2013 :-) since it enforced common control

________________________________
From: Charles Eckel (eckelcu)
Sent: Wednesday, October 26, 2016 10:18 AM
To: Alissa Cooper
Cc: Christer Holmberg; Tom Kristensen (tomkrist); Tom Kristensen; [email-masked]; Suhas Nandakumar (snandaku)
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

Hi Alissa,

Cheers,
Charles

Thanks Christer.

Alissa

Thank s again,
Charles

Hi,

Regards,

Christer

Thanks Tom.

Cheers,
Charles

-- Tom

Hi Tom,

Cheers,
Charles

-- Tom

Abstract:

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 26 Oct 2016 18:14:43 +0000

Hi,

I don’t understand how it can be IDENTICAL if we haven’t even defined how to bundle multiple bfcp streams.

Regards,

Christer

From: Suhas Nandakumar (snandaku) [mailto:[email-masked]]
Sent: 26 October 2016 20:59
To: Charles Eckel (eckelcu) <[email-masked]>; Alissa Cooper <[email-masked]>
Cc: Christer Holmberg <[email-masked]>; Tom Kristensen (tomkrist) <[email-masked]>; Tom Kristensen <[email-masked]>; [email-masked]
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

​Hello Charles

Cheers

Suhas

Cc: Christer Holmberg; Tom Kristensen (tomkrist); Tom Kristensen; [email-masked]<mailto:[email-masked]>; Suhas Nandakumar (snandaku)

Hi Alissa,

Cheers,
Charles

Thanks Christer.

Alissa

Thank s again,
Charles

Hi,

Regards,

Christer

Thanks Tom.

Cheers,
Charles

-- Tom

Hi Tom,

Cheers,
Charles

-- Tom

Abstract:

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 26 Oct 2016 15:29:27 -0400

> how to bundle multiple bfcp streams.

+1

I suspect that the solution to bundling bfcp will be bfcp over data channel.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 26 Oct 2016 20:08:21 +0000

Hi,

I wonder whether draft-mux-attributes should define the mux category for attributes associated with BFCP to begin with. Because, IF someone at some point defines how to bundle BFCP, draft-mux-attributes would have to be updated.

Regards,

Christer

-----Original Message-----
From: bfcpbis [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 26 October 2016 22:29
To: [email-masked]
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

>
> I don't understand how it can be IDENTICAL if we haven't even defined 
> how to bundle multiple bfcp streams.

+1

	Thanks,
	Paul

[email-masked]

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 27 Oct 2016 10:32:56 +0000

Christer and Paul,

Having taken another look at the mux attributes draft, I think you are both correct.
TBD is defined as follows:

4.9.  Category: TBD

   The attributes in the TBD category have not been analyzed under the
   proposed multiplexing framework and SHOULD NOT be multiplexed.

This seems appropriate not only for bfcpver but also for floorctlr. If we agree to this, the mux attribute draft would need to be updated to reflect this.

Cheers,
Charles

On 10/26/16, 10:08 PM, "bfcpbis on behalf of Christer Holmberg" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Christer

-----Original Message-----
From: bfcpbis [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 26 October 2016 22:29
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-15.txt

+1

    Thanks,
    Paul