Subject: [bfcpbis] Mirja Kühlewind's No Objection on draft-ietf-bfcpbis-bfcp-websocket-13: (with COMMENT)

From: "Mirja Kuehlewind" <[email-masked]>
Date: Tue, 17 Jan 2017 06:21:48 -0800

Mirja Kühlewind has entered the following ballot position for
draft-ietf-bfcpbis-bfcp-websocket-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-bfcp-websocket/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

1) I find this sentence slightly confusing:  „This document specifies a new WebSocket sub-
   protocol as a reliable transport mechanism between Binary Floor
   Control Protocol (BFCP) entities to enable usage of BFCP in new
   scenarios.“ because it suggests that this document specifies a new protocol which is
not true. How about the following instead:
„This document specifies the use of Binary Floor
   Control Protocol (BFCP) as a new WebSocket sub-
   protocol enabling a reliable transport mechanism between     BFCP entities in new scenarios.“
If this change is used, please also check similar wording in the rest of
the doc.
2) In section 4.1: 
„The WebSocket messages transmitted over this connection MUST conform
to
   the negotiated WebSocket sub-protocol.“ Not sure if this is actually meaningful given the subsequent MUSTs in the
next section. I guess this sentence could simply be removed… Also would
this mean that it is the task of the BFCP WS sub protocol to verify that
BFCP messages are valid?
3) In section 5: „Each BFCP message MUST be carried within a single
WebSocket message,
   and a WebSocket message MUST NOT contain more than one BFCP message.“ This seem to be long rather in section 4.2 than in 5.
4) The following sentence in section 6.2 is basically copied and pasted
from ietf-bfcpbis-sdp-ws-uri. It’s usually not a good idea to duplicate
normative text (as problems when updating might occur). I’d recommend to
either a) remove this text (and only refer to ietf-bfcpbis-sdp-ws-uri),
or b) use quotes to make clear that this is a citation, or c) rephrase in
non-normative language (with a clear indication that the normative text
can be found in ietf-bfcpbis-sdp-ws-uri). „When the 'ws-uri' or 'wss-uri' attribute is present in the
   media section of the SDP, the IP and port information provided in
the
   'c' lines SHALL be ignored and the full URI SHALL be used instead to
   open the WebSocket connection. “

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 17 Jan 2017 14:39:43 +0000

Hi Mirja,

Thanks for your feedback. Please see inline <Ram>

-----Original Message-----
From: Mirja Kuehlewind <[email-masked]>
Date: Tuesday, 17 January 2017 at 7:51 PM
To: The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Charles Eckel (eckelcu)" <[email-masked]>, "[email-masked]" <[email-masked]>, "Charles Eckel (eckelcu)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Mirja Kühlewind's No Objection on draft-ietf-bfcpbis-bfcp-websocket-13: (with COMMENT)
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Tuesday, 17 January 2017 at 7:51 PM

    

<Ram> Proposed text looks good. I will update and also check for similar wording in rest of doc.

<Ram> The BFCP message validation has to be still done by BFCP stack. WS is just a means to transport. I will remove the above line 

<Ram> Ok I will move this as last line in 4.2

<Ram> How about replacing the text with this ?
When the 'ws-uri' or 'wss-uri' attribute is present in the
       media section of the SDP, the procedures mentioned in [I.D. ietf-bfcpbis-sdp-ws-uri] MUST be followed”.

Regards,
Ram