Subject: [bfcpbis] Review of draft-ietf-bfcpbis-bfcp-websocket-13

From: Robert Sparks <[email-masked]>
Date: Wed, 04 Jan 2017 14:35:57 -0800

Reviewer: Robert Sparks
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-bfcpbis-bfcp-websocket13-
Reviewer: Robert Sparks
Review Date: 2017-01-04
IETF LC End Date: 2017-01-11
IESG Telechat date: 2017-01-19

Summary: Basically ready but with issues that need to be addressed
before publication as a Proposed Standard

Issues: 

The BFCP spec (at draft-ietf-bfcpbis-rfc4582bis) relies heavily on
recommendations it makes about the use of TLS or DTLS, and even goes
to
the point of specifyig a particular set of cipher suites to use wih
those protocols when using them with BFCP. The security
considerations
section of that document details some specific attacks and how the
use
of TLS/DTLS mitigates them (providing some justification for the
cipher
suites that the document specifies).

This document provides a _COMPLETELY DIFFERENT_ security mechanism
(essentially punting entirely to whatever a websocket library
provides
with the expectation that that will also be rooted in TLS) when it
substitutes websockets as the layer under BFCP. The security
considerations section needs to make this much more obvious -
implementers and deployers need to be see this as a strong-primary
point to avoid anyone thinking all the thinking that went into
securing
BFCP as captured in draft-ietf-bfcpbis-rfc4582bis still applies.

There should be more discussion about what a BFCP implementation that
cares about the attacks discussed in section 14 of
draft-ietf-bfcpbis-rfc4582bis requires of its library. The current
document gets most of the way there, but there are things missing.
Shouldn't there be some discussion of ensuring the websocket library
used supports and will use the cipher suites called out in the core
BFCP document? If not, this document needs to be very explicit that
you
are only going to get the confidentiality protection the library
provides. The current consideration section calls out relying on "a
typical webserver-client model" and talks about server
authentication,
but not client authentication. Section 8 shows most of what you're
expecting the server to do to authenticate the client, but you need
more text about what you expect the client libraries to be doing to
let
the server do its job (and you should point back to that from the
security considerations section).

I strongly recommend simply walking through the cases again in the
security considerations section of this document, explaining how the
websocket library and the bfcp implementation are going to interact
to
mitigate the attacks. 

Nits/editorial comments: 

The 3rd paragraph of section 3 speaks generally about how the
websocket
protocol works - you call out it can carry text or binary data and
that
it supports split frames. But then you go on to constrain the use of
the protocol in this document to a particular bit of binary data and
constrain using the protocol to not split frames (and to only put one
BFCP message in each frame). This is confusing. I suggest deleting
the
second sentence of that paragraph and the indented call-out below it.
If the observation about the API callbacks is important, work it in 
where you talk about the one-messsage-per-frame restriction.

The last sentence of the second paragraph of section 5 relies on an
inference that you should make explicit. Instead of "is a server on
the
Internet", say "will have a globally routable address". 

The last paragraph of 6.1 is not logically sound - it falls apart at
"So". Please restructure it. As it stands, it says something like:
'Some soda manufacturers don't provide sugar-free variants of their
soda. Therefore, we recommend always drinking sugar-laden soda, but
we
allow drinking sugar-free.' What were you actually trying to say?

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 16 Jan 2017 05:36:55 +0000

Hi Robert,

Thanks for your review. Please see inline <Ram>

>-----Original Message-----
>From: Robert Sparks <[email-masked]>
>Date: Thursday, 5 January 2017 at 4:05 AM
>To: "[email-masked]" <[email-masked]>
>Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" ><[email-masked]>
>Subject: Review of draft-ietf-bfcpbis-bfcp-websocket-13
>Resent-From: <[email-masked]>
>Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, ><[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, ><[email-masked]>, Charles Eckel <[email-masked]>
>Resent-Date: Thursday, 5 January 2017 at 4:05 AM

    
 >   BFCP as captured in draft-ietf-bfcpbis-rfc4582bis still applies.

<Ram> I will add the below line in security consideration section. Is this sufficient?

NEW:
“The security considerations described in draft-ietf-bfcpbis-rfc4582bis are applicable here as well.”
    
    > provides.

<Ram> Good point. I would prefer to add a text something to the effect of:

“The security considerations mentioned in section 14 of [draft-ietf-bfcpbis-rfc4582bis] are applicable here. In order to mitigate
the attacks mentioned in section 14 of [draft-ietf-bfcpbis-rfc4582bis], it is RECOMMENDED that the clients and server use secure WebSocket 
with an encryption algorithm according to Section 7 of [draft-ietf-bfcpbis-rfc4582bis]”

> The current consideration section calls out relying on "a

<Ram> section 8 second para has text on what client should do. Also 4th para has some text.  Is there anything else you would like to see in that?
 I will add a line in security considerations

EXISTING:
The security model here is a typical webserver-
   client model where the client validates the server certificate and
   then connects to the server

NEW:
The security model here is a typical webserver-
   client model where the client validates the server certificate and
   then connects to the server. Section 8 describes the authentication procedures between client and server. 
    
   > where you talk about the one-messsage-per-frame restriction.

<Ram>  I am ok to delete the second line and the indented call-out.

  > Internet", say "will have a globally routable address". 

<Ram> Ok will fix it.

  >  allow drinking sugar-free.' What were you actually trying to say?

How about changing to this?

EXISTING:
Some web browsers do not allow non-secure WebSocket connections to be
   made.  So, while this document recommends the use of Secure
   WebSockets (i.e.TCP/WSS) for security reasons, TCP/WS is also
   permitted so as to achieve maximum compatibility among clients.

NEW:
While this document recommends the use of Secure
   WebSockets (i.e.TCP/WSS) for security reasons, TCP/WS is also
   permitted so as to achieve maximum compatibility among clients.

Regards,
Ram

---

From: Robert Sparks <[email-masked]>
Date: Tue, 17 Jan 2017 09:21:23 -0600

> “The security considerations described in draft-ietf-bfcpbis-rfc4582bis are applicable here as well.”
Well, no. That misses the point entirely.

> with an encryption algorithm according to Section 7 of [draft-ietf-bfcpbis-rfc4582bis]”
Do websocket libraries give the application that kind of control?
> <Ram> section 8 second para has text on what client should do. Also 4th para has some text.  Is there anything else you would like to see in that?
Yes - you're still looking at the text that describes how the client 
authenticates the server.
I was asking for more text talking about what the client needs to do to 
allow the server to authenticate the client.
I'm rereading the 5th paragraph now and maybe you're saying all you can.

>     permitted so as to achieve maximum compatibility among clients.
That's much clearer

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Thu, 19 Jan 2017 03:37:59 +0000

Just to close this thread. We had an offline discussion with Robert and posted a new revision with his comments incorporated. Below are the changes

In security consideration section we added:
When using BFCP over websockets, the security mechanisms defined in
   [I-D.ietf-bfcpbis-rfc4582bis] are not used.  Instead, the application
   is required to build and rely on the security mechanisms in
   [RFC6455].

On the point about websocket libraries giving the application the control to select the algorithm to use for TLS setup, there is no such control provided by the current WS API 
at https://www.w3.org/TR/2012/CR-websockets-20120920/ WebSocket W3C API spec 

New revision published with Roberts comments: https://www.ietf.org/rfcdiff?url2=draft-ietf-bfcpbis-bfcp-websocket-14

Regards,
Ram

-----Original Message-----
From: Robert Sparks <[email-masked]>
Date: Tuesday, 17 January 2017 at 8:51 PM
To: "Ram Mohan R (rmohanr)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Review of draft-ietf-bfcpbis-bfcp-websocket-13

    
    That's much clearer