Subject: [bfcpbis] BFCP with ICE: MIT transport?

From: Christer Holmberg <[email-masked]>
Date: Fri, 3 Feb 2017 13:56:35 +0000

Hi,

During the MMUSIC session in Seoul we discussed a number of issues related to ICE-SDP. We made some decisions, and I got action points to verify one of those on the list.

One of those issues affect BFCP, when used with ICE.

Example:

BFCP client A supports both UDP and TCP, sends an SDP offer with UDP proto in the SDP m- line. The TCP option is given as an ICE candidate.

BFCP server B only supports TCP.

The problem is that, according to RFC 3264, the m- line proto value in the answer must match the value in the offer. But, server B does not support UDP.

Two alternatives were discussed:

ALT #1: Every protocol that supports ICE must define a MIT transport. That transport must always be reflected in the m- line proto (additional transports are provided as ICE candidates).

ALT #2: Allow an m- line proto value in the answer even if the answerer does not support the associated transport – as long as the answerer provides a candidate with the supported transport.

Based on the discussions, there was strong consensus to go for Alt#2, which was allowing a transport in the m- line of the answer even if the answerer doesn’t support it, as ICE candidates will be used to determine the transport.

Having said that, that still does not prevent individual protocols to specify a MIT transport.

So, my QUESTION is: should we specify a MIT transport for BFCP? Again, this only applies to usage with ICE.

The associated slides from the meting can be found here:

https://www.ietf.org/proceedings/97/slides/slides-97-mmusic-ice-sip-sdp-00.pdf

(See slides 4-6)

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 3 Feb 2017 16:55:06 +0000

MIT = MTI = Mandatory To Implement

Sent from my iPhone

On 3 Feb 2017, at 15.56, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Example:

(See slides 4-6)

Regards,

Christer

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 3 Feb 2017 12:18:48 -0500

On 2/3/17 8:56 AM, Christer Holmberg wrote:
>
> Hi,
>
> During the MMUSIC session in Seoul we discussed a number of issues
> related to ICE-SDP. We made some decisions, and I got action points to
> verify one of those on the list.
>
> BFCP client A supports both UDP and TCP, sends an SDP offer with UDP
> proto in the SDP m- line. The TCP option is given as an ICE candidate.
>

When we talk about a BFCP implementation supporting TCP I think we mean 
the BFCP that runs directly over TCP.

But when talk about ICE over TCP I think we are talking about UDP 
packets framed over TCP. That is really something different that the 
BFCP implementation may or may not support.

Its important not to conflate these.

But I think that is mostly distinct from the question below.

	Thanks,
	Paul

> The problem is that, according to RFC 3264, the m- line proto value in
> the answer must match the value in the offer. But, server B does not
> support UDP.
>
> ALT #1: Every protocol that supports ICE must define a MIT transport.
> That transport must always be reflected in the m- line proto (additional
> transports are provided as ICE candidates).
>
> ALT #2: Allow an m- line proto value in the answer even if the answerer
> does not support the associated transport – as long as the answerer
> provides a candidate with the supported transport.
>
>
> Based on the discussions, there was strong consensus to go for Alt#2,
> which was allowing a transport in the m- line of the answer even if the
> answerer doesn’t support it, as ICE candidates will be used to determine
> the transport.
>
>
> [email-masked]

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 10 Feb 2017 22:18:38 +0000

As an individual, I think Alt#2 is fine for BFCP and we do not need to define a mandatory to implement transport when using ICE.

Cheers,
Charles 

-----Original Message-----
From: bfcpbis <[email-masked]> on behalf of Paul Kyzivat <[email-masked]>
Date: Friday, February 3, 2017 at 9:18 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] BFCP with ICE: MIT transport?

    

    
    	Thanks,
    	Paul