Subject: Re: [bfcpbis] Ben Campbell's Discuss on draft-ietf-bfcpbis-rfc4583bis-26: (with DISCUSS and COMMENT)

From: Christer Holmberg <[email-masked]>
Date: Sun, 2 Dec 2018 11:32:07 +0000

Hi Ben,

Thanks for your review!

As the MUX category issue is discussed in a dedicated thread, I will not address it in this reply.
 
>    §4: "The fmt (format) list is not applicable to BFCP. The fmt list of ’m’
>    lines in the case of any proto field value related to BFCP MUST
>    contain a single "*" character. If the the fmt list contains any
>    other value it is ignored."
>    
>    It seems like the last sentence should use a MUST to match the one in the
>    previous sentence.
  
I will modify to "any other value MUST be ignored".

---

>    §3: "Typically, a client that establishes a BFCP
>    stream with a conference server will act as a floor control client,
>    while the conference server will act as a floor control server."
>    
>    The use of "typically" seems odd without a discussion of when it might not.
>    Perhaps a forward reference to section 7 would help?
  
I don't think referencing section 7 would help, because it only talks about the TCP roles.

I suggest to remove the "Typically,.." sentence.

---
  
>    §6: "[I-D.ietf-mmusic-sdp-mux-attributes] defines the mux categories for
>    the SDP attributes defined in this specification. Table 2 defines
>    the mux category for the ’bfcpver’ attribute:"
>    
>    I assume the first sentence should say "... except for bfcpver."?

Well, it IS said in the second sentence, but I will add the suggested text.

---
    
>    §10, 3rd paragraph: Incorrect comma use in "... SDP), in ..."

I will remove the comma.

---

>    §10.1, last paragraph: "... value, in the offer, ...": The first comma is
    incorrect.

I will remove the comma.

---

> §10.3: First paragraph: "When the offerer receives an answer, which
>    contains an ’m’ line..." s/ ", which" / "that"
  
I will change to "that".

---

>    §16.2: It seems like [I-D.ietf-mmusic-sdp-mux-attributes] should be a normative
>    reference.
  
I will make the reference normative.

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Wed, 5 Dec 2018 11:08:20 -0600

That all looks good to me.

Thanks!

Ben.

> On Dec 2, 2018, at 5:32 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi Ben,
> 
> Thanks for your review!
>