Subject: Re: [bfcpbis] Alexey Melnikov's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)

From: Christer Holmberg <[email-masked]>
Date: Sun, 2 Dec 2018 11:32:09 +0000

Hi,

I suggest to add to add the following:

"The maximum length of the attribute value is determined by the COMMON-HEADER format [reference-to-4582bis]."

Regards,

Christer

On 24/10/2018, 13.02, "bfcpbis on behalf of Alexey Melnikov" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Charles,
    
    > On 23 Oct 2018, at 18:56, Charles Eckel (eckelcu) <[email-masked]> wrote:
    > 
    > Hi Alexey,
    > 
    > Thank you for your review and comments.
    > The maximum value for each of these is determined by the COMMON-HEADER format in https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4582bis-16#section-5.1.
    
    I think adding a cross reference would help readers/implementors.
    
    Best Regards,
    Alexey
    
    > Cheers,
    > Charles
    > 
    > -----Original Message-----
    > From: Alexey Melnikov <[email-masked]>
    > Date: Tuesday, October 23, 2018 at 3:44 PM
    > To: The IESG <[email-masked]>
    > Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Mary Barnes <[email-masked]>, "[email-masked]" <[email-masked]>
    > Subject: Alexey Melnikov's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)
    > Resent-From: <[email-masked]>
    > Resent-To: Charles Eckel <[email-masked]>, Keith Drage <[email-masked]>
    > Resent-Date: Tuesday, October 23, 2018 at 3:44 PM
    > 
    >    Alexey Melnikov has entered the following ballot position for
    >    draft-ietf-bfcpbis-rfc4583bis-26: No Objection
    > 
    >    When responding, please keep the subject line intact and reply to all
    >    email addresses included in the To and CC lines. (Feel free to cut this
    >    introductory paragraph, however.)
    > 
    > 
    >    Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
    >    for more information about IESG DISCUSS and COMMENT positions.
    > 
    > 
    >    The document, along with other ballot positions, can be found here:
    >    https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-rfc4583bis/
    > 
    > 
    > 
    >    ----------------------------------------------------------------------
    >    COMMENT:
    >    ----------------------------------------------------------------------
    > 
    >    I have one small issue with this document which applies to several sections:
    > 
    >    5.2.  SDP 'confid' Attributes
    > 
    >           The Augmented BNF syntax [RFC5234] for the attribute is:
    > 
    >             conference-id = 1*DIGIT
    > 
    >    Is there any limit on the maximum allowed value of this attribute?
    > 
    > 
    >    The same issue in all the following sections where "1*DIGIT" construct is used:
    > 
    >    5.3.  SDP 'userid' Attribute
    > 
    >    5.4.  SDP 'floorid' Attribute
    > 
    >    5.5.  SDP 'bfcpver' Attribute
    > 
    > 
    > 
    > 
    
    _______________________________________________
    bfcpbis mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 4 Dec 2018 07:13:58 +0000

Please see inline, marked with [cue]

-----Original Message-----
From: Christer Holmberg <[email-masked]>
Date: Sunday, December 2, 2018 at 3:32 AM
To: Alexey Melnikov <[email-masked]>, Charles Eckel <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Mary Barnes <[email-masked]>, The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] Alexey Melnikov's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)

    Hi,

[cue] I agree; however, I think it would be better to replace maximum length with maximum value.

Cheers,
Charles
    
    Regards,
    
    Christer

    
        Hi Charles,

        
        Best Regards,
        Alexey

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 4 Dec 2018 07:44:52 +0000

Hi,

I will replace with "maximum value".

Regards,

Christer

________________________________
From: Charles Eckel (eckelcu) <[email-masked]>
Sent: Tuesday, December 4, 2018 9:13 AM
To: Christer Holmberg; Alexey Melnikov
Cc: [email-masked]; [email-masked]; The IESG; [email-masked]
Subject: Re: [bfcpbis] Alexey Melnikov's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)

-----Original Message-----
From: Christer Holmberg <[email-masked]>
Date: Sunday, December 2, 2018 at 3:32 AM
To: Alexey Melnikov <[email-masked]>, Charles Eckel <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Mary Barnes <[email-masked]>, The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] Alexey Melnikov's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)

    Hi,

Cheers,
Charles

    Regards,

    Christer

        Hi Charles,

        Best Regards,
        Alexey

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 4 Dec 2018 13:10:58 +0000

Hi,

I have made a commit with the “maximum value” change.

Regards,

Christer

From: Christer Holmberg <[email-masked]>
Date: Tuesday, 4 December 2018 at 9.45
To: Charles Eckel <[email-masked]>, Alexey Melnikov <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] Alexey Melnikov's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)
Resent-From: <[email-masked]>
Resent-To: Gonzalo Camarillo <[email-masked]>, <[email-masked]>, Christer Holmberg <[email-masked]>
Resent-Date: Tuesday, 4 December 2018 at 9.45

Hi,

Regards,

Christer

-----Original Message-----
From: Christer Holmberg <[email-masked]>
Date: Sunday, December 2, 2018 at 3:32 AM
To: Alexey Melnikov <[email-masked]>, Charles Eckel <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Mary Barnes <[email-masked]>, The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] Alexey Melnikov's No Objection on draft-ietf-bfcpbis-rfc4583bis-26: (with COMMENT)

    Hi,

Cheers,
Charles

    Regards,

    Christer

        Hi Charles,

        Best Regards,
        Alexey