Subject: [Bgp-autoconf] Progress report of design team on IDR virtual meeting

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 23 Mar 2020 15:22:32 +0000

Hi all, 

You may notice that we will have a time slot on the IDR virtual meeting on March 30 to introduce the progress of BGP autoconf design team. 

Here are what I think we could introduce to the WG. 

1. The purpose of the design team: determine the problem space, identify the requirements, review the solution space
2. How we worked during the past 2 months
3. The collected requirements: the minimal set of common ones and the union of other requirements
4. The list of current solution drafts
5. We may also briefly introduce the comparison of the solution documents, this could be based on the comparisons from Warren. 
6. Next steps

Please let me know if there is anything else you think we should present to the WG. 

The plan is: I will prepare an initial version of the slide deck by Wednesday, then the team could review it and give further suggestion.

Best regards,
Jie

---

From: Randy Bush <[email-masked]>
Date: Mon, 23 Mar 2020 19:16:19 -0700

> 2. How we worked during the past 2 months

email distributions by time and by person

>    union of other requirements

would like to see these two lists again, requirements and agreed non-
requirements

> 4. The list of current solution drafts

i would not call them solution drafts.  more various efforts in this
space from which it would be good to steal

randy

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 24 Mar 2020 14:57:16 +0000

Hi Randy, 

> -----Original Message-----
> From: Randy Bush [mailto:[email-masked]]
> Sent: Tuesday, March 24, 2020 10:16 AM
> To: Dongjie (Jimmy) <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Bgp-autoconf] Progress report of design team on IDR virtual
> meeting
> 

The collected requirements can be found at: https://mailarchive.ietf.org/arch/msg/bgp-autoconf/a6JCSbhvCFiqJG1TUeZTFyTeFj4/

Note in that mail they are categorized as common requirements, union of other functional requirements and requirements about design principle.

And based on the recent discussion, "Discover the role of the connected nodes" will be added to the list of "common requirements"

> i would not call them solution drafts.  more various efforts in this space from
> which it would be good to steal

Or maybe could call them existing proposals. 

Best regards,
Jie

---

From: Randy Bush <[email-masked]>
Date: Tue, 24 Mar 2020 15:37:53 -0700

jimmy,

my apologies for my poor communication.  let me try with text

  Two prospective peers SHOULD be able to exchange arbitrary attributes
  to communicate things such as position or role in a topology, link
  speeds and/or loading, preferred time of day, favorite ice cream, etc.
  None of these example attributes are requirements, will be specified,
  given code points, etc. in the protocol design.  But there SHOULD be a
  protocol provision for communicating arbitrary attributes so that the
  operator may configure as needed for their environment.

hope that helps.

randy

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 24 Mar 2020 23:48:06 +0100

All,

I completely agree with Randy on this part:

" None of these example attributes are requirements, will be specified, given
code points, etc. in the protocol design."

On the rest I would actually go even further and say that such things
should be out of scope of pure and simple auto discovery.

Reason being that once you open a trunk - even if originally empty or
containing only spare tire - folks will load it with junk
beyond imagination making the interop nightmare, opportunity to keep old
mantra alive fix one bug intro two etc ...

And as I said in the other note - some of this stuff being proposed should
be transitive and IMHO belongs in BGP not in autodiscovery.

Thx

On Tue, Mar 24, 2020 at 11:38 PM Randy Bush <[email-masked]> wrote:

> --
> Bgp-autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bgp-autoconf
>

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 24 Mar 2020 15:53:17 -0700

I’m with Robert here, autodiscovery meant to provide minimum necessary amount of data to establish peering relationship, the rest is done thought BGP.

Cheers,
Jeff
On Mar 24, 2020, 3:48 PM -0700, Robert Raszuk <[email-masked]>, wrote:
> " None of these example attributes are requirements, will be specified, given code points, etc. in the protocol design."
>
> On the rest I would actually go even further and say that such things should be out of scope of pure and simple auto discovery.
>
> Reason being that once you open a trunk - even if originally empty or containing only spare tire - folks will load it with junk beyond imagination making the interop nightmare, opportunity to keep old mantra alive fix one bug intro two etc ...
>
> And as I said in the other note - some of this stuff being proposed should be transitive and IMHO belongs in BGP not in autodiscovery.
>
> Thx
>
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 25 Mar 2020 03:33:56 +0000

Hi Randy, 

Thanks for your further clarification. Thus what you suggest is a generic capability to communicate arbitrary attributes according to the operators' need. Is my understanding correct?

" But there SHOULD be a protocol provision for communicating arbitrary attributes so that the operator may configure as needed for their environment."

Do you think such information exchange should happen in the peer autodiscovery/autoconf stage? 

I'd also appreciate other team members' opinion on:

1. Whether it is a requirement to bgp autoconf, or it should be done after BGP session is established?

2. Whether it should be a generic capability for operator's customization, or some guidance or structure needs be specified as part of the protocol design?

Best regards,
Jie

-----Original Message-----
From: Randy Bush [mailto:[email-masked]] 
Sent: Wednesday, March 25, 2020 6:38 AM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bgp-autoconf] Progress report of design team on IDR virtual meeting

jimmy,

hope that helps.

randy

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 25 Mar 2020 06:29:48 +0000

Hi Robert,

Thanks for sharing your opinion.

I see you used the words “out of scope of pure and simple auto discovery”, does it mean that the capability as described in Randy’s text should be entirely out of scope of BGP auto discovery, or it could be an optional capability of BGP auto discovery?

I understand your concern about possible overloading of such vehicle, which could be discussed further with the WG, while at current stage we are discussing whether such capability is needed or not in BGP auto discovery.

For attributes which needs to be transitive, I agree that there are more suitable mechanisms to carry them.

Best regards,
Jie

From: Robert Raszuk [mailto:[email-masked]]
Sent: Wednesday, March 25, 2020 6:48 AM
To: Randy Bush <[email-masked]>
Cc: Dongjie (Jimmy) <[email-masked]>; [email-masked]
Subject: Re: [Bgp-autoconf] Progress report of design team on IDR virtual meeting

All,

Thx

On Tue, Mar 24, 2020 at 11:38 PM Randy Bush <[email-masked]<mailto:[email-masked]>> wrote:
jimmy,

hope that helps.

randy

--
Bgp-autoconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bgp-autoconf

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 25 Mar 2020 06:45:09 +0000

Hi Jeff,

Thanks for sharing your opinion on this.  So you also think additional attributes about the peer should be communicated after the BGP session is established.

I agree that we need to define the minimal set of requirements of BGP autoconf/auto discovery, and you could check the list of common requirements in my previous mail.

Best regards,
Jie

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Wednesday, March 25, 2020 6:53 AM
To: Randy Bush <[email-masked]>; Robert Raszuk <[email-masked]>
Cc: [email-masked]; Dongjie (Jimmy) <[email-masked]>
Subject: Re: [Bgp-autoconf] Progress report of design team on IDR virtual meeting

Cheers,
Jeff
On Mar 24, 2020, 3:48 PM -0700, Robert Raszuk <[email-masked]<mailto:[email-masked]>>, wrote:

All,

Thx

hope that helps.

randy

---

From: Randy Bush <[email-masked]>
Date: Wed, 25 Mar 2020 06:15:11 -0700

jimmy,

> Thanks for your further clarification. Thus what you suggest is a
> generic capability to communicate arbitrary attributes according to
> the operators' need. Is my understanding correct?

yes.  i did point to how l3dl-ulpc does that.  [ not meant as an
argument to adopt l3dl ]

> autodiscovery/autoconf stage?

sure.  if and only if there are no predefined semantics, then it's just
some bits on the wire that the op can leverage.

randy

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 27 Mar 2020 02:44:31 +0000

Hi Randy, 

Thanks for your confirmation. I'll put together all our discussion about this into the slides of the design team progress report.

Best regards,
Jie

-----Original Message-----
From: Bgp-autoconf [mailto:[email-masked]] On Behalf Of Randy Bush
Sent: Wednesday, March 25, 2020 9:15 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bgp-autoconf] Progress report of design team on IDR virtual meeting

jimmy,

> the operators' need. Is my understanding correct?

yes.  i did point to how l3dl-ulpc does that.  [ not meant as an argument to adopt l3dl ]

> autodiscovery/autoconf stage?

sure.  if and only if there are no predefined semantics, then it's just some bits on the wire that the op can leverage.

randy