Subject: [Bier] 答复: Re: New Version Notification for draft-chh-bier-bier-yang-01.txt

From: [email-masked]
Date: Mon, 2 Nov 2015 17:02:54 +0800

Hi, Reshad

Thanks for your comments.

Please see inline marked with [hfw].

Hi,

Took a look and here are some quick comments:
bitstringlengthenum is defined in a couple of places, instead you should 
have a typedef and use that typedef for all your bitstringlength leaf 
nodes. There are also some bitstringlength leaf nodes which are of type 
uint16, I believe this is incorrect.

[hfw] We  Define two types of bitstringLenths (imposition and disposition) 
instead of one just for more flexibility.  If the type is enumeration, the 
values are 64, 128, 256,512,etc. 
If the type of bitstringlength is uint16, it means that the 
bitstringlength is a unique value. 

Leaf SI, in description spell out the full name “Set identifier”.

[hfw]Ok. 

Might be good to have a type for BIER base types such as SI, sub-domain ID 
etc. YANG experts can advise you on this.
[hfw]Ok.

For AF, my understanding is that recommendation is to have a list indexed 
by AF, so you could combine list ipv4 and list ipv6 into 1 list . Please 
take a look at draft-raza-mpls-ldp-mldp-yang-02 for an example.

[hfw] There are some documents defines that IPv4 and IPv6  separately, 
while the mpls ldp mldp yang data uses the list indexed by AF, so I am not 
sure which one is better.

For label instead of uint32 you should eventually use mpls-label from 
ietf-mpls.yang

[hfw]Ok. We will use mpls-lable instead of uint32.

For bfr-nbr you don’t need to have your own union of  ipv4-address and 
ipv6-address, use existing ip-address typedef from RFC6021

[hfw] The bfr-nbr may be a IPv4 address or IPv6 address. 

The BIRT portion needs to be described in section 5, e.g. why that key was 
chosen etc etc. Not a BIER expert but I am not sure the routing table as 
modelled is complete/correct.

[hfw] We can identify a BIRT entry if we use the three keys(sub-domain-id, 
bitstringlength, SI).

Regards.
Fangwei.

"Reshad Rahman (rrahman)" <[email-masked]> 
2015-10-31 05:44

收件人
"[email-masked]" <[email-masked]>, 
抄送
"[email-masked]" <[email-masked]>, BIER <[email-masked]>, 
"[email-masked]" <[email-masked]>, "Mahesh Sivakumar 
(masivaku)" <[email-masked]>, "[email-masked]" 
<[email-masked]>
主题
Re: [Bier] New Version Notification for draft-chh-bier-bier-yang-01.txt

Hi,

Took a look and here are some quick comments:
bitstringlengthenum is defined in a couple of places, instead you should 
have a typedef and use that typedef for all your bitstringlength leaf 
nodes. There are also some bitstringlength leaf nodes which are of type 
uint16, I believe this is incorrect.
Leaf SI, in description spell out the full name “Set identifier”.
Might be good to have a type for BIER base types such as SI, sub-domain ID 
etc. YANG experts can advise you on this.
For AF, my understanding is that recommendation is to have a list indexed 
by AF, so you could combine list ipv4 and list ipv6 into 1 list . Please 
take a look at draft-raza-mpls-ldp-mldp-yang-02 for an example.
For label instead of uint32 you should eventually use mpls-label from 
ietf-mpls.yang
For bfr-nbr you don’t need to have your own union of  ipv4-address and 
ipv6-address, use existing ip-address typedef from RFC6021
The BIRT portion needs to be described in section 5, e.g. why that key was 
chosen etc etc. Not a BIER expert but I am not sure the routing table as 
modelled is complete/correct.

Regards,
Reshad.

From: "[email-masked]" <[email-masked]>
Date: Friday, October 23, 2015 at 2:38 AM
To: Reshad <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, BIER <[email-masked]>, "
[email-masked]" <[email-masked]>, "Mahesh Sivakumar 
(masivaku)" <[email-masked]>, "[email-masked]" <
[email-masked]>
Subject: Re: [Bier] New Version Notification for 
draft-chh-bier-bier-yang-01.txt

Hi Reshad, 
Thank you your comments. 
please see inline.Thanks. 

Regards, 
Ran

发件人:         "Reshad Rahman (rrahman)" <[email-masked]>
收件人:         "[email-masked]" <[email-masked]>, "
[email-masked]" <[email-masked]>, 
抄送:        "[email-masked]" <[email-masked]>, "
[email-masked]" <[email-masked]>, "Mahesh Sivakumar 
\(masivaku\)" <[email-masked]>
日期:         2015/10/22 22:10
主题:        Re: [Bier] New Version Notification for 
draft-chh-bier-bier-yang-01.txt
发件人:        "BIER" <[email-masked]>

Hi, 

Repeating the same comments as for 00, the 2 following comments still 
apply for sure 
Please follow RFC6087 guidelines e.g. use of <CODE BEGINS>, <CODE ENDS> 
etc   
<Ran>: OK. we will add it in next version. Thanks 
Finally, please use the validator @ http://www.yangvalidator.com/          

<Ran>:  Sure, we have used this validator, and have passed.Please see 
below:

Regards, 
Reshad. 

From: BIER <[email-masked]> on behalf of "[email-masked]" <
[email-masked]>
Date: Thursday, October 22, 2015 at 4:59 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Mahesh Sivakumar 
(masivaku)" <[email-masked]>, "[email-masked]" <
[email-masked]>
Subject: [Bier] New Version Notification for 
draft-chh-bier-bier-yang-01.txt

Hi all， 
We have updated draft-chh-bier-bier-yang to 01 version.
The link is：  
https://www.ietf.org/internet-drafts/draft-chh-bier-bier-yang-01.txt
Any comments and suggestion are welcome. Thanks.
Regards, 
Ran

[email-masked] 写于 2015/10/19 10:27:13:

> 发件人:  [email-masked]
> 收件人:  "Xianxian Dai" <[email-masked]>, 
> "[email-masked]" <[email-masked]>, "Zheng Zhang" 
> <[email-masked]>, "fangwei hu" <[email-masked]>, 
> "Fangwei Hu" <[email-masked]>, "Ran Chen" 
> <[email-masked]>, "Mahesh Sivakumar" <[email-masked]>, 
> "Zheng Zhang" <[email-masked]>, "Mahesh Sivakumar" 
> <[email-masked]>, "Ran Chen" <[email-masked]>, 
> 日期:  2015/10/19 10:27 
> 主题: New Version Notification for draft-chh-bier-bier-yang-01.txt
> 
> 
> A new version of I-D, draft-chh-bier-bier-yang-01.txt
> has been successfully submitted by Ran Chen and posted to the
> IETF repository.
> 
> Name:      draft-chh-bier-bier-yang
> Revision:   01
> Title:      YANG Data Model for BIER Protocol
> Document date:   2015-10-16
> Group:      Individual Submission
> Pages:      17
> URL:            https://www.ietf.org/internet-drafts/draft-chh-bier-
> bier-yang-01.txt
> Status:         
https://datatracker.ietf.org/doc/draft-chh-bier-bier-yang/
> Htmlized:       https://tools.ietf.org/html/draft-chh-bier-bier-yang-01
> Diff:           
https://www.ietf.org/rfcdiff?url2=draft-chh-bier-bier-yang-01
> 
> Abstract:
>    This document defines a YANG data model for BIER configuration and
>    operation.
> 
>  
> 
> 
> Please note that it may take a couple of minutes from the time of 
submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
-----来自 <[email-masked]> 的消息，在 Thu, 23 Jul 2015 20:46:17 
+0800 ----- 
收件人:
"Reshad Rahman (rrahman)" <[email-masked]> 
抄送:
"[email-masked]" <
[email-masked]>, "[email-masked]" <[email-masked]>, 
BIER <[email-masked]>
主题:
Re: [Bier] Comments on draft-chh-bier-bier-yang-00

Hi, Rahman,

Thanks for your comments, we will correct it based on your suggestion.

Regards 
Fangwei.

"Reshad Rahman (rrahman)" <[email-masked]>
发件人:  "BIER" <[email-masked]> 
2015-07-23 19:43

收件人
"[email-masked]" <
[email-masked]>, 
抄送
"[email-masked]" <[email-masked]>
主题
[Bier] Comments on draft-chh-bier-bier-yang-00

Hi authors, 
I tried to pyang the model in the draft and ran into quite a few errors. I 
stopped after the 4 below (these are basic YANG errors, wasn’t even using 
strict/ietf option)
Once you fix these errors please compile with ―ietf option (sricter rules 
regarding ordering of statements, requiring description etc etc)
Please follow RFC6087 guidelines e.g. use of <CODE BEGINS>, <CODE ENDS> 
etc
Finally, please use the validator @ http://www.yangvalidator.com/

Regards, 
Reshad. 

ERRORS 

No “” for the contact 
ietf-bier.yang:34: error: unterminated statement definition for keyword 
"contact", looking at L

Extra “ in "reference "draft-chen-bier-bier-yang-00”;
59: error: unterminated statement definition for keyword "reference", 
looking at d

Missing ; in key "sub-domain-id" 
125: error: unterminated statement definition for keyword "key", looking 
at l

Missing ; in type if:interface-ref 
154: error: unterminated statement definition for keyword "type", looking 
at }

_______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier
[附件 "ATT00002.txt" 被 陈然080434/user/zte_ltd 删除]
_______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 2 Nov 2015 09:36:03 +0000

Hi Fangwei,

Comments <RR> on couple of your replies

  *   bitstringlengthenum is defined in a couple of places, instead you should have a typedef and use that typedef for all your bitstringlength leaf nodes. There are also some bitstringlength leaf nodes which are of type uint16, I believe this is incorrect.

[hfw] We  Define two types of bitstringLenths (imposition and disposition) instead of one just for more flexibility.  If the type is enumeration, the values are 64, 128, 256,512,etc.
If the type of bitstringlength is uint16, it means that the bitstringlength is a unique value.

<RR> You can still have a typedef for the enumeration, in the current model the enumeration is defined twice.

  *   For bfr-nbr you don’t need to have your own union of  ipv4-address and ipv6-address, use existing ip-address typedef from RFC6021

[hfw] The bfr-nbr may be a IPv4 address or IPv6 address.
<RR> This is ok. My point is that you don’t have to define the union, you can reuse existing ip-address type, it’s a union so can be V4 or V6.

  *   The BIRT portion needs to be described in section 5, e.g. why that key was chosen etc etc. Not a BIER expert but I am not sure the routing table as modelled is complete/correct.

[hfw] We can identify a BIRT entry if we use the three keys(sub-domain-id, bitstringlength, SI).
<RR> What you have to consider, and maybe you have already, is whether you want to be able to e.g. list all the entries for 1 sub-domain. If you do, then you may want to have nested containers as opposed to using a composite key.

Regards,
Reshad.

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 2, 2015 at 5:02 AM
To: Reshad <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, BIER <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahesh Sivakumar (masivaku)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: 答复: Re: [Bier] New Version Notification for draft-chh-bier-bier-yang-01.txt

Hi, Reshad

Hi,

  *   bitstringlengthenum is defined in a couple of places, instead you should have a typedef and use that typedef for all your bitstringlength leaf nodes. There are also some bitstringlength leaf nodes which are of type uint16, I believe this is incorrect.
  *

[hfw] We  Define two types of bitstringLenths (imposition and disposition) instead of one just for more flexibility.  If the type is enumeration, the values are 64, 128, 256,512,etc.
If the type of bitstringlength is uint16, it means that the bitstringlength is a unique value.

  *   Leaf SI, in description spell out the full name “Set identifier”.
  *

[hfw]Ok.

  *   Might be good to have a type for BIER base types such as SI, sub-domain ID etc. YANG experts can advise you on this.

[hfw]Ok.

  *
  *   For AF, my understanding is that recommendation is to have a list indexed by AF, so you could combine list ipv4 and list ipv6 into 1 list . Please take a look at draft-raza-mpls-ldp-mldp-yang-02 for an example.

[hfw] There are some documents defines that IPv4 and IPv6  separately, while the mpls ldp mldp yang data uses the list indexed by AF, so I am not sure which one is better.

  *
  *   For label instead of uint32 you should eventually use mpls-label from ietf-mpls.yang

  *
  *   For bfr-nbr you don’t need to have your own union of  ipv4-address and ipv6-address, use existing ip-address typedef from RFC6021

  *   The BIRT portion needs to be described in section 5, e.g. why that key was chosen etc etc. Not a BIER expert but I am not sure the routing table as modelled is complete/correct.
  *

[hfw] We can identify a BIRT entry if we use the three keys(sub-domain-id, bitstringlength, SI).

Regards.
Fangwei.

"Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>

2015-10-31 05:44

收件人
        "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
抄送
        "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, BIER <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahesh Sivakumar (masivaku)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
主题
        Re: [Bier] New Version Notification for draft-chh-bier-bier-yang-01.txt

Hi,

  *   bitstringlengthenum is defined in a couple of places, instead you should have a typedef and use that typedef for all your bitstringlength leaf nodes. There are also some bitstringlength leaf nodes which are of type uint16, I believe this is incorrect.
  *   Leaf SI, in description spell out the full name “Set identifier”.
  *   Might be good to have a type for BIER base types such as SI, sub-domain ID etc. YANG experts can advise you on this.
  *   For AF, my understanding is that recommendation is to have a list indexed by AF, so you could combine list ipv4 and list ipv6 into 1 list . Please take a look at draft-raza-mpls-ldp-mldp-yang-02 for an example.
  *   For label instead of uint32 you should eventually use mpls-label from ietf-mpls.yang
  *   For bfr-nbr you don’t need to have your own union of  ipv4-address and ipv6-address, use existing ip-address typedef from RFC6021
  *   The BIRT portion needs to be described in section 5, e.g. why that key was chosen etc etc. Not a BIER expert but I am not sure the routing table as modelled is complete/correct.

Regards,
Reshad.

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Friday, October 23, 2015 at 2:38 AM
To: Reshad <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, BIER <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahesh Sivakumar (masivaku)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] New Version Notification for draft-chh-bier-bier-yang-01.txt

Hi Reshad,
Thank you your comments.

Regards,
Ran

发件人:         "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
收件人:         "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
抄送:        "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahesh Sivakumar \(masivaku\)" <[email-masked]<mailto:[email-masked]>>
日期:         2015/10/22 22:10
主题:        Re: [Bier] New Version Notification for draft-chh-bier-bier-yang-01.txt
发件人:        "BIER" <[email-masked]<mailto:[email-masked]>>
________________________________

Hi,

Repeating the same comments as for 00, the 2 following comments still apply for sure

  *   Please follow RFC6087 guidelines e.g. use of <CODE BEGINS>, <CODE ENDS> etc
  *   <Ran>: OK. we will add it in next version. Thanks
  *   Finally, please use the validator @ http://www.yangvalidator.com/
  *   <Ran>:  Sure, we have used this validator, and have passed.Please see below:

Regards,
Reshad.

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 22, 2015 at 4:59 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahesh Sivakumar (masivaku)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Bier] New Version Notification for draft-chh-bier-bier-yang-01.txt

Hi all，
We have updated draft-chh-bier-bier-yang to 01 version.
The link is：  https://www.ietf.org/internet-drafts/draft-chh-bier-bier-yang-01.txt
Any comments and suggestion are welcome. Thanks.
Regards,
Ran

[email-masked]<mailto:[email-masked]> 写于 2015/10/19 10:27:13:

> 发件人:  [email-masked]<mailto:[email-masked]>
> 收件人:  "Xianxian Dai" <[email-masked]<mailto:[email-masked]>>,
> "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Zheng Zhang"
> <[email-masked]<mailto:[email-masked]>>, "fangwei hu" <[email-masked]<mailto:[email-masked]>>,
> "Fangwei Hu" <[email-masked]<mailto:[email-masked]>>, "Ran Chen"
> <[email-masked]<mailto:[email-masked]>>, "Mahesh Sivakumar" <[email-masked]<mailto:[email-masked]>>,
> "Zheng Zhang" <[email-masked]<mailto:[email-masked]>>, "Mahesh Sivakumar"
> <[email-masked]<mailto:[email-masked]>>, "Ran Chen" <[email-masked]<mailto:[email-masked]>>,
> 日期:  2015/10/19 10:27
> Status:         https://datatracker.ietf.org/doc/draft-chh-bier-bier-yang/
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-chh-bier-bier-yang-01
>
> Abstract:
> Please note that it may take a couple of minutes from the time of submission
-----来自 <[email-masked]<mailto:[email-masked]>> 的消息，在 Thu, 23 Jul 2015 20:46:17 +0800 -----
收件人:
        "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
抄送:
        "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, BIER <[email-masked]<mailto:[email-masked]>>
主题:
        Re: [Bier] Comments on draft-chh-bier-bier-yang-00

Hi, Rahman,

Regards
Fangwei.

"Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
发件人:  "BIER" <[email-masked]<mailto:[email-masked]>>

2015-07-23 19:43

收件人
        "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
抄送
        "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
主题
        [Bier] Comments on draft-chh-bier-bier-yang-00

Hi authors,

  *   I tried to pyang the model in the draft and ran into quite a few errors. I stopped after the 4 below (these are basic YANG errors, wasn’t even using strict/ietf option)
  *   Once you fix these errors please compile with ―ietf option (sricter rules regarding ordering of statements, requiring description etc etc)
  *   Please follow RFC6087 guidelines e.g. use of <CODE BEGINS>, <CODE ENDS> etc
  *   Finally, please use the validator @ http://www.yangvalidator.com/

Regards,
Reshad.

ERRORS

No “” for the contact
ietf-bier.yang:34: error: unterminated statement definition for keyword "contact", looking at L

Extra “ in "reference "draft-chen-bier-bier-yang-00”;
59: error: unterminated statement definition for keyword "reference", looking at d

Missing ; in key "sub-domain-id"
125: error: unterminated statement definition for keyword "key", looking at l

Missing ; in type if:interface-ref
154: error: unterminated statement definition for keyword "type", looking at }

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier
[附件 "ATT00002.txt" 被 陈然080434/user/zte_ltd 删除]_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier