Subject: Re: [Bier] DR election ...

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 10 Nov 2015 14:52:49 +0000

[ + PIM ]

Weiguo,

In the MC-LAG case, put aside BIER, how does it work today with PIM?

Jeffrey

From: Haoweiguo [mailto:[email-masked]]
Sent: Tuesday, November 10, 2015 7:19 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Robert Raszuk <[email-masked]>; IJsbrand Wijnands <[email-masked]>
Cc: [email-masked]
Subject: RE: [Bier] DR election ...

Hi Jeffrey,

There are two multi-homing scenarios, one is multi-homed network, another one is multi-homed device. For multi-homed network, the network is a LAN, DR/DF mechanism can be used to select one router as master and other routers as slave, only the master router can forward traffic to the LAN network, IGMP/MLD extension can be used for the DR/DF election, this is the focus of draft-wijnands-bier-mld-lan-election-00. However, if a multicast source or receiver is directly accessed to two multicast routers through MC-LAG, flow-based loadbalancing can be achieved for uplink direction traffic. In this case, IGMP/MLD can't be used for DR/DF election for the MC-LAG. I think the new DR/DF election mechanism should also cover the MC-LAG multi-homed scenario.

My two cents.

Thanks,

weiguo

________________________________
From: Jeffrey (Zhaohui) Zhang [[email-masked]]
Sent: Monday, November 09, 2015 23:08
To: Haoweiguo; Robert Raszuk; IJsbrand Wijnands
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Bier] DR election ...
Not exactly sure about the details of active-active or active-standby scenarios and their relationship to BIER, but here is my understanding:

- BIER architecture has three layers: multicast overlay, bier forwarding, and routing underlay. It is really the multicast overlay's job to handle the multi-homing - be it PIM, IGMP/MLD, or BGP, or any other things.
- While Ice's DR election draft was triggered from using IGMP/MLD to replace PIM for multicast overlay signaling in a BIER domain and the draft has some BIER keywords in it, it is really independent of BIER. The draft is still applicable if BIER had never happened.

Jeffrey

From: BIER [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Thursday, November 05, 2015 7:39 PM
To: Robert Raszuk <[email-masked]<mailto:[email-masked]>>; IJsbrand Wijnands <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] DR election ...

I agree with Robert's comments. I think BIER also should cover active-active and active-standby access scenarios.

Thanks,

weiguo

________________________________
From: BIER [[email-masked]] on behalf of Robert Raszuk [[email-masked]]
Sent: Friday, November 06, 2015 8:36
To: IJsbrand Wijnands
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Bier] DR election ...

Ice,

As we duscussed offline there are practically two major types of multihomed deployments in production networks:

1. True multihoming ... each edge router connect to CEs over different subnet

2. Active/standby .. there is multiaccess lan but VRRP is used so hosts can have single default out.

Now moreover beteen BIER domain and multicast senders and receivers there will pretty much always CEs. I am worried that most BIER slides skip those.

Cheers,
R.

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 10 Nov 2015 14:33:41 -0800

https://en.wikipedia.org/wiki/MC-LAG ???

Thats an L2 technology, PIM would neither know nor care.

If you're talking about eg: dual-PE or in general dual PIM routers
connecting to the same LAN, PIM DR/DF priority can follow VRRP/HSRP
priority to leverage their fast failover draft-zhou-pim-vrrp-03.

There is no load-splitting in this approach though, so only one
router is DR/DF. If you want load-balancing, you may want
draft-ietf-pim-drlb (currently expired, already had last call).

Toerless

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

-- 
---
Toerless Eckert, [email-masked]

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 10 Nov 2015 22:45:05 +0000

Neither should BIER care - or it's transparent to PIM/BIER ... that's my point.

> -----Original Message-----
> From: Toerless Eckert [mailto:[email-masked]]
> Sent: Tuesday, November 10, 2015 5:34 PM
> To: Jeffrey (Zhaohui) Zhang <[email-masked]>
> Cc: Haoweiguo <[email-masked]>; Robert Raszuk <[email-masked]>;
> IJsbrand Wijnands <[email-masked]>; [email-masked]; [email-masked]
> > To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Robert Raszuk
> <[email-masked]>; IJsbrand Wijnands <[email-masked]>
> > Cc: [email-masked]
> > There are two multi-homing scenarios, one is multi-homed network,
> another one is multi-homed device. For multi-homed network, the network is
> a LAN, DR/DF mechanism can be used to select one router as master and
> other routers as slave, only the master router can forward traffic to the
> LAN network, IGMP/MLD extension can be used for the DR/DF election, this
> is the focus of draft-wijnands-bier-mld-lan-election-00. However, if a
> multicast source or receiver is directly accessed to two multicast routers
> through MC-LAG, flow-based loadbalancing can be achieved for uplink
> direction traffic. In this case, IGMP/MLD can't be used for DR/DF election
> for the MC-LAG. I think the new DR/DF election mechanism should also cover
> the MC-LAG multi-homed scenario.
> >
> > My two cents.
> >
> > Thanks,
> >
> > weiguo
> >
> > Not exactly sure about the details of active-active or active-standby
> scenarios and their relationship to BIER, but here is my understanding:
> >
> > - BIER architecture has three layers: multicast overlay, bier forwarding,
> and routing underlay. It is really the multicast overlay's job to handle
> the multi-homing - be it PIM, IGMP/MLD, or BGP, or any other things.
> > - While Ice's DR election draft was triggered from using IGMP/MLD to
> replace PIM for multicast overlay signaling in a BIER domain and the draft
> has some BIER keywords in it, it is really independent of BIER. The draft
> is still applicable if BIER had never happened.
> >
> > Jeffrey
> >
> > To: Robert Raszuk <[email-masked]<mailto:[email-masked]>>;
> IJsbrand Wijnands <[email-masked]<mailto:[email-masked]>>
> > I agree with Robert's comments. I think BIER also should cover active-
> active and active-standby access scenarios.
> >
> > Thanks,
> >
> > weiguo
> >
> > As we duscussed offline there are practically two major types of
> multihomed deployments in production networks:
> >
> > Now moreover beteen BIER domain and multicast senders and receivers
> there will pretty much always CEs. I am worried that most BIER slides skip
> those.
> >
> > Cheers,
> > R.
>