Subject: [Bier] comments on draft-zwzw-bier-prefix-redistribute

From: Tony Przygienda <[email-masked]>
Date: Mon, 19 Mar 2018 13:18:13 +0000

Read with interest draft-zwzw-bier-prefix-redistribute. Comments

1. Figure 2 is mildly confusing. Where is area 0? Once we have area 0 the
current OSPF RFC (upcoming) is already dealing with redistribution within
OSPF. So I think a realistic problem is redistributing from OSPF into ISIS
or vice versa (or multiple instances of OSPF/ISIS edge/core facing) ...
2. The really hard problem of how to prevent redistribution loops is not
tackled. As long we assume a star topology the tie-breaking is trivial but
when e.g. two ASBRs from two different OSPF areas attach to ISIS we already
have a problem and even worse if spokes have e.g. ASBR shortcuts to prevent
going through the backbone. And what happens if two different protocols
pick up same BFR-id or advertise conflicting information. Basically we need
a DV/PV protocol to make that work in generic sense.
3. Alternately we could introduce the concept of a proxy-BFR that
advertises a BFR-id into two subdomains and forwards between them but I
think when this is thought through it will looks like PMSI stitching and
with that implode into MVPN overlay solution doing inter-domain multicast.

Let's see the discussion on the floor

--- tony

---

From: Zhang Z <[email-masked]>
Date: Mon, 19 Mar 2018 14:53:27 +0000

Hi Tony,

Thank you for your comments. Please see in line.

Thanks,
Sandy
________________________________
发件人: BIER <[email-masked]> 代表 Tony Przygienda <[email-masked]>
发送时间: 2018年3月19日 21:18:13
收件人: BIER WG
主题: [Bier] comments on draft-zwzw-bier-prefix-redistribute

1. Figure 2 is mildly confusing. Where is area 0? Once we have area 0 the current OSPF RFC (upcoming) is already dealing with redistribution within OSPF. So I think a realistic problem is redistributing from OSPF into ISIS or vice versa (or multiple instances of OSPF/ISIS edge/core facing) ...

Sandy: There's no OSPF area 0 but ISIS level-2 area instead of it. ABRs translate the routing info from ISIS to OSPF or vice versa, such as R3, R4.

2. The really hard problem of how to prevent redistribution loops is not tackled. As long we assume a star topology the tie-breaking is trivial but when e.g. two ASBRs from two different OSPF areas attach to ISIS we already have a problem and even worse if spokes have e.g. ASBR shortcuts to prevent going through the backbone. And what happens if two different protocols pick up same BFR-id or advertise conflicting information. Basically we need a DV/PV protocol to make that work in generic sense.

Sandy: The bfr-id conflicting is a general problem but sure it may be more terrible when two different protocols are used. We will consider it in next version.

3. Alternately we could introduce the concept of a proxy-BFR that advertises a BFR-id into two subdomains and forwards between them but I think when this is thought through it will looks like PMSI stitching and with that implode into MVPN overlay solution doing inter-domain multicast.

Sandy: Yes. It looks like PMSI stitching but the forwarding plane can't be builded if underlay protocol doesn't take part in.

--- tony