Subject: [Bier] Call for adoption: draft-zzhang-algorithms

From: Greg Shepherd <[email-masked]>
Date: Tue, 27 Mar 2018 14:03:54 -0700

We had solid support in London to adopt  draft-zzhang-algorithms as a WG
item. Please respond to this thread with/without your support to adopt:

https://datatracker.ietf.org/doc/draft-zzhang-bier-algorithm/

Thanks,
Greg
(Chairs)

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 27 Mar 2018 14:49:21 -0700

support

On Tue, Mar 27, 2018 at 2:03 PM, Greg Shepherd <[email-masked]> wrote:

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>
>

---

From: <[email-masked]>
Date: Wed, 28 Mar 2018 08:24:14 +0800 (CST)

Support.

Thanks,

Sandy

原始邮件

发件人：GregShepherd <[email-masked]>
收件人：BIER WG <[email-masked]>
日 期 ：2018年03月28日 05:04
主 题 ：[Bier] Call for adoption: draft-zzhang-algorithms

We had solid support in London to adopt  draft-zzhang-algorithms as a WG item. Please respond to this thread with/without your support to adopt:

Thanks,
Greg
(Chairs)

---

From: Xiejingrong <[email-masked]>
Date: Wed, 28 Mar 2018 02:00:22 +0000

I am opposed to the adoption of this draft.

For the draft raised a lot of problems, and only mentioned the possibility of using some algorithm to solve, but I am not sure how could such algorithm could solve such problems.

Is this draft a problem statement ? or an architecture of using BIER specific algorithms ? or a protocol extension ?

On the other hand, <draft-xie-bier-mvpn-mpls-p2mp> had raised some detail methods to solve the same problems mentioned in the draft.

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Wednesday, March 28, 2018 5:04 AM
To: BIER WG <[email-masked]>
Subject: [Bier] Call for adoption: draft-zzhang-algorithms

Thanks,
Greg
(Chairs)

---

From: "Dolganow, Andrew (Nokia - SG/Singapore)" <[email-masked]>
Date: Wed, 28 Mar 2018 04:09:07 +0000

support

From: BIER <[email-masked]> on behalf of Greg Shepherd <[email-masked]>
Reply-To: Greg Shepherd <[email-masked]>
Date: Wednesday, March 28, 2018 at 5:04 AM
To: BIER WG <[email-masked]>
Subject: [Bier] Call for adoption: draft-zzhang-algorithms

Thanks,
Greg
(Chairs)

---

From: IJsbrand Wijnands <[email-masked]>
Date: Wed, 28 Mar 2018 08:55:54 +0200

Dear WG,

I believe this draft is not ready for WG adoption.

4.1 Handling BIER incapable routers is something that can also be solved by depending on a unicast underlay that provides this support (ie Flex Algo). So its not at all clear that a BAR value of 1 is the best way to go forward. Its likely we’ll end up with two different ways to solve this problem in IETF.

4.1 The example of bypassing BIER incapable routers is weak, I think tunnelling through a non-BIER capable router is a much more realistic deployment scenario.

4.2 Computing a Maximum Disjoint Tree is also something that can be done through Flex-Algo. In many networks, a MDT is also required for unicast, so BIER and unicast can share the same underlay. Much more details need to be added to this section in order to do a comparison with FA and determine which is the better way to go forward.

4.3 This section requires much more details and its unclear (to me) this is a problem we need to solve.

4.4 This section also needs much more details. BIER-TE has scale limitation due to the number of BP’s, but solving it through BIER and BAR may not scale either. It all depends on how many sub-topologies are needed. With BIER the limitation is the number of Sub-Domains.

So I agree with xiejingrong, its not clear this draft is a use-case document or an actual solutions draft. It certainly missed a lot of details to be the latter.

Thx,

Ice.

> On 27 Mar 2018, at 23:03, Greg Shepherd <[email-masked]> wrote:
>

---

From: Senthil Dhanaraj <[email-masked]>
Date: Wed, 28 Mar 2018 12:19:28 +0000

Not Support.

I understand that this draft proposes a set of new BAR algorithms.
However, I see that most of the details/solutions about the algorithm itself is yet to be explained clearly.

Should we wait for the authors to update the draft with more details which would allow the WG members to discuss further on the solutions/algorithms proposed?

Thanks,
Senthil

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: 28 March 2018 02:34
To: BIER WG <[email-masked]>
Subject: [Bier] Call for adoption: draft-zzhang-algorithms

Thanks,
Greg
(Chairs)

---

From: syed arish <[email-masked]>
Date: Wed, 28 Mar 2018 12:41:44 +0000

Without Support

I think we should have some details about BAR algorithms in place before
adopting it.

Thanks
 Arish

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 28 Mar 2018 17:42:52 +0300

Hi,
decision whether to support WG adoption of a draft can be drawn by
answering three questions:

   - does the draft addresses practical problem that the WG is
   interested/should work on
   - is the proposed solution technically viable
   - is the draft reasonably well-written, i.e. can be read and understood

Here are my view of the draft called for the WG adoption:

   - draft proposes creation of IANA registry - right step; draft proposes
   directions to handle BAR-wise heterogeneous BIER environment - timely
   proposal;
   - proposed solutions are technically viable
   - I was able to read and, hopefully, understand the draft.

Hence, I support the adoption

Regards,
Greg

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 28 Mar 2018 16:30:25 +0000

Oppose.

I am quite surprised that an adoption call is being requested at this time.

The document as it exists is a placeholder for things which will be discussed in (to quote the draft) “future versions”.
So the substance of the draft is still TBD. Why then would we consider this ready for WG adoption?

I would agree that the draft mentions problems of interest to the WG – but this is just the beginning. Please continue to work on/discuss the problems mentioned in the draft. I would expect at some future time there would be enough substance/consensus for the WG to consider that the solutions defined in some future revision are on the right track and deserve WG status – but this is much too early to consider WG adoption.

    Les

From: BIER <[email-masked]> On Behalf Of Greg Shepherd
Sent: Tuesday, March 27, 2018 2:04 PM
To: BIER WG <[email-masked]>
Subject: [Bier] Call for adoption: draft-zzhang-algorithms

Thanks,
Greg
(Chairs)

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 28 Mar 2018 09:36:04 -0700

Quick observation only

On Tue, Mar 27, 2018 at 11:55 PM, IJsbrand Wijnands <[email-masked]> wrote:

> 4.1 Handling BIER incapable routers is something that can also be solved
> by depending on a unicast underlay that provides this support (ie Flex
> Algo). So its not at all clear that a BAR value of 1 is the best way to go
> forward. Its likely we’ll end up with two different ways to solve this
> problem in IETF.
>
> 4.1 The example of bypassing BIER incapable routers is weak, I think
> tunnelling through a non-BIER capable router is a much more realistic
> deployment scenario.
>

Ice, it's probably a grave misunderstanding here if the draft has been read
as "BAR=1" is _the_ solution for non-congruent topologies or even _the best
solution_. That was never intended to be the intention or claim. It is
suggested as just one of possibilities with its own set of
advantages/disadvantages/preconditions  just as a pure MT solution is e.g.
(which does not need any extensions or additional technologies at all and
is already "baked into BIER") ...

In fact multiple solutions to solve brown-field/non-congruent topologies
are needed from having had extensive discussions about BIER deployment
scenarios with interested parties. It all depends on a wide set of
preconditions customers have or are willing to deploy in their networks and
what they consider a viable operational solution under their set of
constraints/preferences/timelines. So I don't think talking about a best
solution for everyone and every scenario is even meaningful.

4.2 Computing a Maximum Disjoint Tree is also something that can be done
> through Flex-Algo. In many networks, a MDT is also required for unicast, so
> BIER and unicast can share the same underlay. Much more details need to be
> added to this section in order to do a comparison with FA and determine
> which is the better way to go forward.
>

Correct, again, this draft never intended to claim that it is the only or
best solution and as you say multiple are needed. I would agree that
multiple solutions for Live-Live should be described (I see at least three
each with their own set of trade-offs ;-) and compared and the customers
will decide what their operational preferences are ...

So, I hope in both cases we'll have multiple solutions described and some
kind of framework for customers to understand what kind of advantages they
get with each one while understanding the preconditions to deploy it
successfully.

I leave the BIER-TE, controller use cases and so on out this discussion ...

--- tony

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 28 Mar 2018 09:41:33 -0700

On Wed, Mar 28, 2018 at 9:30 AM, Les Ginsberg (ginsberg) <[email-masked]
> wrote:

Why? The room showed support, so we take it to the list. It's this process
that triggers these discussions. If the call hadn't been made, this thread
allowing everyone to voice their concerns in one place wouldn't exist. :-)

Greg

> The document as it exists is a placeholder for things which will be
> discussed in (to quote the draft) “future versions”.
>
> I would agree that the draft mentions problems of interest to the WG – but
> this is just the beginning. Please continue to work on/discuss the problems
> mentioned in the draft. I would expect at some future time there would be
> enough substance/consensus for the WG to consider that the solutions
> defined in some future revision are on the right track and deserve WG
> status – but this is much too early to consider WG adoption.
>
>
>
>     Les
>
>
>
>
>
> *From:* BIER <[email-masked]> *On Behalf Of *Greg Shepherd
> *Sent:* Tuesday, March 27, 2018 2:04 PM
> *To:* BIER WG <[email-masked]>
> *Subject:* [Bier] Call for adoption: draft-zzhang-algorithms
>
>
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 28 Mar 2018 16:55:13 +0000

Greg –

I am not questioning the process.
You had sufficient input from the room to justify asking the question.

My surprise is that the authors of the draft thought this was the right time to ask.

Peace.

   Les

From: Greg Shepherd <[email-masked]>
Sent: Wednesday, March 28, 2018 9:42 AM
To: Les Ginsberg (ginsberg) <[email-masked]>
Cc: BIER WG <[email-masked]>
Subject: Re: [Bier] Call for adoption: draft-zzhang-algorithms

On Wed, Mar 28, 2018 at 9:30 AM, Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>> wrote:
Oppose.

Why? The room showed support, so we take it to the list. It's this process that triggers these discussions. If the call hadn't been made, this thread allowing everyone to voice their concerns in one place wouldn't exist. :-)

Greg

    Les

From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Greg Shepherd
Sent: Tuesday, March 27, 2018 2:04 PM
To: BIER WG <[email-masked]<mailto:[email-masked]>>
Subject: [Bier] Call for adoption: draft-zzhang-algorithms

Thanks,
Greg
(Chairs)