Subject: [Bier] [bier] Question regarding BAR-IPA in BIER-OSPF /BIER-ISIS

From: Xiejingrong <[email-masked]>
Date: Tue, 6 Mar 2018 13:15:06 +0000

Hi folks,

draft-ietf-bier-isis-extensions
   IPA  IGP Algorithm.  May be used to modify, enhance or replace the //It seems that, IPA AlGorithm  have a higher priority than BAR ?
      calculation of underlay paths as defined by the BAR value

   IPA  IGP algorithm.  Specifies an IGP Algorithm to either modify,
      enhance or replace the calculation of underlay paths to reach  //It seems that, IPA AlGorithm have a higher priority than BAR ?
      BFERs as defined by the BAR value.  Values are from the IGP
      Algorithm registry. 1 octet

draft-ietf-bier-ospf-bier-extensions-15.txt
      IPA: Single octet IGP algorithm to either modify, enhance or   //It seems that, IPA AlGorithm have a higher priority than BAR ?
      replace the calculation of underlay paths to reach other BFRs as
     defined by the BAR value.  Values are defined in the "IGP
      Algorithm Types" registry.

As my understanding to the above text about IPA, IPA AlGorithm(caculation) seems to have a higher priority than BAR, so it can modify/enhance/replace BAR AlGorithm(calculation).
But in <draft-zzhang-bier-bar-ipa-00>, It seems to be clear that, BAR AlGorithm always has a higher priority, because once BAR is Non-Zero, AlGorithm always select BAR.
3. Select the algorithm AG as following:
A. If BA is NULL, AG is set to RA.
B. If BA is not NULL, AG is set to BA. ---> this seems to mean BAR AG has a higher prio

I am a little confused. Is there something wrong or just a language mis-understanding?

Thanks,
XieJingrong

---

From: Xiejingrong <[email-masked]>
Date: Tue, 6 Mar 2018 13:28:26 +0000

Sorry, I take back my question.
I think I understand it.
Even when BAR is fixed, the calculation can still be modified/enhanced/replaced by using a different IPA/RC.

Calculation is a great word.

Xiejingrong

From: BIER [mailto:[email-masked]] On Behalf Of Xiejingrong
Sent: Tuesday, March 06, 2018 9:15 PM
To: [email-masked]
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]>
Subject: [Bier] [bier] Question regarding BAR-IPA in BIER-OSPF /BIER-ISIS

Hi folks,

Thanks,
XieJingrong