Subject: [Bier] Comments on draft-venaas-bier-mtud-02

From: Xiejingrong <[email-masked]>
Date: Sat, 27 Oct 2018 06:52:49 +0000

Hi,

I read out the 3 building blocks in this draft, and I think they are helpful for BIER deployment.
1. A bottom value configured or defaut to make the MTU at least no worse than static configured.
2. A simple/big-grain discovery of per-subdomain MTU by simple per-subdomain TLV for BIER specific usage.
3. A Warning of mis-configuration for administrators to avoid silent error.

Some comments are:
1. I think one of the real usage of this mechanism are useful for BFIR (to leverage the possible bigger MTU discovered). To quote of the 'requirement' defined in RFC8279 as a use-case may be useful.
    Each BFIR is expected to know the Maximum Transmission Unit (MTU) of
    the BIER domain.  This may be known by provisioning, or by some other
    method outside the scope of this document.
2. I think the document is not mean to leverage the bigger MTU (than the default for example) outside of the BIER-domain. For example, to notice the user-side link to use bigger packets.
   There are some words in abstract. And again similar to above, list of the un-intended use-case (that is esay to be confused) may be helpful too.

---

From: Xiejingrong <[email-masked]>
Date: Sat, 27 Oct 2018 07:53:31 +0000

s/RFC8279/RFC8296

From: Xiejingrong
Sent: Saturday, October 27, 2018 2:53 PM
To: [email-masked]
Subject: Comments on draft-venaas-bier-mtud-02

Hi,

Some comments are: