Subject: [Bier] WGLC: draft-ietf-bier-bar-ipa

From: Greg Shepherd <[email-masked]>
Date: Tue, 16 Oct 2018 07:55:08 -0700

Today starts a WGLC two week timer for:

https://tools.ietf.org/html/draft-ietf-bier-bar-ipa-02

Please read and respond to this thread with/without support.

Thanks,
Shep
(Chairs)

---

From: Stig Venaas <[email-masked]>
Date: Tue, 16 Oct 2018 14:22:43 -0700

Hi

I think the draft needs a little bit more work before publication.

It's not clear to me what the contents of the BAR and IPA fields are.

For BAR you say that it is BCBA and that for the currently defined
algorithm 0, BC and BA are both NULL. But if new BIER algorithms are
defined, how would you define BC? Is the idea that the values in the
BIER algorithm registry signify both BC and BA? In that case the name
is misleading.

For IPA it is also not clear how you specify RC for the different
values of RA. The existing registry only specifies the RA.

In section 1 it says:
   [To be added]
Will anything be added here?

In section 2 it says:

   In [RFC8401] and [I-D.ietf-bier-ospf-bier-extensions], an 8-bit BAR
   field and 8-bit IPA field are defined to signal the BIER specific
   algorithm and generic IGP Algorithm respectively and only value 0 is
   allowed for both fields currently.  This document specifies the
   general rules for the two fields and their interaction when either or
   both fields are not 0.

I think the term "currently" will be confusing once this becomes an RFC.
"Currently" here talks about the situation prior to the publication of the
RFC, it would no longer be true after publication.

Typo in the title.

Typo: multit-topolgy

Stig

On Tue, Oct 16, 2018 at 7:55 AM Greg Shepherd <[email-masked]> wrote:
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 26 Oct 2018 15:34:34 +0000

Hi Stig,

> -----Original Message-----
> From: BIER <[email-masked]> On Behalf Of Stig Venaas
> Sent: Tuesday, October 16, 2018 5:23 PM
> To: Greg Shepherd <[email-masked]>
> Cc: BIER WG <[email-masked]>
> Subject: Re: [Bier] WGLC: draft-ietf-bier-bar-ipa
> 
> Hi
> 
> BIER algorithm registry signify both BC and BA?

Yes when a new value is defined, corresponding BC & BA semantics need to be given. I will clarify that.

> In that case the name is misleading.

Is it "misleading" in that RFC8401 says " BAR:  BIER Algorithm" while here we're saying it's constraint plus algorithm?

> values of RA. The existing registry only specifies the RA.

We all agreed that "IPA" is the IGP Algorithm which could be a Flexible algorithm.
What draft-ietf-lsr-flex-algo calls a flexible algorithm also is really a combination of constraints and "algorithm" (or calculation-type) :-)

   The set consisting of (a) calculation-type, (b) metric-type and (c) a
   set of constraints is referred to as a Flexible-Algorithm Definition.

   Flexible-Algorithm is a numeric identifier in the range 128-255 that
   is associated via provisioning with the Flexible-Algorithm
   Definition.

   IANA "IGP Algorithm Types" registry defines the set of values for IGP
   Algorithms.  We propose to allocate the following values for Flex-
   Algorithms from this registry:

      128-255 - Flex-Algorithms

So I perhaps we could go a little easy here :-)

> Will anything be added here?

Wow - that's embarrassing :-) Will add and post a new revision.
 
> RFC, it would no longer be true after publication.

You're right. How about "in those two documents"?

> Typo: multit-topolgy

Thanks! Will fix.

Jeffrey

> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Dbier-2Dbar-2Dipa-
> 2D02&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=uNIw3ToxQY1ZhO84imJM9czs-
> 8fEmjuqCxiqvu6ciEY&s=9Up4dsFxMx0w5cbbj5c7DKimcRHUXcjL7EQw6mygnp
> A&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bier&d=DwICAg&c=HAkYuh63rsuhr6Scbf
> h0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=uNIw3ToxQY1ZhO84imJM9czs-
> 8fEmjuqCxiqvu6ciEY&s=TcDDTfwL4a4v6qxlh7BvKbIsDtm-
> WeF4RR8xqjpAIag&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bier&d=DwICAg&c=HAkYuh63rsuhr6Scbf
> h0UjBXeMK-
> ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&
> m=uNIw3ToxQY1ZhO84imJM9czs-
> 8fEmjuqCxiqvu6ciEY&s=TcDDTfwL4a4v6qxlh7BvKbIsDtm-
> WeF4RR8xqjpAIag&e=