Subject: [Bier] BIER IPv6 Requirement

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Thu, 20 Aug 2020 07:14:07 +0000

Hi Mike, authors and WG,

I have read through the existing version of draft-ietf-bier-ipv6-requirements and the comments in the mailing list.  The concerns for this document mainly comes from three aspects:

1.       The problem statement: why we need BIER IPv6 solution (which I think is straight forward: we need solution(s) to deploy BIER in an IPv6 domain)

2.       The conceptual model for BIER IPv6 encapsulation (the existing model classification seems to be roughly agreed in the WG but the descriptions should be modified based on the comments)

3.       The requirement items and classification

I think the previous two points mainly request editing work and a document with some my personal recommended text could be found in the attachment just for your reference.
For the third point, I list the requirement items based on the existing discussions in the WG as follows:
Mandatory:

?   L2 Agnostic (may be removed)

?   Align to BIER architecture defined in RFC8279 (may be removed)

?   Support deployment with Non-BFR routers

?   Support OAM

?   Support overlay service, e.g., MVPN, EVPN
Optional:

?   Support native IPv6 functions, e.g., IPSEC, Fragmentation

?   Support inter-AS multicast deployment

?   Provide necessary security methods (may be removed)

I suggest to discuss and confirm these items in WG first, including what should be included/excluded, which one should be mandatory etc., then we could work on the detailed explanations for each item.

Best Regards
Xuesong

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 20 Aug 2020 11:52:47 -0400

Hi Xuesong

I am working on an update I will be posting to GitHub using Mikes version.

The main item I am updating is clarifying the BIER layers definition In the
drawing and verbiage with the three layers so it’s crystal clear that we
discussed in our understanding discussion.

Their were some comments that Alvaro mentioned so I am trying to address
some of those as well.

I will be completed tomorrow and then you can update the draft with
comments.

Mike has a -mm version that I am building on in GitHub link below.

 https://github.com/mmcbride7/bier-v6-requirements

Thanks

Gyan

On Thu, Aug 20, 2020 at 3:14 AM Gengxuesong (Geng Xuesong) <
[email-masked]> wrote:

>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> Hi Mike, authors and WG,
>
>
>
>
>
> I have read through the existing version of
> draft-ietf-bier-ipv6-requirements and the comments in the mailing list.
> The concerns for this document mainly comes from three aspects:
>
>
>
>
> 1..
>
> The problem statement: why we need BIER IPv6 solution (which I think is
> straight forward: we need solution(s) to deploy BIER in an IPv6 domain)
>
>
>
>
> 2..
>
> The conceptual model for BIER IPv6 encapsulation (the existing model
> classification seems to be roughly agreed in the WG but the descriptions
> should be modified based on the comments)
>
>
>
>
> 3..
>
> The requirement items and classification
>
>
>
>
>
>
> I think the previous two points mainly request editing work and a document
> with some my personal recommended text could be found in the attachment
> just for your reference.
>
>
> *Mandatory:*
> Ÿ
> L2 Agnostic (may be removed)
>
>
>
>
> Ÿ
>
> Align to BIER architecture defined in RFC8279 (may be removed)
>
>
>
>
> Ÿ
>
> Support deployment with Non-BFR routers
>
>
>
>
> Ÿ
>
> Support OAM
>
>
>
>
> Ÿ
>
> Support overlay service, e.g., MVPN, EVPN
>
>
> *Optional:*
>
>
>
>
> Ÿ
>
> Support native IPv6 functions, e.g., IPSEC, Fragmentation
>
>
>
>
> Ÿ
>
> Support inter-AS multicast deployment
>
>
>
>
> Ÿ
>
> Provide necessary security methods (may be removed)
>
>
>
>
>
> I suggest to discuss and confirm these items in WG first, including what
> should be included/excluded, which one should be mandatory etc., then we
> could work on the detailed explanations for each
>
> item.
>
>
>
>
>
> Best Regards
>
>
> Xuesong
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
>
> BIER mailing list
>
> [email-masked]
>
> https://www.ietf.org/mailman/listinfo/bier
>
> --

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 20 Aug 2020 12:08:10 -0400

Mike

I am using your -mm version as the base version as you sand then creating a
new -gsm version and a full aggregate version called -final.

That way anyone else Xuesong, Jingrong and other authors can create their
version and then also update the -final version so we have incremental
updates as well as full final version so we can easily make incremental
author changes and finalize the “-final“ version.

Thanks

Gyan

On Thu, Aug 20, 2020 at 11:52 AM Gyan Mishra <[email-masked]> wrote:

> The main item I am updating is clarifying the BIER layers definition In
> the drawing and verbiage with the three layers so it’s crystal clear that
> we discussed in our understanding discussion.
>
>> I think the previous two points mainly request editing work and a
>> document with some my personal recommended text could be found in the
>> attachment just for your reference.
>>
>>

*Gyan Mishra*

---

From: Greg Shepherd <[email-masked]>
Date: Thu, 20 Aug 2020 12:55:11 -0700

I had comments from a previous thread that need to be considered as well. 

Shep

Sent from my iPhone

> On Aug 20, 2020, at 08:53, Gyan Mishra <[email-masked]> wrote:
> 
> 
> Hi Xuesong 
> 
> The main item I am updating is clarifying the BIER layers definition In the drawing and verbiage with the three layers so it’s crystal clear that we discussed in our understanding discussion.
> 
> Their were some comments that Alvaro mentioned so I am trying to address some of those as well.
> 
> I will be completed tomorrow and then you can update the draft with comments.  
> 
>> On Thu, Aug 20, 2020 at 3:14 AM Gengxuesong (Geng Xuesong) <[email-masked]> wrote:
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> Hi Mike, authors and WG,
>> 
>> 
>> 
>>  
>> 
>> 
>> 
>> I have read through the existing version of draft-ietf-bier-ipv6-requirements and the comments in the mailing list..  The concerns for this document mainly comes from three aspects:
>> 
>> 
>> 
>> 
>> 
>> 1..      
>> 
>> The problem statement: why we need BIER IPv6 solution (which I think is straight forward: we need solution(s) to deploy BIER in an IPv6 domain)
>> 
>> 
>> 
>> 
>> 
>> 2..      
>> 
>> The conceptual model for BIER IPv6 encapsulation (the existing model classification seems to be roughly agreed in the WG but the descriptions should be modified based on the comments)
>> 
>> 
>> 
>> 
>> 
>> 3..      
>> 
>> I suggest to discuss and confirm these items in WG first, including what should be included/excluded, which one should be mandatory etc., then we could work on the detailed explanations for each
>> 
>> item.
>> 
>> 
>> 
>>  
>> 
>> 
>> 
>> Best Regards
>> 
>> 
>> 
>> Xuesong
>> 
>> 
>> 
>>  
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
> Gyan Mishra
> Network Solutions Architect 
> M 301 502-1347
> 13101 Columbia Pike 
> Silver Spring, MD
>

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 20 Aug 2020 16:22:24 -0400

Yes will do.

Thanks

Gyan

On Thu, Aug 20, 2020 at 3:55 PM Greg Shepherd <[email-masked]> wrote:

> <https://github..com/mmcbride7/bier-v6-requirements>
>
> Thanks
>
> Gyan
>
>
>
>> draft-ietf-bier-ipv6-requirements and the comments in the mailing list..

-- 

*Gyan Mishra*

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 21 Aug 2020 01:53:35 +0000

Hi Gyan,

Sure, thanks for your work!
I will also go back to the previous comments from Greg to consider what could be modified.

Best Regards
Xuesong

From: Gyan Mishra [mailto:[email-masked]]
Sent: Friday, August 21, 2020 4:22 AM
To: Greg Shepherd <[email-masked]>
Cc: Gengxuesong (Geng Xuesong) <[email-masked]>; [email-masked]; Mike McBride <[email-masked]>; [email-masked]
Subject: Re: [Bier] BIER IPv6 Requirement

Yes will do.

Thanks

Gyan

On Thu, Aug 20, 2020 at 3:55 PM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
I had comments from a previous thread that need to be considered as well.

Shep
Sent from my iPhone

On Aug 20, 2020, at 08:53, Gyan Mishra <[email-masked]<mailto:[email-masked]>> wrote:

Hi Xuesong

 https://github.com/mmcbride7/bier-v6-requirements<https://github..com/mmcbride7/bier-v6-requirements>

Thanks

Gyan

On Thu, Aug 20, 2020 at 3:14 AM Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mike, authors and WG,

1..

2..

3..

Mandatory:

•

•

•

•

Support OAM

•

Optional:

•

•

•

item.

Best Regards

Xuesong

BIER mailing list

[email-masked]<mailto:[email-masked]>

[图像已被发件人删除。]<http://www.verizon.com/>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

--

[图像已被发件人删除。]<http://www.verizon.com/>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD