Subject: [Bier] What is Slice Aggregate?

From: Lizhenbin <[email-masked]>
Date: Tue, 9 Nov 2021 13:34:47 +0000

Hi authors of draft-ietf-teas-ietf-network-slices,

The authors of the draft draft-zzhang-bier-slicing-and-differentiation-00 mentioned in the draft:
"
   [I-D.bestbar-teas-ns-packet] introduces the notion of Slice Aggregate
   which comprises of one of more IETF network slice traffic streams.  A
   Slice Aggregate is identified by a Slice Selector (SS), and packets
   carry the SS so that associated forwarding treatment or S-PHB (Slice
   policy Per Hop Behavior - the externally observable forwarding
   behavior applied to a specific packet belonging to a slice aggregate)
   - can be applied along the path.
"
"
   The authors of this document believe that the IETF Network Slicing
   framework, when augmented by the Slice Aggregate, addresses the APN
   problem domain very well.
"

According to the past discussion, we think the slice aggregate means the underlay slice, that is the new terminology "network resource partition".
If so, the Slice Selector should be the identifier of the network resource partition. But according to the draft-zzhang-bier-slicing-and-differentiation-00,
the slice aggregate can be augmented to address the APN problem. In the recently published draft draft-li-apn-header-00, the APN attribute is defined
including the APN ID (user group/application group) the packet belongs to , the Intent and APN parameters applied to the packet. It is apparent these
attributes are totally different from the identifier of the underlay slice.

Can you clarify the following about the slice aggregate:
1. What is slice aggregate? Is it the underlay network slice, the APN attribute-like parameters, both or other identifier? Or can it be all possible identifiers to identify a flow?
2. What is the usage of the slice aggregate in the draft-ietf-teas-ietf-network-slices if it is not the network resource partition any more? Is it introduced a new identifier to identify a flow?
3. What is the scope of the slice aggregate work in the TEAS WG if it is a new identifier other than the resource partition? Will you go on to define the encapsulation and the
protocol extensions for the new identifier or augment it to address the APN problem?

Best Regards,
Robin

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 18:49:59 +0100

I think a slice aggregate is a pizza

Sorry... to much serious IETF work, i just could not let that opportunity go,
but i am sure you could upsell the idea especially to the BIER-WG if you came
up with a way how the technology could be abbreviated PIZZA ;-)

Please carry on.

Toerless

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier