Subject: [Bier] BIER slicing & flex algo

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 11 Nov 2021 20:54:42 +0000

Hi Xuesong, Sandy,

I thought you were referring to some BIER+FlexAlgo draft - I could only find this https://datatracker.ietf.org/doc/html/draft-nainar-bier-flex-algo-00 but that does not seem to be what you were referring to.

Anyway, the BIER slicing draft should work well with flex algo - each SA (for one or a set of slices) would have a corresponding FlexAlgo and maps to a BIRT. In fact, after looking at the following in RFC 8401:

        0                   1                   2                   3
        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |    Type       |   Length      |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |   BAR         |    IPA        | subdomain-id  |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |     BFR-id                    |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |  sub-sub-TLVs (variable)                                      |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

I don't think we need the signaling extensions mentioned the BIER slicing draft. The "IPA" field above will identify the flex algo number used for an SA. We just need to allow multiple sub-TLVs of the above for the same subdomain (currently not allowed in RFC8401) and make sure that different IPAs will lead to different BIRTs.

Jeffrey

  Juniper Business Use Only

---

From: <[email-masked]>
Date: Fri, 12 Nov 2021 14:26:41 +0800 (CST)

Hi Jeffrey, 
Yes. The draft "draft-nainar-bier-flex-algo-00" was I talked about in yesterday meeting. 
And I agree with you, the IPA can be set to the FA-ID, and the SA infomation can be carried in the sub-TLV.
Thanks, 
Sandy

------------------原始邮件------------------
发件人：Jeffrey(Zhaohui)Zhang
收件人：Gengxuesong (Geng Xuesong);张征00007940;
抄送人：[email-masked];
日 期 ：2021年11月12日 04:55
主 题 ：BIER slicing & flex algo

Hi Xuesong, Sandy,

0                   1                   2                   3

I don’t think we need the signaling extensions mentioned the BIER slicing draft. The “IPA” field above will identify the flex algo number used for an SA. We just need to allow multiple sub-TLVs of the above for the same subdomain (currently not allowed in RFC8401) and make sure that different IPAs will lead to different BIRTs.

Jeffrey